# Help us improve the Elastic Stack by providing basic feature usage statistics? We will never share this data outside of Elastic

**URL:** <https://discuss.elastic.co/t/help-us-improve-the-elastic-stack-by-providing-basic-feature-usage-statistics-we-will-never-share-this-data-outside-of-elastic/202149>\
**Category:** Kibana\
**Created:** [October 3, 2019, 10:30am UTC](https://discuss.elastic.co/t/help-us-improve-the-elastic-stack-by-providing-basic-feature-usage-statistics-we-will-never-share-this-data-outside-of-elastic/202149 "2019-10-03T10:30:21Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![carel.lubbe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carel.lubbe/32/51359_2.png) [@carel.lubbe](https://discuss.elastic.co/u/carel.lubbe)\
**Post date:** [October 3, 2019, 10:30am UTC](https://discuss.elastic.co/t/help-us-improve-the-elastic-stack-by-providing-basic-feature-usage-statistics-we-will-never-share-this-data-outside-of-elastic/202149/1 "2019-10-03T10:30:21Z")

</div>

I have upgraded my system to the latest versions in the RedHat repos... since then i have the message "Help us improve the Elastic Stack by providing basic feature usage statistics? We will never share this data outside of Elastic." displayed when i log into kibana.  
I have 2 options a YES or NO and it does not matter which i choose Im stuck in the same place.

I get an error Displayed:  
Config: Request failed with status code: 503 Error: Request failed with status code: 503 \_callee$@[https://10.185.11.21:5601/bundles/commons.bundle.js:3:878828](https://10.185.11.21:5601/bundles/commons.bundle.js:3:878828) tryCatch@[https://10.185.11.21:5601/bundles/vendors.bundle.js:43:602782](https://10.185.11.21:5601/bundles/vendors.bundle.js:43:602782) invoke@[https://10.185.11.21:5601/bundles/vendors.bundle.js:43:606667](https://10.185.11.21:5601/bundles/vendors.bundle.js:43:606667) defineIteratorMethods/\</prototype[method]@[https://10.185.11.21:5601/bundles/vendors.bundle.js:43:603903](https://10.185.11.21:5601/bundles/vendors.bundle.js:43:603903) step@[https://10.185.11.21:5601/bundles/commons.bundle.js:3:879592](https://10.185.11.21:5601/bundles/commons.bundle.js:3:879592) step/\<@[https://10.185.11.21:5601/bundles/commons.bundle.js:3:879726](https://10.185.11.21:5601/bundles/commons.bundle.js:3:879726) run@[https://10.185.11.21:5601/bundles/vendors.bundle.js:43:571210](https://10.185.11.21:5601/bundles/vendors.bundle.js:43:571210) notify/\<@[https://10.185.11.21:5601/bundles/vendors.bundle.js:43:571450](https://10.185.11.21:5601/bundles/vendors.bundle.js:43:571450) flush@[https://10.185.11.21:5601/bundles/vendors.bundle.js:167:55587](https://10.185.11.21:5601/bundles/vendors.bundle.js:167:55587)

I am unable to use the interface as i am unable to get past this.

Is this a known issue?

[root@elk02 ~]# cat /etc/redhat-release  
Red Hat Enterprise Linux Server release 7.7 (Maipo)  
You have mail in /var/spool/mail/root  
[root@elk02 ~]# rpm -qa | grep kibana  
kibana-6.4.2-1.x86\_64  
[root@elk02 ~]# rpm -qa | grep logstash  
logstash-6.4.2-1.noarch  
[root@elk02 ~]# rpm -qa | grep elasticsearch  
elasticsearch-curator-5.5.4-1.x86\_64  
elasticsearch-6.4.2-1.noarch

[root@elk02 ~]# curl -X GET "localhost:9200/\_cluster/health"  
curl: (52) Empty reply from server

---

<div class="post-metadata">

**Author:** ![mattkime](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mattkime/32/43522_2.png) [@mattkime](https://discuss.elastic.co/u/mattkime)\
**Post date:** [October 4, 2019, 9:11pm UTC](https://discuss.elastic.co/t/help-us-improve-the-elastic-stack-by-providing-basic-feature-usage-statistics-we-will-never-share-this-data-outside-of-elastic/202149/2 "2019-10-04T21:11:30Z")

</div>

Do you have any errors in the kibana logs? If so, can you share them?

Thanks

---

<div class="post-metadata">

**Author:** ![carel.lubbe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carel.lubbe/32/51359_2.png) [@carel.lubbe](https://discuss.elastic.co/u/carel.lubbe)\
**Post date:** [October 8, 2019, 10:16pm UTC](https://discuss.elastic.co/t/help-us-improve-the-elastic-stack-by-providing-basic-feature-usage-statistics-we-will-never-share-this-data-outside-of-elastic/202149/3 "2019-10-08T22:16:57Z")

</div>

Hi Matthew,

I have found this in my logs:  
Oct 8 22:11:04 elk02 kibana: {"type":"error","@timestamp":"2019-10-08T22:11:04Z","tags":["warning","stats-collection"],"pid":15582,"level":"error","error":{"message":"[search\_phase\_execution\_exception] all shards failed","name":"Error","stack":"[search\_phase\_execution\_exception] all shards failed :: {"path":"/.kibana/\_search","query":{"ignore\_unavailable":true,"filter\_path":"aggregations.types.buckets"},"body":"{\"size\":0,\"query\":{\"terms\":{\"type\":[\"dashboard\",\"visualization\",\"search\",\"index-pattern\",\"graph-workspace\",\"timelion-sheet\"]}},\"aggs\":{\"types\":{\"terms\":{\"field\":\"type\",\"size\":6}}}}","statusCode":503,"response":"{\"error\":{\"root\_cause\":,\"type\":\"search\_phase\_execution\_exception\",\"reason\":\"all shards failed\",\"phase\":\"query\",\"grouped\":true,\"failed\_shards\":},\"status\":503}"}\n at respond (/usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:307:15)\n at checkRespForFailure (/usr/share/kibana/node\_modules/elasticsearch/src/lib/transport.js:266:7)\n at HttpConnector. (/usr/share/kibana/node\_modules/elasticsearch/src/lib/connectors/http.js:159:7)\n at IncomingMessage.bound (/usr/share/kibana/node\_modules/elasticsearch/node\_modules/lodash/dist/lodash.js:729:21)\n at emitNone (events.js:111:20)\n at IncomingMessage.emit (events.js:208:7)\n at endReadableNT (\_stream\_readable.js:1064:12)\n at \_combinedTickCallback (internal/process/next\_tick.js:138:11)\n at process.\_tickDomainCallback (internal/process/next\_tick.js:218:9)"},"message":"[search\_phase\_execution\_exception] all shards failed"}

---

<div class="post-metadata">

**Author:** ![mattkime](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mattkime/32/43522_2.png) [@mattkime](https://discuss.elastic.co/u/mattkime)\
**Post date:** [October 9, 2019, 1:01am UTC](https://discuss.elastic.co/t/help-us-improve-the-elastic-stack-by-providing-basic-feature-usage-statistics-we-will-never-share-this-data-outside-of-elastic/202149/4 "2019-10-09T01:01:35Z")

</div>

> [@carel.lubbe](#):
>
> all shards failed

Looks like your elasticsearch service is having problems. You should check its logs to figure out how to fix it.

---

<div class="post-metadata">

**Author:** ![carel.lubbe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/carel.lubbe/32/51359_2.png) [@carel.lubbe](https://discuss.elastic.co/u/carel.lubbe)\
**Post date:** [October 9, 2019, 1:17pm UTC](https://discuss.elastic.co/t/help-us-improve-the-elastic-stack-by-providing-basic-feature-usage-statistics-we-will-never-share-this-data-outside-of-elastic/202149/5 "2019-10-09T13:17:57Z")

</div>

Hi,

Found the issue.... the number of open files on the ELK server was set to a limit.... once i have made that limit bigger the problem was solved.

Thanks for looking at my issue

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 6, 2019, 1:18pm UTC](https://discuss.elastic.co/t/help-us-improve-the-elastic-stack-by-providing-basic-feature-usage-statistics-we-will-never-share-this-data-outside-of-elastic/202149/6 "2019-11-06T13:18:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
