# \[Help!\] x-pack reporting returns timeout error

**URL:** <https://discuss.elastic.co/t/help-x-pack-reporting-returns-timeout-error/90455>\
**Category:** Elasticsearch\
**Created:** [June 22, 2017, 1:08pm UTC](https://discuss.elastic.co/t/help-x-pack-reporting-returns-timeout-error/90455 "2017-06-22T13:08:31Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![YuWatanabe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yuwatanabe/32/13259_2.png) [@YuWatanabe](https://discuss.elastic.co/u/YuWatanabe)\
**Post date:** [June 22, 2017, 1:08pm UTC](https://discuss.elastic.co/t/help-x-pack-reporting-returns-timeout-error/90455/1 "2017-06-22T13:08:31Z")

</div>

Hello.

I would like get advice for reporting configuration.

I am getting **Max attempts reached (3)** when I generate report.

I have an environment which kibana is operating behind reverse proxy (nginx). All elastic components are **5.4.0**.

```
nginx - kibana - tribe node
               - coordinator node - master and data node

```

nginx and kibana is installed on _same_ host and network setting are below.

```
nginx : 0.0.0.0:80
kibana : 127.0.0.1:5601

```

I have configured **xpack.reporting.kibanaServer.port : 80** but still getting timeout error.

According to _/var/log/message_ , below requests are returning **200 OK**.

1. POST /kibana/api/reporting/generate/dashboard/xxxxx

2. GET /kibana/api/reporting/jobs/list\_completed\_since?xxxx

Are there any other setting which I should look for ?

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [June 30, 2017, 5:28pm UTC](https://discuss.elastic.co/t/help-x-pack-reporting-returns-timeout-error/90455/2 "2017-06-30T17:28:47Z")

</div>

If you're using a reverse proxy, you may also need to specify the hostname, unless you're connecting through `localhost`. Whatever URL you use to connect to Kibana as a user, you need to configure in the `kibana.yml` file. For example, if Kibana is running at `http://localhost:5601`, but you connect through `http://hostname.tld`, you'll need to provide the hostname and the port. If you've added SSL to the proxy, you'll also need the protocol.

You can set these with `xpack.reporting.kibanaServer.protocol`, `xpack.reporting.kibanaServer.hostname`, and `xpack.reporting.kibanaServer.port` (which you already have).

From the description, I'm not sure you need to change anything else though. The GET and POST endpoints you shared I'd expect to work, Reporting happens in the background, as though you had a user on the same box loading Kibana through the proxy. Those routes simply talk to Kibana like any other request.

Maybe see if you can connect to the Kibana server **from the box hosting Kibana** , but using the proxy settings. That's effectively what reporting is trying to do, so if that connection doesn't work, that would be the cause of the error.

---

<div class="post-metadata">

**Author:** ![YuWatanabe](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/yuwatanabe/32/13259_2.png) [@YuWatanabe](https://discuss.elastic.co/u/YuWatanabe)\
**Post date:** [July 21, 2017, 6:59am UTC](https://discuss.elastic.co/t/help-x-pack-reporting-returns-timeout-error/90455/3 "2017-07-21T06:59:24Z")

</div>

@Joe_Fleming

Thank you for the reply. I found that request was somehow not properly mapped to the server block I had.

Thus, I eluded the situation by modifying the nginx configuration to have just _one server block_ and make sure requests to KIbana are mapped to only server block that I have.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 18, 2017, 6:59am UTC](https://discuss.elastic.co/t/help-x-pack-reporting-returns-timeout-error/90455/4 "2017-08-18T06:59:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
