# Hive into es err \[HEAD\] on \[pon\_ihgu\_sp\_day\_ln20220627\] failed; server\[10.204.172.64:9200\] returned \[503|Service Unavailable:\]

**URL:** https://discuss.elastic.co/t/hive-into-es-err-head-on-pon-ihgu-sp-day-ln20220627-failed-server-10-204-172-64-9200-returned-503-service-unavailable/308203
**Category:** Elasticsearch
**Tags:** es-hadoop
**Created:** [June 27, 2022, 2:18am UTC](https://discuss.elastic.co/t/hive-into-es-err-head-on-pon-ihgu-sp-day-ln20220627-failed-server-10-204-172-64-9200-returned-503-service-unavailable/308203 "2022-06-27T02:18:18Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![baishangkun2011](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/baishangkun2011/32/107602_2.png) [@baishangkun2011](https://discuss.elastic.co/u/baishangkun2011)
#### Post date: [June 27, 2022, 2:18am UTC](https://discuss.elastic.co/t/hive-into-es-err-head-on-pon-ihgu-sp-day-ln20220627-failed-server-10-204-172-64-9200-returned-503-service-unavailable/308203/1 "2022-06-27T02:18:18Z")

</div>

HI  
i use hive into es have err  
  
Caused by: org.elasticsearch.hadoop.rest.EsHadoopInvalidRequest: [HEAD] on [pon\_ihgu\_sp\_day\_ln20220627] failed; server[10.204.172.64:9200] returned [503|Service Unavailable:]  
at org.elasticsearch.hadoop.rest.RestClient.checkResponse(RestClient.java:469)  
at org.elasticsearch.hadoop.rest.RestClient.executeNotFoundAllowed(RestClient.java:439)  
at org.elasticsearch.hadoop.rest.RestClient.exists(RestClient.java:529)  
at org.elasticsearch.hadoop.rest.RestClient.indexExists(RestClient.java:524)  
at org.elasticsearch.hadoop.rest.RestClient.touch(RestClient.java:535)  
at org.elasticsearch.hadoop.rest.RestRepository.touch(RestRepository.java:364)  
at org.elasticsearch.hadoop.rest.RestService.initSingleIndex(RestService.java:660)  
at org.elasticsearch.hadoop.rest.RestService.createWriter(RestService.java:636)  
at org.elasticsearch.hadoop.mr.EsOutputFormat$EsRecordWriter.init(EsOutputFormat.java:175)  
at org.elasticsearch.hadoop.hive.EsHiveOutputFormat$EsHiveRecordWriter.write(EsHiveOutputFormat.java:59)  
at org.apache.hadoop.hive.ql.exec.FileSinkOperator.process(FileSinkOperator.java:987)  
at org.apache.hadoop.hive.ql.exec.vector.VectorFileSinkOperator.process(VectorFileSinkOperator.java:111)  
at org.apache.hadoop.hive.ql.exec.Operator.vectorForward(Operator.java:966)  
at org.apache.hadoop.hive.ql.exec.Operator.forward(Operator.java:939)  
at org.apache.hadoop.hive.ql.exec.vector.VectorSelectOperator.process(VectorSelectOperator.java:158)  
at org.apache.hadoop.hive.ql.exec.Operator.vectorForward(Operator.java:966)  
at org.apache.hadoop.hive.ql.exec.Operator.forward(Operator.java:939)  
at org.apache.hadoop.hive.ql.exec.TableScanOperator.process(TableScanOperator.java:125)  
at org.apache.hadoop.hive.ql.exec.vector.VectorMapOperator.process(VectorMapOperator.java:889)  
... 10 more  
  
my yml  
cluster.name: escluster  
node.name: es1  
node.master: true  
node.data: true  
node.max\_local\_storage\_nodes: 4  
network.host: 0.0.0.0  
#cluster.initial\_master\_nodes: ["10.204.172.64","10.204.172.65","10.204.172.66"]  
#cluster.initial\_master\_nodes: ["10.204.172.64"]  
cluster.initial\_master\_nodes: ["es1","es2","es3","es4"]  
bootstrap.system\_call\_filter: false  
http.port: 9200  
discovery.seed\_hosts: ["10.204.172.64:9300","10.204.172.65:9300","10.204.172.66:9300","10.204.172.60:9300"]  
xpack.security.enabled: true  
xpack.security.transport.ssl.enabled: true  
xpack.security.transport.ssl.verification\_mode: certificate  
xpack.security.transport.ssl.keystore.path: ./elastic-certificates.p12  
xpack.security.transport.ssl.truststore.path: ./elastic-certificates.p12

http.cors.allow-headers: Authorization,Content-Type  
action.destructive\_requires\_name: true  
http.cors.enabled: true  
http.cors.allow-origin: "\*"

discovery.zen.fd.ping\_timeout: 1000s  
discovery.zen.fd.ping\_retries: 10

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [June 27, 2022, 2:21am UTC](https://discuss.elastic.co/t/hive-into-es-err-head-on-pon-ihgu-sp-day-ln20220627-failed-server-10-204-172-64-9200-returned-503-service-unavailable/308203/2 "2022-06-27T02:21:30Z")

</div>

Welcome to our community! 😃  
Please format your code/logs/config using the `</>` button, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

What do your Elasticsearch logs show?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 25, 2022, 2:21am UTC](https://discuss.elastic.co/t/hive-into-es-err-head-on-pon-ihgu-sp-day-ln20220627-failed-server-10-204-172-64-9200-returned-503-service-unavailable/308203/3 "2022-07-25T02:21:34Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
