# Host unreachable

**URL:** <https://discuss.elastic.co/t/host-unreachable/83488>\
**Category:** Logstash\
**Created:** [April 25, 2017, 4:31am UTC](https://discuss.elastic.co/t/host-unreachable/83488 "2017-04-25T04:31:15Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Raja1](https://avatars.discourse-cdn.com/v4/letter/r/85f322/32.png) [@Raja1](https://discuss.elastic.co/u/Raja1)\
**Post date:** [April 25, 2017, 4:31am UTC](https://discuss.elastic.co/t/host-unreachable/83488/1 "2017-04-25T04:31:15Z")

</div>

Hi All,

I am keep on getting below error after installing x-pack. Please find my configuration below and also i have disabled the sniffing. I am not understansing how its taking localhost. Please guide me to resolve this issue.

input  
{  
file  
{  
path =\> "/etc/logstash/\*.log"  
codec =\> multiline {  
pattern =\> "(^%{TIMESTAMP\_ISO8601} )"  
negate =\> "true"  
what =\> "previous"  
}  
type =\> "%{type}"  
sincedb\_path =\> "/dev/null"  
}  
}  
filter  
{  
date  
{ match =\> ["timestamp", "dd/MMM/yyyy:HH:mm:ss Z"] }  
}

output {  
elasticsearch {  
user =\> "logstash\_internal"  
password =\> "abcs1234"  
hosts =\> ["x.x.x.x:9200"]  
sniffing =\> false  
}  
stdout {codec =\> rubydebug }  
}

04:25:32.945 [Ruby-0-Thread-5: /usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-6.2.6-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:222] INFO logstash.outputs.elasticsearch - Running health check to see if an Elasticsearch connection is working {:healthcheck\_url=\>[http://logstash\_system:xxxxxx@localhost:9200/](http://logstash_system:xxxxxx@localhost:9200/), :path=\>"/"}  
04:25:32.950 [Ruby-0-Thread-5: /usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-6.2.6-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:222] WARN logstash.outputs.elasticsearch - Attempted to resurrect connection to dead ES instance, but got an error. {:url=\>#\<URI::HTTP:0x2653fb26 URL:[http://logstash\_system:xxxxxx@localhost:9200/\_xpack/monitoring/?system\_id=logstash&system\_api\_version=2&interval=1s](http://logstash_system:xxxxxx@localhost:9200/_xpack/monitoring/?system_id=logstash&system_api_version=2&interval=1s)\>, :error\_type=\>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :error=\>"Elasticsearch Unreachable: [[http://logstash\_system:xxxxxx@localhost:9200/](http://logstash_system:xxxxxx@localhost:9200/)][Manticore::SocketException] Connection refused"}  
04:25:37.956 [Ruby-0-Thread-5: /usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-6.2.6-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:222] INFO logstash.outputs.elasticsearch - Running health check to see if an Elasticsearch connection is working {:healthcheck\_url=\>[http://logstash\_system:xxxxxx@localhost:9200/](http://logstash_system:xxxxxx@localhost:9200/), :path=\>"/"}  
04:25:37.982 [Ruby-0-Thread-5: /usr/share/logstash/vendor/bundle/jruby/1.9/gems/logstash-output-elasticsearch-6.2.6-java/lib/logstash/outputs/elasticsearch/http\_client/pool.rb:222] WARN logstash.outputs.elasticsearch - Attempted to resurrect connection to dead ES instance, but got an error. {:url=\>#\<URI::HTTP:0x60eeb34b URL:[http://logstash\_system:xxxxxx@localhost:9200/\_xpack/monitoring/?system\_id=logstash&system\_api\_version=2&interval=1s](http://logstash_system:xxxxxx@localhost:9200/_xpack/monitoring/?system_id=logstash&system_api_version=2&interval=1s)\>, :error\_type=\>LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError, :error=\>"Elasticsearch Unreachable: [[http://logstash\_system:xxxxxx@localhost:9200/](http://logstash_system:xxxxxx@localhost:9200/)][Manticore::SocketException] Connection refused"}  
04:25:38.058 [[.monitoring-logstash]\>worker0] WARN logstash.outputs.elasticsearch - Marking url as dead. Last error: [LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError] Elasticsearch Unreachable: [[http://logstash\_system:xxxxxx@localhost:9200/\_xpack/monitoring/?system\_id=logstash&system\_api\_version=2&interval=1s](http://logstash_system:xxxxxx@localhost:9200/_xpack/monitoring/?system_id=logstash&system_api_version=2&interval=1s)][Manticore::SocketException] Connection refused {:url=\>[http://logstash\_system:xxxxxx@localhost:9200/\_xpack/monitoring/?system\_id=logstash&system\_api\_version=2&interval=1s](http://logstash_system:xxxxxx@localhost:9200/_xpack/monitoring/?system_id=logstash&system_api_version=2&interval=1s), :error\_message=\>"Elasticsearch Unreachable: [[http://logstash\_system:xxxxxx@localhost:9200/\_xpack/monitoring/?system\_id=logstash&system\_api\_version=2&interval=1s](http://logstash_system:xxxxxx@localhost:9200/_xpack/monitoring/?system_id=logstash&system_api_version=2&interval=1s)][Manticore::SocketException] Connection refused", :error\_class=\>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError"}  
04:25:38.059 [[.monitoring-logstash]\>worker0] ERROR logstash.outputs.elasticsearch - Attempted to send a bulk request to elasticsearch' but Elasticsearch appears to be unreachable or down! {:error\_message=\>"Elasticsearch Unreachable: [[http://logstash\_system:xxxxxx@localhost:9200/\_xpack/monitoring/?system\_id=logstash&system\_api\_version=2&interval=1s](http://logstash_system:xxxxxx@localhost:9200/_xpack/monitoring/?system_id=logstash&system_api_version=2&interval=1s)][Manticore::SocketException] Connection refused", :class=\>"LogStash::Outputs::ElasticSearch::HttpClient::Pool::HostUnreachableError", :will\_retry\_in\_seconds=\>2}

Regards  
Raja

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 28, 2017, 8:23am UTC](https://discuss.elastic.co/t/host-unreachable/83488/2 "2017-04-28T08:23:44Z")

</div>

> [@Raja1](#):
>
> Connection refused

Can you curl your hosts with the Logstash user?

---

<div class="post-metadata">

**Author:** ![Raja1](https://avatars.discourse-cdn.com/v4/letter/r/85f322/32.png) [@Raja1](https://discuss.elastic.co/u/Raja1)\
**Post date:** [April 28, 2017, 8:26am UTC](https://discuss.elastic.co/t/host-unreachable/83488/3 "2017-04-28T08:26:09Z")

</div>

Thank you Mark.

I resolved this issue.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 28, 2017, 8:38pm UTC](https://discuss.elastic.co/t/host-unreachable/83488/4 "2017-04-28T20:38:48Z")

</div>

How?

---

<div class="post-metadata">

**Author:** ![Raja1](https://avatars.discourse-cdn.com/v4/letter/r/85f322/32.png) [@Raja1](https://discuss.elastic.co/u/Raja1)\
**Post date:** [May 2, 2017, 2:52am UTC](https://discuss.elastic.co/t/host-unreachable/83488/5 "2017-05-02T02:52:22Z")

</div>

Sorry it was not resolved.

I just removed x-pack for now to avoid my task delay.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 30, 2017, 3:07am UTC](https://discuss.elastic.co/t/host-unreachable/83488/6 "2017-05-30T03:07:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
