How can connect to elastic Search from public ip


(Mas Hgnis) #1

I have installed elastic search on my linux server where my website is
running and I able to access the elastic search using curl
http://localhost:9200/_cluster/health?pretty from local box.

But for debugging purpose (using head/kopf) i would like access the same
from my public internet but when I am trying it with
help http://xxx.xx.xx.xxx:9200/_cluster/health?pretty, I am not able to
connect. (I am able to ping the ip)

Please help in understanding the same and let me know what configurations
are required so as to access elastic search.

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/02c100df-56ee-434d-8961-08baf5a29594%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

Is the 9200 port open?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 mai 2014 à 05:39, Mas Hgnis inspiration0023@gmail.com a écrit :

I have installed elastic search on my linux server where my website is running and I able to access the elastic search using curl http://localhost:9200/_cluster/health?pretty from local box.

But for debugging purpose (using head/kopf) i would like access the same from my public internet but when I am trying it with help http://xxx.xx.xx.xxx:9200/_cluster/health?pretty, I am not able to connect. (I am able to ping the ip)

Please help in understanding the same and let me know what configurations are required so as to access elastic search.

Thanks in advance.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/02c100df-56ee-434d-8961-08baf5a29594%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/E8B1E66E-40D6-4DF3-869F-B24AA03631F8%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(Nik Everett) #3

Ssh tunneling is how I do it. There is always a way to get to port 22.

Sent from my iPhone

On May 27, 2014, at 7:30 AM, David Pilato david@pilato.fr wrote:

Is the 9200 port open?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 mai 2014 à 05:39, Mas Hgnis inspiration0023@gmail.com a écrit :

I have installed elastic search on my linux server where my website is running and I able to access the elastic search using curl http://localhost:9200/_cluster/health?pretty from local box.

But for debugging purpose (using head/kopf) i would like access the same from my public internet but when I am trying it with help http://xxx.xx.xx.xxx:9200/_cluster/health?pretty, I am not able to connect. (I am able to ping the ip)

Please help in understanding the same and let me know what configurations are required so as to access elastic search.

Thanks in advance.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/02c100df-56ee-434d-8961-08baf5a29594%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/E8B1E66E-40D6-4DF3-869F-B24AA03631F8%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/81FAF8E5-C9AE-4E4D-B0D2-42961675553C%40gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Mas Hgnis) #4

Thank you David for your reply, I don't think 9200 port is open on my
server as i am not able to do telnet on that port. Should I go ahead ask my
service provider to open this port.

But i feel a security issue if 9200 port is open.

Kindly suggest me if there a better way to access the elastic search
cluster from my local machine by adding some configs(temporarily) in
elasticsearch.yml at run time.

I am sorry about my lack of knowledge about elastic search at the moment
but I am learning.

Thanks.
Mas

On Tuesday, 27 May 2014 11:01:01 UTC+5:30, David Pilato wrote:

Is the 9200 port open?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 mai 2014 à 05:39, Mas Hgnis <inspira...@gmail.com <javascript:>> a
écrit :

I have installed elastic search on my linux server where my website is
running and I able to access the elastic search using curl
http://localhost:9200/_cluster/health?pretty from local box.

But for debugging purpose (using head/kopf) i would like access the same
from my public internet but when I am trying it with help
http://xxx.xx.xx.xxx:9200/_cluster/health?pretty, I am not able to
connect. (I am able to ping the ip)

Please help in understanding the same and let me know what configurations
are required so as to access elastic search.

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/02c100df-56ee-434d-8961-08baf5a29594%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/02c100df-56ee-434d-8961-08baf5a29594%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/19b37d2d-5d10-4cd3-9b69-248f6e1193ba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #5

Should I go ahead ask my service provider to open this port.

If you need to access Elasticsearch from outside, you need to do whatever is needed. Open 9200 port is one solution.
But It is a security issue for sure.

That said, you could add a NGnix layer to secure access or follow Nik's advice about SSH tunnels.

My 2 cents.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 mai 2014 à 08:26, Mas Hgnis inspiration0023@gmail.com a écrit :

Thank you David for your reply, I don't think 9200 port is open on my server as i am not able to do telnet on that port. Should I go ahead ask my service provider to open this port.

But i feel a security issue if 9200 port is open.

Kindly suggest me if there a better way to access the elastic search cluster from my local machine by adding some configs(temporarily) in elasticsearch.yml at run time.

I am sorry about my lack of knowledge about elastic search at the moment but I am learning.

Thanks.
Mas

On Tuesday, 27 May 2014 11:01:01 UTC+5:30, David Pilato wrote:
Is the 9200 port open?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 27 mai 2014 à 05:39, Mas Hgnis inspira...@gmail.com a écrit :

I have installed elastic search on my linux server where my website is running and I able to access the elastic search using curl http://localhost:9200/_cluster/health?pretty from local box.

But for debugging purpose (using head/kopf) i would like access the same from my public internet but when I am trying it with help http://xxx.xx.xx.xxx:9200/_cluster/health?pretty, I am not able to connect. (I am able to ping the ip)

Please help in understanding the same and let me know what configurations are required so as to access elastic search.

Thanks in advance.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/02c100df-56ee-434d-8961-08baf5a29594%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/19b37d2d-5d10-4cd3-9b69-248f6e1193ba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1AAFF296-37C9-4310-9272-4265DECD3813%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(system) #6