# How do I setup APM all on one machine?

**URL:** <https://discuss.elastic.co/t/how-do-i-setup-apm-all-on-one-machine/324922>\
**Category:** Elastic Observability\
**Created:** [February 7, 2023, 4:47pm UTC](https://discuss.elastic.co/t/how-do-i-setup-apm-all-on-one-machine/324922 "2023-02-07T16:47:17Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![fnbk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fnbk/32/116886_2.png) [@fnbk](https://discuss.elastic.co/u/fnbk)\
**Post date:** [February 8, 2023, 8:36pm UTC](https://discuss.elastic.co/t/how-do-i-setup-apm-all-on-one-machine/324922/3 "2023-02-08T20:36:51Z")

</div>

Thanks @stephenb. I managed to assign the APM integration to the Fleet Server Policy.

But the next problem arises: The agent cannot connect to elasticsearch because it does not use the right url -\> [Failed to connect to backoff(elasticsearch(http://localhost:9200))](https://discuss.elastic.co/t/failed-to-connect-to-backoff-elasticsearch-http-localhost-9200/325065)

---

_[View the full topic](https://discuss.elastic.co/t/how-do-i-setup-apm-all-on-one-machine/324922)._
