# How to add write privilege to elastic search after enabling https protocol

**URL:** <https://discuss.elastic.co/t/how-to-add-write-privilege-to-elastic-search-after-enabling-https-protocol/220960>\
**Category:** Elasticsearch\
**Created:** [February 26, 2020, 6:23am UTC](https://discuss.elastic.co/t/how-to-add-write-privilege-to-elastic-search-after-enabling-https-protocol/220960 "2020-02-26T06:23:09Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ShreyaBhat](https://avatars.discourse-cdn.com/v4/letter/s/ba9def/32.png) [@ShreyaBhat](https://discuss.elastic.co/u/ShreyaBhat)\
**Post date:** [February 26, 2020, 6:23am UTC](https://discuss.elastic.co/t/how-to-add-write-privilege-to-elastic-search-after-enabling-https-protocol/220960/1 "2020-02-26T06:23:10Z")

</div>

Hi  
I have enabled https using the following parameters on the .yml file:

xpack.security.enabled: true  
xpack.security.http.ssl.enabled: true  
xpack.security.transport.ssl.enabled: true  
xpack.security.http.ssl.certificate\_authorities: "certs/ca.crt"  
xpack.security.http.ssl.keystore.path: "certs/pfxFile.pfx"  
xpack.security.http.ssl.keystore.password: "\*\*\*\*\*\*\*\*"

so these have worked properly and I have enabled https but its privilege is a 'read-only' for some reason, anyone who could tell me why this is happening ? and how can I provide write access to the index?  
Also when it was http, things were completely fine.  
Could someone please help? I am new to all this. Thanks

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [February 26, 2020, 11:22am UTC](https://discuss.elastic.co/t/how-to-add-write-privilege-to-elastic-search-after-enabling-https-protocol/220960/4 "2020-02-26T11:22:35Z")

</div>

Have a look at [Web Portocols and Ports used by Elasticsearch](https://discuss.elastic.co/t/web-portocols-and-ports-used-by-elasticsearch/220055/14)

---

<div class="post-metadata">

**Author:** ![ShreyaBhat](https://avatars.discourse-cdn.com/v4/letter/s/ba9def/32.png) [@ShreyaBhat](https://discuss.elastic.co/u/ShreyaBhat)\
**Post date:** [March 2, 2020, 6:15am UTC](https://discuss.elastic.co/t/how-to-add-write-privilege-to-elastic-search-after-enabling-https-protocol/220960/5 "2020-03-02T06:15:59Z")

</div>

Hello  
I have created built-in user passwords, problem now is to create a role with write access, none of the roles are working and all of them are unauthorized.  
I am also unable to integrate kibana with my elasticsearch,  
I have given the following configurations:

server.ssl.enabled:true  
server.ssl.keystore.path:certs/pfxFile.pfx  
ssserver.ssl.keystore.password:\*\*\*\*\*\*\*\*\*

elasticsearch.host:["[https://DomainName:9200](https://DomainName:9200)"]  
elasticsearch.username:kibana  
elasticsearch.password:  
elasticsearch.ssl.certificateAuthorities:[certs/ca.crt]

the only response I get on kibana is -\>  
log [05:49:14.802] [warning][admin][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [05:49:14.804] [warning][admin][elasticsearch] No living connections  
log [05:49:14.814] [warning][migrations] Unable to connect to Elasticsearch. Error: No Living connections  
log [05:49:14.816] [warning][admin][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [05:49:14.818] [warning][admin][elasticsearch] No living connections  
log [05:49:17.337] [warning][admin][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)  
log [05:49:17.347] [warning][admin][elasticsearch] No living connections  
log [05:49:17.350] [warning][admin][elasticsearch] Unable to revive connection: [http://localhost:9200/](http://localhost:9200/)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 30, 2020, 6:16am UTC](https://discuss.elastic.co/t/how-to-add-write-privilege-to-elastic-search-after-enabling-https-protocol/220960/6 "2020-03-30T06:16:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
