# How to check what caused APM error

**URL:** <https://discuss.elastic.co/t/how-to-check-what-caused-apm-error/161617>\
**Category:** APM\
**Created:** [December 20, 2018, 4:45am UTC](https://discuss.elastic.co/t/how-to-check-what-caused-apm-error/161617 "2018-12-20T04:45:11Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![mhd.mam](https://avatars.discourse-cdn.com/v4/letter/m/46a35a/32.png) [@mhd.mam](https://discuss.elastic.co/u/mhd.mam)\
**Post date:** [December 20, 2018, 4:45am UTC](https://discuss.elastic.co/t/how-to-check-what-caused-apm-error/161617/1 "2018-12-20T04:45:11Z")

</div>

I'm getting this error on my server, I need to know how to know what's the root cause?  
logging error fe074d03-eae5-4f7b-adcc-de3514859480 with Elastic APM

of course with different id every time.

I How I can get the full error log/stack error of this?

Thanks

---

<div class="post-metadata">

**Author:** ![simitt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/simitt/32/106406_2.png) [@simitt](https://discuss.elastic.co/u/simitt)\
**Post date:** [December 20, 2018, 8:06am UTC](https://discuss.elastic.co/t/how-to-check-what-caused-apm-error/161617/2 "2018-12-20T08:06:17Z")

</div>

Could you share some more details about your setup, which APM Server version are you using and which agent? Do you see data getting ingested into your Elasticsearch instance and do they show up in the Kibana UI?

By default the server logs on level `info` but you could set that to `debug`, which produces a lot more log output. You can change that in the [apm-server.yml](https://github.com/elastic/apm-server/blob/master/apm-server.yml#L789).

---

<div class="post-metadata">

**Author:** ![mhd.mam](https://avatars.discourse-cdn.com/v4/letter/m/46a35a/32.png) [@mhd.mam](https://discuss.elastic.co/u/mhd.mam)\
**Post date:** [December 20, 2018, 8:24am UTC](https://discuss.elastic.co/t/how-to-check-what-caused-apm-error/161617/3 "2018-12-20T08:24:20Z")

</div>

I'm using 6.2 with Nodejs  
everything with APM is good, getting data into Kibana.  
but on my server logs i'm seeing such messages just right before my server crashs

> logging error fe074d03-eae5-4f7b-adcc-de3514859480 with Elastic APM

I really don't know what is that means, I used to get such things when miss configure something or missing some npm modules.

but in production and everything working fine, and suddenly out of blue start getting this.  
How/where I can get more info about it? is that ID really useful or it just random logs?

---

<div class="post-metadata">

**Author:** ![simitt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/simitt/32/106406_2.png) [@simitt](https://discuss.elastic.co/u/simitt)\
**Post date:** [December 20, 2018, 8:54am UTC](https://discuss.elastic.co/t/how-to-check-what-caused-apm-error/161617/4 "2018-12-20T08:54:44Z")

</div>

Is there any chance you can upgrade your Elastic stack and the nodejs agent to the latest versions?

Do the nodejs agent logs reveil anything? Otherwise as mentioned above turning the log legel to `debug` instead of `info` for some time might reveal more insights.

---

<div class="post-metadata">

**Author:** ![felixbarny](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/felixbarny/32/27341_2.png) [@felixbarny](https://discuss.elastic.co/u/felixbarny)\
**Post date:** [December 20, 2018, 9:23am UTC](https://discuss.elastic.co/t/how-to-check-what-caused-apm-error/161617/5 "2018-12-20T09:23:02Z")

</div>

Hi,

this message means that the Node.js agent has recorded and error and sent it to the APM Server.

> [@mhd.mam](#):
>
> logging error fe074d03-eae5-4f7b-adcc-de3514859480 with Elastic APM

You can search for this particular error by going to the discover tab in Kibana, selecting the `apm-*` index pattern and searching for `error.id : "fe074d03-eae5-4f7b-adcc-de3514859480"`.

In more recent versions, you can use the query bar in the Error tab of the APM UI:

 ![33](https://us1.discourse-cdn.com/elastic/original/3X/9/2/928a8de1c0f8514d4119b0326d49168451526014.png)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 10, 2019, 5:23am UTC](https://discuss.elastic.co/t/how-to-check-what-caused-apm-error/161617/6 "2019-01-10T05:23:03Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
