# How to fix these errors while staring up Elasticsearch 6

**URL:** https://discuss.elastic.co/t/how-to-fix-these-errors-while-staring-up-elasticsearch-6/109510
**Category:** Elasticsearch
**Created:** [November 29, 2017, 5:23am UTC](https://discuss.elastic.co/t/how-to-fix-these-errors-while-staring-up-elasticsearch-6/109510 "2017-11-29T05:23:37Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![elasticheart](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/elasticheart/32/65189_2.png) [@elasticheart](https://discuss.elastic.co/u/elasticheart)
#### Post date: [November 29, 2017, 5:23am UTC](https://discuss.elastic.co/t/how-to-fix-these-errors-while-staring-up-elasticsearch-6/109510/1 "2017-11-29T05:23:37Z")

</div>

Hi,

I am using ELK GA 6. When I launch elasticsearch, I was getting the error below;

```
[2017-11-27T14:23:09,678][WARN][o.e.b.JNANatives] unable to install syscall filter:
java.lang.UnsupportedOperationException: seccomp unavailable: requires kernel 3.5+ with CONFIG_SECCOMP and CONFIG_SECCOMP_FILTER compiled in
        at org.elasticsearch.bootstrap.SystemCallFilter.linuxImpl(SystemCallFilter.java:328) ~[elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.bootstrap.SystemCallFilter.init(SystemCallFilter.java:616) ~[elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.bootstrap.JNANatives.tryInstallSystemCallFilter(JNANatives.java:258) [elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.bootstrap.Natives.tryInstallSystemCallFilter(Natives.java:113) [elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:109) [elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:171) [elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:322) [elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:130) [elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:121) [elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:69) [elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134) [elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-6.0.0.jar:6.0.0]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:85) [elasticsearch-6.0.0.jar:6.0.0]
[2017-11-27T14:23:09,938][INFO][o.e.n.Node] [ga6_node_1] initializing ...
[2017-11-27T14:23:10,647][INFO][o.e.e.NodeEnvironment] [ga6_node_1] using [1] data paths, mounts [[/data (/dev/mapper/vg2_data-lv2_data)]], net usable_space [62.6gb], net total_space [265.6gb], types [ext4]
[2017-11-27T14:23:10,647][INFO][o.e.e.NodeEnvironment] [ga6_node_1] heap size [990.7mb], compressed ordinary object pointers [true]
[2017-11-27T14:23:10,649][INFO][o.e.n.Node] [ga6_node_1] node name [ga6_node_1], node ID [BtLlSxX1TBahHAHYWT8uOw]
[2017-11-27T14:23:10,649][INFO][o.e.n.Node] [ga6_node_1] version[6.0.0], pid[27509], build[8f0685b/2017-11-10T18:41:22.859Z], OS[Linux/2.6.32-504.el6.x86_64/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0_102/25.102-b14]
[2017-11-27T14:23:10,650][INFO][o.e.n.Node] [ga6_node_1] JVM arguments [-Xms1g, -Xmx1g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -XX:+HeapDumpOnOutOfMemoryError, -Des.path.home=/data/setup/GA6/elasticsearch-6.0.0, -Des.path.conf=../CONFIG_HOME]
[2017-11-27T14:23:11,781][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [aggs-matrix-stats]
[2017-11-27T14:23:11,781][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [analysis-common]
[2017-11-27T14:23:11,781][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [ingest-common]
[2017-11-27T14:23:11,782][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [lang-expression]
[2017-11-27T14:23:11,782][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [lang-mustache]
[2017-11-27T14:23:11,782][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [lang-painless]
[2017-11-27T14:23:11,782][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [parent-join]
[2017-11-27T14:23:11,782][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [percolator]
[2017-11-27T14:23:11,782][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [reindex]
[2017-11-27T14:23:11,783][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [repository-url]
[2017-11-27T14:23:11,783][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [transport-netty4]
[2017-11-27T14:23:11,783][INFO][o.e.p.PluginsService] [ga6_node_1] loaded module [tribe]
[2017-11-27T14:23:11,784][INFO][o.e.p.PluginsService] [ga6_node_1] no plugins loaded
[2017-11-27T14:23:13,474][INFO][o.e.d.DiscoveryModule] [ga6_node_1] using discovery type [zen]
[2017-11-27T14:23:14,381][INFO][o.e.n.Node] [ga6_node_1] initialized
[2017-11-27T14:23:14,382][INFO][o.e.n.Node] [ga6_node_1] starting ...
[2017-11-27T14:23:14,576][INFO][o.e.t.TransportService] [ga6_node_1] publish_address {192.168.0.1:9300}, bound_addresses {192.168.0.1:9300}
[2017-11-27T14:23:14,594][INFO][o.e.b.BootstrapChecks] [ga6_node_1] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
ERROR: [1] bootstrap checks failed
[1]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
[2017-11-27T14:23:14,610][INFO][o.e.n.Node] [ga6_node_1] stopping ...
[2017-11-27T14:23:14,665][INFO][o.e.n.Node] [ga6_node_1] stopped
[2017-11-27T14:23:14,665][INFO][o.e.n.Node] [ga6_node_1] closing ...
[2017-11-27T14:23:14,684][INFO][o.e.n.Node] [ga6_node_1] closed

```

I have solved the issue by setting `bootstrap.system_call_filter: false` in `elasticsearch.yml` file. But is it just skipping the checks? How can I get rid of this error without giving those attributes?

Thank you.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [November 29, 2017, 6:09am UTC](https://discuss.elastic.co/t/how-to-fix-these-errors-while-staring-up-elasticsearch-6/109510/2 "2017-11-29T06:09:08Z")

</div>

What OS and what kernel are you on?

---

<div class="post-metadata">

### Author: ![elasticheart](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/elasticheart/32/65189_2.png) [@elasticheart](https://discuss.elastic.co/u/elasticheart)
#### Post date: [November 29, 2017, 6:24am UTC](https://discuss.elastic.co/t/how-to-fix-these-errors-while-staring-up-elasticsearch-6/109510/3 "2017-11-29T06:24:13Z")

</div>

Hi Mark, below are the details;

```
Linux mybox1 2.6.32-504.el6.x86_64 #1 SMP Wed Oct 15 04:27:16 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

```

and

```
CentOS release 6.6 (Final)
```

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [November 29, 2017, 7:40am UTC](https://discuss.elastic.co/t/how-to-fix-these-errors-while-staring-up-elasticsearch-6/109510/4 "2017-11-29T07:40:23Z")

</div>

Geez that's a really old kernel ☹ Can you update it?

---

<div class="post-metadata">

### Author: ![elasticheart](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/elasticheart/32/65189_2.png) [@elasticheart](https://discuss.elastic.co/u/elasticheart)
#### Post date: [November 29, 2017, 8:20am UTC](https://discuss.elastic.co/t/how-to-fix-these-errors-while-staring-up-elasticsearch-6/109510/5 "2017-11-29T08:20:39Z")

</div>

Sorry to hear that ☹

So the error can only be rectified by updating my kernel, right?

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [November 29, 2017, 9:27am UTC](https://discuss.elastic.co/t/how-to-fix-these-errors-while-staring-up-elasticsearch-6/109510/6 "2017-11-29T09:27:30Z")

</div>

> [@elasticcloud](#):
>
> requires kernel 3.5+ with CONFIG\_SECCOMP and CONFIG\_SECCOMP\_FILTER compiled in

Yeah.  
2.6 came out in the early 2000's ☹

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [December 27, 2017, 9:27am UTC](https://discuss.elastic.co/t/how-to-fix-these-errors-while-staring-up-elasticsearch-6/109510/7 "2017-12-27T09:27:36Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
