# How to grant permissions for jedis in 5.0.0-alpha5

**URL:** <https://discuss.elastic.co/t/how-to-grant-permissions-for-jedis-in-5-0-0-alpha5/63955>\
**Category:** Elasticsearch\
**Created:** [October 26, 2016, 3:00am UTC](https://discuss.elastic.co/t/how-to-grant-permissions-for-jedis-in-5-0-0-alpha5/63955 "2016-10-26T03:00:29Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![chenjinyuan87](https://avatars.discourse-cdn.com/v4/letter/c/bb73d2/32.png) [@chenjinyuan87](https://discuss.elastic.co/u/chenjinyuan87)\
**Post date:** [October 26, 2016, 3:00am UTC](https://discuss.elastic.co/t/how-to-grant-permissions-for-jedis-in-5-0-0-alpha5/63955/1 "2016-10-26T03:00:29Z")

</div>

My plugin needs jedis.  
But when constructing the connection pool, i was asked for the permission:  
javax.management.MBeanServerPermission "createMBeanServer";  
And after adding this permission, another permission called:  
javax.management.MBeanPermission "org.apache.commons.pool2..." "registerMbean"  
is required.

The problem is i cannot grant this permission. Because:  
when i grant it like:  
javax.management.MBeanPermission "org.apache.commons.pool2\*" "registerMbean"  
I get following error:  
java.security.policy: error parsing file:/home/es/elasticsearch-5.0.0-alpha5/plugins/.installing-1345536864053395201/plugin-security.policy:  
line 23: expected [;], found [\*]

and if i write:  
javax.management.MBeanPermission "org.apache.commons.pool2\*";  
The error becames:  
java.security.policy: error adding Permission, javax.management.MBeanPermission:  
java.lang.IllegalArgumentException: MBeanPermission: actions can't be null

So, i think the problem is: i need specify the action, but the parser cannot recognize the action?

My current elasticsearch version is 5.0.0-alpha5

---

<div class="post-metadata">

**Author:** ![chenjinyuan87](https://avatars.discourse-cdn.com/v4/letter/c/bb73d2/32.png) [@chenjinyuan87](https://discuss.elastic.co/u/chenjinyuan87)\
**Post date:** [October 26, 2016, 11:34am UTC](https://discuss.elastic.co/t/how-to-grant-permissions-for-jedis-in-5-0-0-alpha5/63955/2 "2016-10-26T11:34:49Z")

</div>

up..

---

<div class="post-metadata">

**Author:** ![chenjinyuan87](https://avatars.discourse-cdn.com/v4/letter/c/bb73d2/32.png) [@chenjinyuan87](https://discuss.elastic.co/u/chenjinyuan87)\
**Post date:** [October 27, 2016, 2:49am UTC](https://discuss.elastic.co/t/how-to-grant-permissions-for-jedis-in-5-0-0-alpha5/63955/3 "2016-10-27T02:49:00Z")

</div>

up again...  
Anyone knows?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:09pm UTC](https://discuss.elastic.co/t/how-to-grant-permissions-for-jedis-in-5-0-0-alpha5/63955/4 "2017-07-05T22:09:15Z")

</div>


