How to 'redirect' Rally to use Python 2 instead of Python 3?

This post was flagged by the community and is temporarily hidden.

As far as I know Rally requires python3 and can not be run using python2.

Hello,

Seems like you are right. In that case i have to recover 3.6 and make sure to build it with ssl. Might be a challenge since i don't have much experience with linux.
Edit: I managed to install it by now, while trying to run esrally or esrally configuration i got:

ModuleNotFoundError: No module named 'esrally'

Hi,

Christian is correct to point out that Rally only supports Python 3.

Rally is also available as a Docker image but it has some limitations compared to Rally installed natively. If you are ok with these limitations you can also give the Docker image a go.

Daniel

1 Like