# How to resolve "Failed to poll for work. Work has timed out" error

**URL:** <https://discuss.elastic.co/t/how-to-resolve-failed-to-poll-for-work-work-has-timed-out-error/291538>\
**Category:** Elasticsearch\
**Created:** [December 12, 2021, 11:49am UTC](https://discuss.elastic.co/t/how-to-resolve-failed-to-poll-for-work-work-has-timed-out-error/291538 "2021-12-12T11:49:31Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![mertkaant](https://avatars.discourse-cdn.com/v4/letter/m/9fc29f/32.png) [@mertkaant](https://discuss.elastic.co/u/mertkaant)\
**Post date:** [December 12, 2021, 11:49am UTC](https://discuss.elastic.co/t/how-to-resolve-failed-to-poll-for-work-work-has-timed-out-error/291538/1 "2021-12-12T11:49:31Z")

</div>

**Hello, dear elastic community,**

We recently upgraded our ELK stack to 7.15.2 from 7.7.0.  
All my nodes are on the same version (7.15.2)  
After the upgrade, our Kibana's status goes yellow repeatedly. When it goes yellow I checked the cluster and nodes to see anything is going wrong but all cluster nodes are active and the cluster status is green.  
After I checked the Kibana logs I saw this error:

```auto
{"type":"log","@timestamp":"2021-12-12T06:16:11-05:00","tags":["error","plugins","taskManager"],"pid":1451,"message":"Failed to poll for work: Error: work has timed out"}
{"type":"log","@timestamp":"2021-12-12T06:16:56-05:00","tags":["info","status"],"pid":1451,"message":"Kibana is now available (was degraded)"}
{"type":"log","@timestamp":"2021-12-12T06:17:13-05:00","tags":["error","plugins","taskManager"],"pid":1451,"message":"Failed to poll for work: Error: work has timed out"}
{"type":"log","@timestamp":"2021-12-12T06:17:22-05:00","tags":["info","status"],"pid":1451,"message":"Kibana is now degraded (was available)"}

```

I ran this curl to check task manager but I really don't have any idea about task manager stuff and how to proceed with this error.

> curl -X GET "[http://localhost:5601/api/task\_manager/\_health?pretty](http://localhost:5601/api/task_manager/_health?pretty)" -H 'kbn-xsrf: true'

The response:

```auto
{
    "id": "6461ac68-65ce-453f-9f8a-9652a2ea06f1",
    "timestamp": "2021-12-12T11:25:53.075Z",
    "status": "OK",
    "last_update": "2021-12-12T11:25:47.878Z",
    "stats": {
        "configuration": {
            "timestamp": "2021-12-12T10:40:21.887Z",
            "value": {
                "request_capacity": 1000,
                "max_poll_inactivity_cycles": 10,
                "monitored_aggregated_stats_refresh_rate": 60000,
                "monitored_stats_running_average_window": 50,
                "monitored_task_execution_thresholds": {
                    "default": {
                        "error_threshold": 90,
                        "warn_threshold": 80
                    },
                    "custom": {}
                },
                "poll_interval": 3000,
                "max_workers": 10
            },
            "status": "OK"
        }
    }
}

```

I saw the **poll\_interval** field is set to **3000** , and I thought maybe increasing that might solve my problem but I don't know how to configure the task manager's settings. I checked the documents for the task manager but couldn't find a way to configure it.

Long story short, could configure the poll\_interval field to fix my problem? If so, how can I configure my task manager settings?

Thank you for reading I'm looking forward to your reply.

---

<div class="post-metadata">

**Author:** ![mertkaant](https://avatars.discourse-cdn.com/v4/letter/m/9fc29f/32.png) [@mertkaant](https://discuss.elastic.co/u/mertkaant)\
**Post date:** [December 16, 2021, 7:26am UTC](https://discuss.elastic.co/t/how-to-resolve-failed-to-poll-for-work-work-has-timed-out-error/291538/2 "2021-12-16T07:26:40Z")

</div>

We need help guys, please let us know if you know anything about this issue. We tried to increase the poll\_interval field to 5000 but it didn't work. Our Kibana goes yellow a lot and the only log for error is this one

---

<div class="post-metadata">

**Author:** ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)\
**Post date:** [December 20, 2021, 6:40pm UTC](https://discuss.elastic.co/t/how-to-resolve-failed-to-poll-for-work-work-has-timed-out-error/291538/3 "2021-12-20T18:40:58Z")

</div>

Seems more like an ES problem than Kibana. How many documents are you ingesting? How's the memory usage of Elasticsearch? Is it possible there are networking problems among the hosts?  
If you aren't running monitoring yet ([https://www.elastic.co/guide/en/elasticsearch/reference/current/monitoring-overview.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/monitoring-overview.html)), it would probably help giving you some visibility into what's happening inside your cluster. I'm no expert on performance tuning, but all you wrote so far seems to point to performance/capacity issues, so this looks like a good starting point to me.

1. Elasticsearch is somehow down. (Check its logs to see if an error is happening on your Elasticsearch cluster)
2. A proxy is in-between you and your cluster and the proxy is misbehaving.

Thanks  
Rashmi

---

<div class="post-metadata">

**Author:** ![mertkaant](https://avatars.discourse-cdn.com/v4/letter/m/9fc29f/32.png) [@mertkaant](https://discuss.elastic.co/u/mertkaant)\
**Post date:** [December 21, 2021, 12:02pm UTC](https://discuss.elastic.co/t/how-to-resolve-failed-to-poll-for-work-work-has-timed-out-error/291538/4 "2021-12-21T12:02:27Z")

</div>

**Thank you for your reply!** @rashmi

Yes, currently, we are having a **heap** problem with our cluster. The error message says basically

```auto
{"error":{"root_cause":[{"type":"circuit_breaking_exception","reason":"[parent] Data too large, data for [<http_request>] would be [4156279272/3.8gb], which is larger than the limit of [4080218931/3.7gb], real usage: [4156279272/3.8gb]

```

We have too many shards per node and we assume this is the problem for this heap issue. We'll take action about it.

Though just for clarification, can this heap problem be the main reason for our Kibana's problem?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 18, 2022, 12:03pm UTC](https://discuss.elastic.co/t/how-to-resolve-failed-to-poll-for-work-work-has-timed-out-error/291538/5 "2022-01-18T12:03:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
