# How to run rally against an existing on-premise cluster

**URL:** <https://discuss.elastic.co/t/how-to-run-rally-against-an-existing-on-premise-cluster/270228>\
**Category:** Elasticsearch\
**Tags:** rally\
**Created:** [April 15, 2021, 12:02pm UTC](https://discuss.elastic.co/t/how-to-run-rally-against-an-existing-on-premise-cluster/270228 "2021-04-15T12:02:18Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![anoopkv](https://avatars.discourse-cdn.com/v4/letter/a/49beb7/32.png) [@anoopkv](https://discuss.elastic.co/u/anoopkv)\
**Post date:** [April 15, 2021, 12:02pm UTC](https://discuss.elastic.co/t/how-to-run-rally-against-an-existing-on-premise-cluster/270228/1 "2021-04-15T12:02:19Z")

</div>

I am running my elasticsearch (version 7.11) cluster on an on-premise kubernetes cluster. security is enabled in the cluster. to run rally i have created a separate pod

--chart.yaml--  
apiVersion: v1

```
    kind: Pod

    metadata:

      name: {{ template "fullname" . }}

    spec:

      containers:

      - name: esrally

        image: {{ .Values.image }}

        command:

          - "sleep"

          - "604800"

      {{- if .Values.reportDir }}

        volumeMounts:

        - name: report

          mountPath: {{ .Values.reportDir }}

      restartPolicy: Never

      volumes:

      - name: report

        hostPath:

          path: {{ .Values.reportDir }}

      {{ end }}

```

--values.yaml

> image: elastic/rally  
> reportDir: /tmp  
> reportFile: report-mem-lock.csv

---rally-ini-------

```
[meta]
config.version = 17

[system]
env.name = local

[node]
root.dir = /rally/.rally/benchmarks
src.root.dir = /rally/.rally/benchmarks/src

[source]
remote.repo.url = https://github.com/elastic/elasticsearch.git
elasticsearch.src.subdir = elasticsearch

[benchmarks]
local.dataset.cache = /rally/.rally/benchmarks/data

[reporting]
datastore.type = in-memory
datastore.host =
datastore.port =
datastore.secure = False
datastore.user =
datastore.password =

[tracks]
default.url = https://github.com/elastic/rally-tracks

[teams]
default.url = https://github.com/elastic/rally-teams

[defaults]
preserve_benchmark_candidate = false

[distributions]
release.cache = true

```

We are running behind a proxy, so i have set up http\_proxy and verified that rally is able to get tracks  
[proxy setting](https://esrally.readthedocs.io/en/stable/configuration.html#proxy-configuration)  
Command -  
`esrally race --track=geonames --target-hosts=example.elasticsearch.com --pipeline=benchmark-only --test-mode --kill-running-processes --client-options="timeout:60,use_ssl:true,verify_certs:false,basic_auth_user:'elastic',basic_auth_password:'password'"`

Getting the following error -

```
[WARNING] No Internet connection detected. Automatic download of track data sets etc. is disabled.
[ERROR] Cannot race. Error in race control (ConnectionError(<urllib3.connection.HTTPSConnection object at 0x7f621b4bca60>: Failed to establish a new connection: [Errno -2] Name or service not known) caused by: NewConnectionError(<urllib3.connection.HTTPSConnection object at 0x7f621b4bca60>: Failed to establish a new connection: [Errno -2] Name or service not known))

```

---

<div class="post-metadata">

**Author:** ![RickBoyd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rickboyd/32/80022_2.png) [@RickBoyd](https://discuss.elastic.co/u/RickBoyd)\
**Post date:** [April 15, 2021, 1:17pm UTC](https://discuss.elastic.co/t/how-to-run-rally-against-an-existing-on-premise-cluster/270228/2 "2021-04-15T13:17:11Z")

</div>

Hi! `Name or service not known` should indicate that your pod cannot resolve the address you gave to `--target-hosts`. Without going too deep here, consider:

Is there a defined Service name that you're hitting?  
Is the service for ES in the same namespace as the rally pod?  
If not, are you using the FQDN for the target service?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 13, 2021, 1:18pm UTC](https://discuss.elastic.co/t/how-to-run-rally-against-an-existing-on-premise-cluster/270228/3 "2021-05-13T13:18:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
