# How to set Elasticsearch 5 Network settings

**URL:** <https://discuss.elastic.co/t/how-to-set-elasticsearch-5-network-settings/69336>\
**Category:** Elasticsearch\
**Created:** [December 17, 2016, 8:05am UTC](https://discuss.elastic.co/t/how-to-set-elasticsearch-5-network-settings/69336 "2016-12-17T08:05:39Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![svarup](https://avatars.discourse-cdn.com/v4/letter/s/ee59a6/32.png) [@svarup](https://discuss.elastic.co/u/svarup)\
**Post date:** [December 17, 2016, 8:05am UTC](https://discuss.elastic.co/t/how-to-set-elasticsearch-5-network-settings/69336/1 "2016-12-17T08:05:39Z")

</div>

After changing **network.host** to my current IP address specified in **ifconfig** and **bootstrap.memory\_lock: true** elasticsearch does not start

Error:  
Dec 17 12:54:45 es-1 systemd[1]: Starting Elasticsearch...  
Dec 17 12:54:45 es-1 systemd[1]: Started Elasticsearch.  
Dec 17 12:55:59 es-1 systemd[1]: elasticsearch.service: Main process exited, code=exited, status=78/n/a  
Dec 17 12:55:59 es-1 systemd[1]: elasticsearch.service: Unit entered failed state.  
Dec 17 12:55:59 es-1 systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [December 17, 2016, 8:32am UTC](https://discuss.elastic.co/t/how-to-set-elasticsearch-5-network-settings/69336/2 "2016-12-17T08:32:17Z")

</div>

Read the logs.

Share them if you don't understand.

Also read: [https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html)

---

<div class="post-metadata">

**Author:** ![svarup](https://avatars.discourse-cdn.com/v4/letter/s/ee59a6/32.png) [@svarup](https://discuss.elastic.co/u/svarup)\
**Post date:** [December 17, 2016, 8:59am UTC](https://discuss.elastic.co/t/how-to-set-elasticsearch-5-network-settings/69336/3 "2016-12-17T08:59:37Z")

</div>

after setting **LimitMEMLOCK=infinity** in **/usr/lib/systemd/system/elasticsearch.service** problem is solved **thanks dadoonet**

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 14, 2017, 8:59am UTC](https://discuss.elastic.co/t/how-to-set-elasticsearch-5-network-settings/69336/4 "2017-01-14T08:59:37Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
