# How to visualize new install plugin in kibana

**URL:** <https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404>\
**Category:** Kibana\
**Created:** [May 31, 2016, 9:22am UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404 "2016-05-31T09:22:13Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)\
**Post date:** [May 31, 2016, 9:22am UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/1 "2016-05-31T09:22:13Z")

</div>

i copied kbn\_circles\_vis into src/plugins/.  
when i start kibana. it runs in browser properly. when i see its status it display:-  
plugin kbn\_circles\_vis=ready

but how to use that plugin in visualization.because in visualization we could not find any option for installed plugin.

---

<div class="post-metadata">

**Author:** ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)\
**Post date:** [May 31, 2016, 8:57pm UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/2 "2016-05-31T20:57:54Z")

</div>

If the plugin installed correctly and it's compatible with your version of Kibana it would most likely be added to the list of visualizations on the visualize page at `app/kibana#/visualize/step/1`. Can you share a link to the plugin and your Kibana version?

---

<div class="post-metadata">

**Author:** ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)\
**Post date:** [June 1, 2016, 4:24am UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/3 "2016-06-01T04:24:13Z")

</div>

kibana version is 4.4.2.  
plugin:- kbn\_circles\_vis.  
plugin installation steps:-

1. git clone [https://github.com/JuanCarniglia/kbn\_circles\_vis.git](https://github.com/JuanCarniglia/kbn_circles_vis.git)  
it creates kbn\_circles\_vis directory
2. then just copy the kbn\_circles\_vis folder into /src/plugins.
3. service kibana restart.
4. kibana started. its status shows that plugin ready with green signal.

---

<div class="post-metadata">

**Author:** ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)\
**Post date:** [June 1, 2016, 2:18pm UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/4 "2016-06-01T14:18:42Z")

</div>

It should be adding "Cirlces Diagram" to your list of visualizations, is that not the case?

 ![](https://us1.discourse-cdn.com/elastic/original/2X/3/36ac42410a81361171ba1a40a97c1f7577813188.png)

---

<div class="post-metadata">

**Author:** ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)\
**Post date:** [June 2, 2016, 4:04am UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/5 "2016-06-02T04:04:42Z")

</div>

circles diagram not display in my case.  
what should i do?

---

<div class="post-metadata">

**Author:** ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)\
**Post date:** [June 13, 2016, 7:29am UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/6 "2016-06-13T07:29:33Z")

</div>

please tell me complete steps for installation.

---

<div class="post-metadata">

**Author:** ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)\
**Post date:** [June 14, 2016, 5:37am UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/7 "2016-06-14T05:37:11Z")

</div>

Now i installed kibana 4.5 . its running.but when i  
cp -R kbn\_circles\_vis /opt/kibana/src/plugins/  
and remove kibana.\* files from bundle directory.  
kibana is not running.  
i checked  
cat /var/log/kibana/kibana.stderr.  
file contains:-  
FATAL [Error: Config schema already has key: kbn\_circles\_vis]  
FATAL [Error: Config schema already has key: kbn\_circles\_vis]  
FATAL [Error: Config schema already has key: kbn\_circles\_vis]  
FATAL [Error: Config schema already has key: kbn\_circles\_vis]  
FATAL [Error: Config schema already has key: kbn\_circles\_vis]  
FATAL [Error: Config schema already has key: kbn\_circles\_vis]  
FATAL [Error: Config schema already has key: kbn\_circles\_vis]  
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
cause:  
{ [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' },  
isOperational: true,  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' }  
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
cause:  
{ [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' },  
isOperational: true,  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' }  
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
cause:  
{ [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' },  
isOperational: true,  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' }  
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
cause:  
{ [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' },  
isOperational: true,  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' }  
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
cause:  
{ [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' },  
isOperational: true,  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' }  
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
cause:  
{ [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' },  
isOperational: true,  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' }  
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
cause:  
{ [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' },  
isOperational: true,  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' }  
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
cause:  
{ [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/kibana.entry.js']  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' },  
isOperational: true,  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/kibana.entry.js' }  
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/statusPage.entry.js']  
cause:  
{ [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/statusPage.entry.js']  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/statusPage.entry.js' },  
isOperational: true,  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/statusPage.entry.js' }  
FATAL { [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/statusPage.entry.js']  
cause:  
{ [Error: EACCES: permission denied, open '/opt/kibana/optimize/bundles/statusPage.entry.js']  
errno: -13,  
code: 'EACCES',  
syscall: 'open',  
path: '/opt/kibana/optimize/bundles/statusPage.entry.js' },

where is the problem?

---

<div class="post-metadata">

**Author:** ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)\
**Post date:** [June 15, 2016, 4:10pm UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/8 "2016-06-15T16:10:25Z")

</div>

That's caused by a current bug in kibana ([https://github.com/elastic/kibana/issues/6730](https://github.com/elastic/kibana/issues/6730)). Recursively setting the user and group on the optimize folder to kibana:kibana will fix that issue.

---

<div class="post-metadata">

**Author:** ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)\
**Post date:** [June 16, 2016, 10:49am UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/9 "2016-06-16T10:49:23Z")

</div>

how can i resolve this issue?  
please explain.

---

<div class="post-metadata">

**Author:** ![sarbjeet](https://avatars.discourse-cdn.com/v4/letter/s/e5b9ba/32.png) [@sarbjeet](https://discuss.elastic.co/u/sarbjeet)\
**Post date:** [June 17, 2016, 11:32am UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/10 "2016-06-17T11:32:50Z")

</div>

please reply .how can i resolve this issue?

---

<div class="post-metadata">

**Author:** ![jbudz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jbudz/32/45922_2.png) [@jbudz](https://discuss.elastic.co/u/jbudz)\
**Post date:** [June 21, 2016, 4:46pm UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/11 "2016-06-21T16:46:33Z")

</div>

Something like `chown -R kibana:kibana /opt/kibana/optimize` will make sure the package user kibana can use the files in /opt/kibana/optimize.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:49pm UTC](https://discuss.elastic.co/t/how-to-visualize-new-install-plugin-in-kibana/51404/12 "2017-07-06T13:49:43Z")

</div>


