# HTTP Poller not working - No errors

**URL:** https://discuss.elastic.co/t/http-poller-not-working-no-errors/128213
**Category:** Logstash
**Created:** [April 16, 2018, 2:48pm UTC](https://discuss.elastic.co/t/http-poller-not-working-no-errors/128213 "2018-04-16T14:48:15Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![juandanielpujols](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juandanielpujols/32/30041_2.png) [@juandanielpujols](https://discuss.elastic.co/u/juandanielpujols)
#### Post date: [April 16, 2018, 2:48pm UTC](https://discuss.elastic.co/t/http-poller-not-working-no-errors/128213/1 "2018-04-16T14:48:16Z")

</div>

Hi, i have the configuration below in my logstash.conf file. But is not working and is not givin any errors. I got a certificate error before that i solved with a jks. Any hints on how can i troubleshoot? NOTE: Is a containerized environment.

input {  
stdin{}  
http\_poller {  
urls =\> {  
epowebapi =\> {  
method =\> get  
user =\> "api\_user"  
password =\> "api\_Pass"  
url =\> "[https://xx.xx.xx.xx:9443/remote/core.executeQuery?queryId=855](https://xx.xx.xx.xx:9443/remote/core.executeQuery?queryId=855)"  
headers =\> {  
Accept =\> "application/json"  
}  
}  
}  
truststore =\> "/usr/share/logstash/pipeline/ssl/"  
truststore\_password =\> "Password"  
request\_timeout =\> 160  
schedule =\> { cron =\> "\* \* \* \* \* UTC"}  
codec =\> "json"  
metadata\_target =\> "http\_poller\_metadata"  
}  
}

output{  
elasticsearch {  
manage\_template =\> false  
hosts =\> "elasticsearch:9200"  
user =\> elastic  
password =\> changeme  
}  
stdout {}  
}

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [April 16, 2018, 6:52pm UTC](https://discuss.elastic.co/t/http-poller-not-working-no-errors/128213/2 "2018-04-16T18:52:38Z")

</div>

Increase the log level to get additional clues about what Logstash is doing. You could also try using Wireshark to see what network connections Logstash is making.

---

<div class="post-metadata">

### Author: ![juandanielpujols](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juandanielpujols/32/30041_2.png) [@juandanielpujols](https://discuss.elastic.co/u/juandanielpujols)
#### Post date: [April 16, 2018, 8:40pm UTC](https://discuss.elastic.co/t/http-poller-not-working-no-errors/128213/3 "2018-04-16T20:40:16Z")

</div>

This is what i get in the debug.

[2018-04-16T20:29:00,267][DEBUG][logstash.pipeline] Pushing flush onto pipeline {:pipeline\_id=\>"main", :thread=\>"#\<Thread:0x578503b6 sleep\>"}  
[2018-04-16T20:29:00,304][DEBUG][logstash.inputs.http\_poller] Fetching URL {:name=\>"ePoWebapi", :url=\>[:get, "[https://xx.xx.xx.xx:8443/remote/core.executeQuery?queryId=855](https://xx.xx.xx.xx:8443/remote/core.executeQuery?queryId=855)", {:headers=\>{"Accept"=\>"application/json"}, :auth=\>{:user=\>"api", :pass=\>"Pass", :eager=\>true}}]}  
[2018-04-16T20:29:00,501][DEBUG][logstash.instrument.periodicpoller.cgroup] Error, cannot retrieve cgroups information {:exception=\>"Errno::ENOENT", :message=\>"No such file or directory - /sys/fs/cgroup/cpuacct/docker/777382b06c8067aa9a580f9103bae5ec1bae4a4542157608010b9552811c6335/cpuacct.usage"}  
[2018-04-16T20:29:00,891][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ParNew"}  
[2018-04-16T20:29:00,897][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ConcurrentMarkSweep"}  
[2018-04-16T20:29:02,919][DEBUG][logstash.pipeline] Pushing flush onto pipeline {:pipeline\_id=\>".monitoring-logstash", :thread=\>"#\<Thread:0x7583fca2 sleep\>"}  
[2018-04-16T20:29:05,269][DEBUG][logstash.pipeline] Pushing flush onto pipeline {:pipeline\_id=\>"main", :thread=\>"#\<Thread:0x578503b6 sleep\>"}  
[2018-04-16T20:29:05,512][DEBUG][logstash.instrument.periodicpoller.cgroup] Error, cannot retrieve cgroups information {:exception=\>"Errno::ENOENT", :message=\>"No such file or directory - /sys/fs/cgroup/cpuacct/docker/777382b06c8067aa9a580f9103bae5ec1bae4a4542157608010b9552811c6335/cpuacct.usage"}  
[2018-04-16T20:29:05,912][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ParNew"}  
[2018-04-16T20:29:05,927][DEBUG][logstash.instrument.periodicpoller.jvm] collector name {:name=\>"ConcurrentMarkSweep"}  
[2018-04-16T20:29:07,930][DEBUG][logstash.pipeline] Pushing flush onto pipeline {:pipeline\_id=\>".monitoring-logstash", :thread=\>"#\<Thread:0x7583fca2 sleep\>"}  
[2018-04-16T20:29:08,582][DEBUG][logstash.inputs.metrics] Metrics input: received a new snapshot {:created\_at=\>2018-04-16 20:29:08 UTC, :snapshot=\>#\<LogStash::Instrument::Snapshot:0x4b38f652 @metric\_store=#\<LogStash::Instrument::MetricStore:0x2154bd22 @store=#\<Concurrent:🗺0x00000000000fbc entries=3 default\_proc=nil\>, @structured\_lookup\_mutex=#Mutex:0x23894583, @fast\_lookup=#\<Concurrent:🗺0x00000000000fc0 entries=84 default\_proc=nil\>\>, @created\_at=2018-04-16 20:29:08 UTC\>}

---

<div class="post-metadata">

### Author: ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)
#### Post date: [April 17, 2018, 10:14am UTC](https://discuss.elastic.co/t/http-poller-not-working-no-errors/128213/4 "2018-04-17T10:14:17Z")

</div>

Hmm, okay. Comment out your elasticsearch output and use a `stdout { codec => rubydebug }` output to dump the raw events. Are you getting anything?

---

<div class="post-metadata">

### Author: ![juandanielpujols](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juandanielpujols/32/30041_2.png) [@juandanielpujols](https://discuss.elastic.co/u/juandanielpujols)
#### Post date: [April 24, 2018, 8:23pm UTC](https://discuss.elastic.co/t/http-poller-not-working-no-errors/128213/5 "2018-04-24T20:23:17Z")

</div>

> [@magnusbaeck](#):
>
> codec =\> rubydebug

This is the output. No error, and stdout working fine.

docker attach logstashtest  
Sending Logstash's logs to /usr/share/logstash/logs which is now configured via log4j2.properties  
[2018-04-24T20:13:31,521][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"netflow", :directory=\>"/usr/share/logstash/modules/netflow/configuration"}  
[2018-04-24T20:13:31,549][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"fb\_apache", :directory=\>"/usr/share/logstash/modules/fb\_apache/configuration"}  
[2018-04-24T20:13:33,503][INFO][logstash.modules.scaffold] Initializing module {:module\_name=\>"arcsight", :directory=\>"/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/x-pack-6.2.3-java/modules/arcsight/configuration"}  
[2018-04-24T20:13:33,762][INFO][logstash.setting.writabledirectory] Creating directory {:setting=\>"path.queue", :path=\>"/usr/share/logstash/data/queue"}  
[2018-04-24T20:13:33,770][INFO][logstash.setting.writabledirectory] Creating directory {:setting=\>"path.dead\_letter\_queue", :path=\>"/usr/share/logstash/data/dead\_letter\_queue"}  
[2018-04-24T20:13:34,825][INFO][logstash.agent] No persistent UUID file found. Generating new UUID {:uuid=\>"39605706-a3f3-4a1d-b6a0-cbe04f7148ca", :path=\>"/usr/share/logstash/data/uuid"}  
[2018-04-24T20:13:36,324][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"6.2.3"}  
[2018-04-24T20:13:36,891][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2018-04-24T20:13:39,893][WARN][logstash.outputs.elasticsearch] You are using a deprecated config setting "document\_type" set in elasticsearch. Deprecated settings will continue to work, but are scheduled for removal from logstash in the future. Document types are being deprecated in Elasticsearch 6.0, and removed entirely in 7.0. You should avoid this feature If you have any questions about this, please visit the #logstash channel on freenode irc. {:name=\>"document\_type", :plugin=\>\<LogStash::Outputs::Elasticsearch hosts=\>[[http://elasticsearch:9200](http://elasticsearch:9200)], bulk\_path=\>"/\_xpack/monitoring/\_bulk?system\_id=logstash&system\_api\_version=2&interval=1s", manage\_template=\>false, document\_type=\>"%{[@metadata][document\_type]}", sniffing=\>false, user=\>"logstash\_system", password=\>, id=\>"a8534760ec12a086fe293ee32232f724b17c660fec5c5bee2bbb376965e5bb43", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_1e95cb1f-a8ce-4e24-b8fb-c9c450974adb", enable\_metric=\>true, charset=\>"UTF-8"\>, workers=\>1, template\_name=\>"logstash", template\_overwrite=\>false, doc\_as\_upsert=\>false, script\_type=\>"inline", script\_lang=\>"painless", script\_var\_name=\>"event", scripted\_upsert=\>false, retry\_initial\_interval=\>2, retry\_max\_interval=\>64, retry\_on\_conflict=\>1, action=\>"index", ssl\_certificate\_verification=\>true, sniffing\_delay=\>5, timeout=\>60, pool\_max=\>1000, pool\_max\_per\_route=\>100, resurrect\_delay=\>5, validate\_after\_inactivity=\>10000, http\_compression=\>false\>}  
[2018-04-24T20:13:40,038][INFO][logstash.pipeline] Starting pipeline {:pipeline\_id=\>".monitoring-logstash", "pipeline.workers"=\>1, "pipeline.batch.size"=\>2, "pipeline.batch.delay"=\>50}  
[2018-04-24T20:13:40,901][INFO][logstash.outputs.elasticsearch] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://logstash\_system:xxxxxx@elasticsearch:9200/](http://logstash_system:xxxxxx@elasticsearch:9200/)]}}  
[2018-04-24T20:13:40,931][INFO][logstash.outputs.elasticsearch] Running health check to see if an Elasticsearch connection is working {:healthcheck\_url=\>[http://logstash\_system:xxxxxx@elasticsearch:9200/](http://logstash_system:xxxxxx@elasticsearch:9200/), :path=\>"/"}  
[2018-04-24T20:13:41,329][WARN][logstash.outputs.elasticsearch] Restored connection to ES instance {:url=\>"[http://logstash\_system:xxxxxx@elasticsearch:9200/](http://logstash_system:xxxxxx@elasticsearch:9200/)"}  
[2018-04-24T20:13:41,418][INFO][logstash.outputs.elasticsearch] ES Output version determined {:es\_version=\>6}  
[2018-04-24T20:13:41,423][WARN][logstash.outputs.elasticsearch] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>6}  
[2018-04-24T20:13:41,451][INFO][logstash.outputs.elasticsearch] New Elasticsearch output {:class=\>"LogStash::Outputs::Elasticsearch", :hosts=\>["[http://elasticsearch:9200](http://elasticsearch:9200)"]}  
[2018-04-24T20:13:41,640][INFO][logstash.licensechecker.licensereader] Elasticsearch pool URLs updated {:changes=\>{:removed=\>, :added=\>[[http://logstash\_system:xxxxxx@elasticsearch:9200/](http://logstash_system:xxxxxx@elasticsearch:9200/)]}}  
[2018-04-24T20:13:41,642][INFO][logstash.licensechecker.licensereader] Running health check to see if an Elasticsearch connection is working {:healthcheck\_url=\>[http://logstash\_system:xxxxxx@elasticsearch:9200/](http://logstash_system:xxxxxx@elasticsearch:9200/), :path=\>"/"}  
[2018-04-24T20:13:41,651][WARN][logstash.licensechecker.licensereader] Restored connection to ES instance {:url=\>"[http://logstash\_system:xxxxxx@elasticsearch:9200/](http://logstash_system:xxxxxx@elasticsearch:9200/)"}  
[2018-04-24T20:13:41,660][INFO][logstash.licensechecker.licensereader] ES Output version determined {:es\_version=\>6}  
[2018-04-24T20:13:41,660][WARN][logstash.licensechecker.licensereader] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>6}  
[2018-04-24T20:13:41,845][INFO][logstash.pipeline] Pipeline started succesfully {:pipeline\_id=\>".monitoring-logstash", :thread=\>"#\<Thread:0x87cedd2 run\>"}  
[2018-04-24T20:13:47,518][INFO][logstash.pipeline] Starting pipeline {:pipeline\_id=\>"main", "pipeline.workers"=\>4, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>50}  
[2018-04-24T20:13:47,593][INFO][logstash.inputs.http\_poller] Registering http\_poller Input {:type=\>nil, :schedule=\>{"in"=\>"10 s"}, :timeout=\>nil}  
[2018-04-24T20:13:47,650][INFO][logstash.pipeline] Pipeline started succesfully {:pipeline\_id=\>"main", :thread=\>"#\<Thread:0x1d808cf sleep\>"}  
The stdin plugin is now waiting for input:  
[2018-04-24T20:13:47,766][INFO][logstash.agent] Pipelines running {:count=\>2, :pipelines=\>[".monitoring-logstash", "main"]}  
[2018-04-24T20:13:47,804][INFO][logstash.inputs.metrics] Monitoring License OK  
Test  
{  
"message" =\> "Test",  
"@version" =\> "1",  
"@timestamp" =\> 2018-04-24T20:14:29.394Z,  
"host" =\> "a147d8cf00cd"  
}  
Test2  
{  
"message" =\> "Test2",  
"@version" =\> "1",  
"@timestamp" =\> 2018-04-24T20:15:50.982Z,  
"host" =\> "a147d8cf00cd"  
}  
Test3  
{  
"message" =\> "Test3",  
"@version" =\> "1",  
"@timestamp" =\> 2018-04-24T20:22:14.592Z,  
"host" =\> "a147d8cf00cd"  
}

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 22, 2018, 8:23pm UTC](https://discuss.elastic.co/t/http-poller-not-working-no-errors/128213/6 "2018-05-22T20:23:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
