HttpClient calls not getting captured

I have a .Net Framework app where I included the AspNetFullFramework module. I downloaded the source and have successfully stepped into the code. I'm testing out my application against the APM and it's not capturing my HttpClient calls and I'm not sure why. I looked at how it's instrumented, but I can't figure out what supposed to make it capture the HttpClient calls. Can anyone give me some insight on how this is supposed to work so I can further debug why it's not working.

Thanks,
Mark

Hi @Mark_DeMichele,

That is strange, thanks for reporting this.

The way we capture HttpClient calls is that we use diagnosticsource. This is a good intro to that. A small note: On .NET Framework HttpClient sends different events compared to .NET Core.

Regarding how to debug: Setting a breakpoint to this line could help. That is the point where we receive the events - this is in a base class, which would end up in this class which is the implementation for Full Framework. So probably the 1. question is: does the OnNext method get called?

Additionally if you turn the log level to Trace and send the logs here, I'm also happy to look into that.

Thanks so much for the details. I'll see if I can test this.. I was using a free 14 trial of the APM from Elastic.co that's expiring on Monday. If I can get to this over the weekend, I will, just so we know what's going on. Otherwise, I may need stand up set of servers locally for testing. I have an Elastic Search Service Cluster already set up in AWS, but based on my investigations, they don't support APM events, though the version of Kibana they are using implies that it's there. Do you know if it's possible to get it working via the Elastic Search Service Cluster that AWS provides? I wonder if at a minimum, I can stand up one EC2 instance that runs APM and somehow send it's data to the AWS Elastic Search cluster. Right now I'm just shipping some logs to it using a Kinesis agent and a firehose. I'm not sure if I can leverage that at all.

Do you know if it's possible to get it working via the Elastic Search Service Cluster that AWS provides?

APM is not available on the AWS service. I think for debugging this, a local setup is the easiest. You can start Elasticsearch, Kibana, and the APM Server locally, these are basically 3 executables you need to start. No need for any configuration, the defaults work for basic debugging (at least I test like that a lot). For the .NET Agent if you don't configure the ServerUrls it'll also automatically send data to an APM Server on localhost. This is a good place to start: https://www.elastic.co/downloads/apm