# I always appear when using graph of x pack Error 500 Internal Server Error: An Internal Server Error occurred

**URL:** https://discuss.elastic.co/t/i-always-appear-when-using-graph-of-x-pack-error-500-internal-server-error-an-internal-server-error-occurred/78099
**Category:** Elasticsearch
**Created:** [March 10, 2017, 7:01am UTC](https://discuss.elastic.co/t/i-always-appear-when-using-graph-of-x-pack-error-500-internal-server-error-an-internal-server-error-occurred/78099 "2017-03-10T07:01:16Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![xuhaibo](https://avatars.discourse-cdn.com/v4/letter/x/34f0e0/32.png) [@xuhaibo](https://discuss.elastic.co/u/xuhaibo)
#### Post date: [March 10, 2017, 7:01am UTC](https://discuss.elastic.co/t/i-always-appear-when-using-graph-of-x-pack-error-500-internal-server-error-an-internal-server-error-occurred/78099/1 "2017-03-10T07:01:16Z")

</div>

I always appear when using graph of x pack Error 500 Internal Server Error: An Internal Server Error occurred .  
I have configured the account. And there are no close xpack any function

---

<div class="post-metadata">

### Author: ![rashmi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rashmi/32/16391_2.png) [@rashmi](https://discuss.elastic.co/u/rashmi)
#### Post date: [March 11, 2017, 11:50pm UTC](https://discuss.elastic.co/t/i-always-appear-when-using-graph-of-x-pack-error-500-internal-server-error-an-internal-server-error-occurred/78099/2 "2017-03-11T23:50:22Z")

</div>

Hi

Can you please provide us with the Build versions you are using ?

A good start to understand more graphs would be : [https://www.elastic.co/guide/en/x-pack/5.2/graph-getting-started.html](https://www.elastic.co/guide/en/x-pack/5.2/graph-getting-started.html)

The internal server error could be because when you select an index pattern to specify what indices you want to explore and select one or more multi value fields that contain the terms you want to graph, the relationship between the fields might not exist. The error message is misleading . There is already a github issue to address this.

Let us know if you need more help.

Thanks  
Rashmi

---

<div class="post-metadata">

### Author: ![xuhaibo](https://avatars.discourse-cdn.com/v4/letter/x/34f0e0/32.png) [@xuhaibo](https://discuss.elastic.co/u/xuhaibo)
#### Post date: [March 13, 2017, 3:41am UTC](https://discuss.elastic.co/t/i-always-appear-when-using-graph-of-x-pack-error-500-internal-server-error-an-internal-server-error-occurred/78099/3 "2017-03-13T03:41:18Z")

</div>

I'm using version 5.2.2. I've seen it many times, completely is according to the configuration document

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 10, 2017, 3:41am UTC](https://discuss.elastic.co/t/i-always-appear-when-using-graph-of-x-pack-error-500-internal-server-error-an-internal-server-error-occurred/78099/4 "2017-04-10T03:41:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
