# I am setting elasticsearch 8.5.3 but getting below error

**URL:** <https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216>\
**Category:** Elasticsearch\
**Created:** [January 16, 2023, 5:17am UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216 "2023-01-16T05:17:59Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![devdev7711](https://avatars.discourse-cdn.com/v4/letter/d/3be4f8/32.png) [@devdev7711](https://discuss.elastic.co/u/devdev7711)\
**Post date:** [January 16, 2023, 5:17am UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/1 "2023-01-16T05:17:59Z")

</div>

[2023-01-16T10:41:07,855][ERROR][o.e.i.g.GeoIpDownloader] [node-203] exception during geoip databases update  
java.net.SocketTimeoutException: Connect timed out  
at sun.nio.ch.NioSocketImpl.timedFinishConnect(NioSocketImpl.java:539) ~[?:?]  
at sun.nio.ch.NioSocketImpl.connect(NioSocketImpl.java:585) ~[?:?]  
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:327) ~[?:?]  
at java.net.Socket.connect(Socket.java:666) ~[?:?]  
at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:304) ~[?:?]  
at sun.net.NetworkClient.doConnect(NetworkClient.java:178) ~[?:?]  
at sun.net.www.http.HttpClient.openServer(HttpClient.java:531) ~[?:?]  
at sun.net.www.http.HttpClient.openServer(HttpClient.java:636) ~[?:?]  
at sun.net.www.protocol.https.HttpsClient.(HttpsClient.java:264) ~[?:?]  
at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:378) ~[?:?]  
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(AbstractDelegateHttpsURLConnection.java:193) ~[?:?]  
at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1241) ~[?:?]  
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1127) ~[?:?]  
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:179) ~[?:?]  
at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1661) ~[?:?]  
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1585) ~[?:?]  
at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:529) ~[?:?]  
at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:308) ~[?:?]  
at org.elasticsearch.ingest.geoip.HttpClient.lambda$get$0(HttpClient.java:46) ~[?:?]  
at java.security.AccessController.doPrivileged(AccessController.java:569) ~[?:?]  
at org.elasticsearch.ingest.geoip.HttpClient.doPrivileged(HttpClient.java:88) ~[?:?]  
at org.elasticsearch.ingest.geoip.HttpClient.get(HttpClient.java:40) ~[?:?]  
at org.elasticsearch.ingest.geoip.HttpClient.getBytes(HttpClient.java:36) ~[?:?]  
at org.elasticsearch.ingest.geoip.GeoIpDownloader.fetchDatabasesOverview(GeoIpDownloader.java:155) ~[?:?]  
at org.elasticsearch.ingest.geoip.GeoIpDownloader.updateDatabases(GeoIpDownloader.java:143) ~[?:?]  
at org.elasticsearch.ingest.geoip.GeoIpDownloader.runDownloader(GeoIpDownloader.java:274) ~[?:?]  
at org.elasticsearch.ingest.geoip.GeoIpDownloaderTaskExecutor.nodeOperation(GeoIpDownloaderTaskExecutor.java:102) ~[?:?]  
at org.elasticsearch.ingest.geoip.GeoIpDownloaderTaskExecutor.nodeOperation(GeoIpDownloaderTaskExecutor.java:48) ~[?:?]  
at org.elasticsearch.persistent.NodePersistentTasksExecutor$1.doRun(NodePersistentTasksExecutor.java:42) ~[elasticsearch-8.5.3.jar:?]  
at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:892) ~[elasticsearch-8.5.3.jar:?]  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:26) ~[elasticsearch-8.5.3.jar:?]  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1144) ~[?:?]  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:642) ~[?:?]  
at java.lang.Thread.run(Thread.java:1589) ~[?:?]

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [January 16, 2023, 5:58am UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/2 "2023-01-16T05:58:42Z")

</div>

I suggest you read this I detail.

> **[GeoIP processor | Elasticsearch Guide \[8.11\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/geoip-processor.html)**

> By default, the processor uses the GeoLite2 City, GeoLite2 Country, and GeoLite2 ASN GeoIP2 databases from MaxMind, shared under the CC BY-SA 4.0 license. Elasticsearch automatically downloads updates for these databases from the Elastic GeoIP endpoint: [https://geoip.elastic.co/v1/database](https://geoip.elastic.co/v1/database). To get download statistics for these updates, use the GeoIP stats API.

If you do not plan to use geoip you can [disable](https://www.elastic.co/guide/en/elasticsearch/reference/current/geoip-processor.html#geoip-cluster-settings)

---

<div class="post-metadata">

**Author:** ![devdev7711](https://avatars.discourse-cdn.com/v4/letter/d/3be4f8/32.png) [@devdev7711](https://discuss.elastic.co/u/devdev7711)\
**Post date:** [January 16, 2023, 6:34am UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/3 "2023-01-16T06:34:54Z")

</div>

after Disable it is working fine but I am getting this error  
[node-1] This node is a fully-formed single-node cluster with cluster UUID [e1Pg5eAWRgy3aNdJKGmzvg], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.

elasticsearch service is not working url is not opening. I am not getting any error in log after above warn nothing is displaying

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [January 16, 2023, 6:49am UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/4 "2023-01-16T06:49:34Z")

</div>

That's a different error ... I would open another topic with that error...

Basically it looks like you probably originally started that node in as a single-node... As the error says if you want it to form the a cluster you will need to clean the data path

Perhaps open a new thread with that error

---

<div class="post-metadata">

**Author:** ![devdev7711](https://avatars.discourse-cdn.com/v4/letter/d/3be4f8/32.png) [@devdev7711](https://discuss.elastic.co/u/devdev7711)\
**Post date:** [January 16, 2023, 7:00am UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/5 "2023-01-16T07:00:28Z")

</div>

How can we clean data and clean old cluster and old node and install elasticsearch fresh

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [January 16, 2023, 11:35am UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/6 "2023-01-16T11:35:48Z")

</div>

I have the same errors in my log: _[ERROR][o.e.i.g.GeoIpDownloader] [elk1] exception during geoip databases update_, however, can work with ELK without problems.  
It might be your elasticsearch.yml doesn't have correct params. Is that single or multinode?

ES keeps the configuration in elasticsearch.yml  
To clean data just remove directories:  
path.data: /path1/data  
path.logs: /path2/logs

If you install from rpm use the command: rpm -e elasticsearch  
If you install from zip, just delete directory.

---

<div class="post-metadata">

**Author:** ![devdev7711](https://avatars.discourse-cdn.com/v4/letter/d/3be4f8/32.png) [@devdev7711](https://discuss.elastic.co/u/devdev7711)\
**Post date:** [January 17, 2023, 9:55am UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/7 "2023-01-17T09:55:43Z")

</div>

Now when I am clicking elasticsearch.bat getting below logs service is not starting.

[2023-01-17T15:14:37,919][INFO][o.e.n.Node] [node-1] version[8.5.3], pid[12252], build[zip/4ed5ee9afac63de92ec98f404ccbed7d3ba9584e/2022-12-05T18:22:22.226119656Z], OS[Windows Server 2012 R2/6.3/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/19.0.1/19.0.1+10-21]  
[2023-01-17T15:14:37,935][INFO][o.e.n.Node] [node-1] JVM home [E:\setup\elasticsearch-8.5.3-windows-x86\_64\elasticsearch-8.5.3\jdk], using bundled JDK [true]  
[2023-01-17T15:14:37,950][INFO][o.e.n.Node] [node-1] JVM arguments [-Des.networkaddress.cache.ttl=60, -Des.networkaddress.cache.negative.ttl=10, -Djava.security.manager=allow, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -XX:-OmitStackTraceInFastThrow, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j2.formatMsgNoLookups=true, -Djava.locale.providers=SPI,COMPAT, --add-opens=java.base/java.io=ALL-UNNAMED, -XX:+UseG1GC, -Djava.io.tmpdir=C:\Users\VS0077~1\AppData\Local\Temp\5\elasticsearch, -XX:+HeapDumpOnOutOfMemoryError, -XX:+ExitOnOutOfMemoryError, -XX:HeapDumpPath=data, -XX:ErrorFile=logs/hs\_err\_pid%p.log, -Xlog:gc\*,gc+age=trace,safepoint:file=logs/gc.log:utctime,pid,tags:filecount=32,filesize=64m, -Xms4095m, -Xmx4095m, -XX:MaxDirectMemorySize=2147483648, -XX:G1HeapRegionSize=4m, -XX:InitiatingHeapOccupancyPercent=30, -XX:G1ReservePercent=15, -Des.distribution.type=zip, --module-path=E:\setup\elasticsearch-8.5.3-windows-x86\_64\elasticsearch-8.5.3\lib, --add-modules=[jdk.net](http://jdk.net), -Djdk.module.main=org.elasticsearch.server]  
[2023-01-17T15:14:44,216][INFO][c.a.c.i.j.JacksonVersion] [node-1] Package versions: jackson-annotations=2.13.2, jackson-core=2.13.2, jackson-databind=2.13.2.2, jackson-dataformat-xml=2.13.2, jackson-datatype-jsr310=2.13.2, azure-core=1.27.0, Troubleshooting version conflicts: [Troubleshoot dependency version conflicts when using the Azure SDK for Java | Microsoft Learn](https://aka.ms/azsdk/java/dependency/troubleshoot)  
[2023-01-17T15:14:47,982][INFO][o.e.p.PluginsService] [node-1] loaded module [aggs-matrix-stats]  
[2023-01-17T15:14:47,982][INFO][o.e.p.PluginsService] [node-1] loaded module [analysis-common]  
[2023-01-17T15:14:47,982][INFO][o.e.p.PluginsService] [node-1] loaded module [apm]  
[2023-01-17T15:14:47,982][INFO][o.e.p.PluginsService] [node-1] loaded module [constant-keyword]  
[2023-01-17T15:14:47,982][INFO][o.e.p.PluginsService] [node-1] loaded module [data-streams]  
[2023-01-17T15:14:47,982][INFO][o.e.p.PluginsService] [node-1] loaded module [frozen-indices]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [ingest-attachment]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [ingest-common]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [ingest-geoip]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [ingest-user-agent]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [kibana]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [lang-expression]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [lang-mustache]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [lang-painless]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [legacy-geo]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [mapper-extras]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [mapper-version]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [old-lucene-versions]  
[2023-01-17T15:14:47,997][INFO][o.e.p.PluginsService] [node-1] loaded module [parent-join]  
[2023-01-17T15:14:48,013][INFO][o.e.p.PluginsService] [node-1] loaded module [percolator]  
[2023-01-17T15:14:48,013][INFO][o.e.p.PluginsService] [node-1] loaded module [rank-eval]  
[2023-01-17T15:14:48,013][INFO][o.e.p.PluginsService] [node-1] loaded module [reindex]  
[2023-01-17T15:14:48,013][INFO][o.e.p.PluginsService] [node-1] loaded module [repositories-metering-api]  
[2023-01-17T15:14:48,013][INFO][o.e.p.PluginsService] [node-1] loaded module [repository-azure]  
[2023-01-17T15:14:48,013][INFO][o.e.p.PluginsService] [node-1] loaded module [repository-encrypted]  
[2023-01-17T15:14:48,013][INFO][o.e.p.PluginsService] [node-1] loaded module [repository-gcs]  
[2023-01-17T15:14:48,013][INFO][o.e.p.PluginsService] [node-1] loaded module [repository-s3]  
[2023-01-17T15:14:48,013][INFO][o.e.p.PluginsService] [node-1] loaded module [repository-url]  
[2023-01-17T15:14:48,013][INFO][o.e.p.PluginsService] [node-1] loaded module [runtime-fields-common]  
[2023-01-17T15:14:48,013][INFO][o.e.p.PluginsService] [node-1] loaded module [search-business-rules]  
[2023-01-17T15:14:48,029][INFO][o.e.p.PluginsService] [node-1] loaded module [searchable-snapshots]  
[2023-01-17T15:14:48,029][INFO][o.e.p.PluginsService] [node-1] loaded module [snapshot-based-recoveries]  
[2023-01-17T15:14:48,029][INFO][o.e.p.PluginsService] [node-1] loaded module [snapshot-repo-test-kit]  
[2023-01-17T15:14:48,029][INFO][o.e.p.PluginsService] [node-1] loaded module [spatial]  
[2023-01-17T15:14:48,029][INFO][o.e.p.PluginsService] [node-1] loaded module [transform]  
[2023-01-17T15:14:48,044][INFO][o.e.p.PluginsService] [node-1] loaded module [transport-netty4]  
[2023-01-17T15:14:48,044][INFO][o.e.p.PluginsService] [node-1] loaded module [unsigned-long]  
[2023-01-17T15:14:48,044][INFO][o.e.p.PluginsService] [node-1] loaded module [vector-tile]  
[2023-01-17T15:14:48,044][INFO][o.e.p.PluginsService] [node-1] loaded module [wildcard]  
[2023-01-17T15:14:48,044][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-aggregate-metric]  
[2023-01-17T15:14:48,044][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-analytics]  
[2023-01-17T15:14:48,060][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-async]  
[2023-01-17T15:14:48,060][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-async-search]  
[2023-01-17T15:14:48,060][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-autoscaling]  
[2023-01-17T15:14:48,060][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-ccr]  
[2023-01-17T15:14:48,060][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-core]  
[2023-01-17T15:14:48,060][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-deprecation]  
[2023-01-17T15:14:48,060][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-enrich]  
[2023-01-17T15:14:48,060][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-eql]  
[2023-01-17T15:14:48,060][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-fleet]  
[2023-01-17T15:14:48,060][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-graph]  
[2023-01-17T15:14:48,060][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-identity-provider]  
[2023-01-17T15:14:48,075][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-ilm]  
[2023-01-17T15:14:48,075][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-logstash]  
[2023-01-17T15:14:48,075][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-ml]  
[2023-01-17T15:14:48,075][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-monitoring]  
[2023-01-17T15:14:48,075][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-ql]  
[2023-01-17T15:14:48,075][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-rollup]  
[2023-01-17T15:14:48,075][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-security]  
[2023-01-17T15:14:48,075][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-shutdown]  
[2023-01-17T15:14:48,075][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-sql]  
[2023-01-17T15:14:48,075][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-stack]  
[2023-01-17T15:14:48,075][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-text-structure]  
[2023-01-17T15:14:48,091][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-voting-only-node]  
[2023-01-17T15:14:48,091][INFO][o.e.p.PluginsService] [node-1] loaded module [x-pack-watcher]  
[2023-01-17T15:14:48,091][INFO][o.e.p.PluginsService] [node-1] no plugins loaded  
[2023-01-17T15:14:54,982][WARN][stderr] [node-1] Jan 17, 2023 3:14:54 PM org.apache.lucene.store.MMapDirectory lookupProvider  
[2023-01-17T15:14:54,982][WARN][stderr] [node-1] WARNING: You are running with Java 19. To make full use of MMapDirectory, please pass '--enable-preview' to the Java command line.  
[2023-01-17T15:14:55,013][INFO][o.e.e.NodeEnvironment] [node-1] using [1] data paths, mounts [[New Volume (E:)]], net usable\_space [7.2gb], net total\_space [49.9gb], types [NTFS]  
[2023-01-17T15:14:55,013][INFO][o.e.e.NodeEnvironment] [node-1] heap size [4gb], compressed ordinary object pointers [true]  
[2023-01-17T15:14:55,185][INFO][o.e.n.Node] [node-1] node name [node-1], node ID [CTG69\_BqSayLFuEcdgb0gQ], cluster name [UNO-application], roles [data\_cold, ingest, data\_frozen, ml, data\_hot, transform, data\_content, data\_warm, master, remote\_cluster\_client, data]  
[2023-01-17T15:15:02,122][INFO][o.e.x.s.Security] [node-1] Security is disabled  
[2023-01-17T15:15:02,372][INFO][o.e.x.m.p.l.CppLogMessageHandler] [node-1] [controller/8712] [Main.cc@123] controller (64 bit): Version 8.5.3 (Build 32c68d5e2f9f8f) Copyright (c) 2022 Elasticsearch BV  
[2023-01-17T15:15:03,926][INFO][o.e.t.n.NettyAllocator] [node-1] creating NettyAllocator with the following configs: [name=elasticsearch\_configured, chunk\_size=1mb, suggested\_max\_allocation\_size=1mb, factors={es.unsafe.use\_netty\_default\_chunk\_and\_page\_size=false, g1gc\_enabled=true, g1gc\_region\_size=4mb}]  
[2023-01-17T15:15:03,991][INFO][o.e.i.r.RecoverySettings] [node-1] using rate limit [40mb] with [default=40mb, read=0b, write=0b, max=0b]  
[2023-01-17T15:15:04,060][INFO][o.e.d.DiscoveryModule] [node-1] using discovery type [single-node] and seed hosts providers [settings]  
[2023-01-17T15:15:07,169][INFO][o.e.n.Node] [node-1] initialized  
[2023-01-17T15:15:07,185][INFO][o.e.n.Node] [node-1] starting ...  
[2023-01-17T15:15:07,216][INFO][o.e.x.s.c.f.PersistentCache] [node-1] persistent cache index loaded  
[2023-01-17T15:15:07,216][INFO][o.e.x.d.l.DeprecationIndexingComponent] [node-1] deprecation component started  
[2023-01-17T15:15:07,544][INFO][o.e.t.TransportService] [node-1] publish\_address {127.0.0.1:9300}, bound\_addresses {127.0.0.1:9300}, {[::1]:9300}  
[2023-01-17T15:15:08,044][WARN][o.e.c.c.ClusterBootstrapService] [node-1] this node is locked into cluster UUID [RDQafVKZRXiwbpZQiZEiUQ] but [cluster.initial\_master\_nodes] is set to [node-1]; remove this setting to avoid possible data loss caused by subsequent cluster bootstrap attempts  
[2023-01-17T15:15:08,247][INFO][o.e.c.s.MasterService] [node-1] elected-as-master ([1] nodes joined)[_FINISH\_ELECTION_, {node-1}{CTG69\_BqSayLFuEcdgb0gQ}{4xGQhH1aSQa4NY90gGcUZg}{node-1}{127.0.0.1}{127.0.0.1:9300}{cdfhilmrstw} completing election], term: 2, version: 23, delta: master node changed {previous , current [{node-1}{CTG69\_BqSayLFuEcdgb0gQ}{4xGQhH1aSQa4NY90gGcUZg}{node-1}{127.0.0.1}{127.0.0.1:9300}{cdfhilmrstw}]}  
[2023-01-17T15:15:08,372][INFO][o.e.c.s.ClusterApplierService] [node-1] master node changed {previous , current [{node-1}{CTG69\_BqSayLFuEcdgb0gQ}{4xGQhH1aSQa4NY90gGcUZg}{node-1}{127.0.0.1}{127.0.0.1:9300}{cdfhilmrstw}]}, term: 2, version: 23, reason: Publication{term=2, version=23}  
[2023-01-17T15:15:08,529][INFO][o.e.c.r.a.DiskThresholdMonitor] [node-1] low disk watermark [85%] exceeded on [CTG69\_BqSayLFuEcdgb0gQ][node-1][E:\setup\elasticsearch-8.5.3-windows-x86\_64\elasticsearch-8.5.3\data] free: 7.2gb[14.5%], replicas will not be assigned to this node  
[2023-01-17T15:15:08,544][INFO][o.e.r.s.FileSettingsService] [node-1] starting file settings watcher ...  
[2023-01-17T15:15:08,591][INFO][o.e.h.AbstractHttpServerTransport] [node-1] publish\_address {10.179.32.143:9301}, bound\_addresses {10.179.32.143:9301}  
[2023-01-17T15:15:08,591][INFO][o.e.n.Node] [node-1] started {node-1}{CTG69\_BqSayLFuEcdgb0gQ}{4xGQhH1aSQa4NY90gGcUZg}{node-1}{127.0.0.1}{127.0.0.1:9300}{cdfhilmrstw}{ml.allocated\_processors=2, ml.max\_jvm\_size=4294967296, ml.allocated\_processors\_double=2.0, xpack.installed=true, ml.machine\_memory=8589516800}  
[2023-01-17T15:15:08,607][INFO][o.e.r.s.FileSettingsService] [node-1] file settings service up and running [tid=49]  
[2023-01-17T15:15:08,872][INFO][o.e.l.LicenseService] [node-1] license [38f6488c-150c-483d-97e9-5c8c5c1ae1e1] mode [basic] - valid  
[2023-01-17T15:15:08,904][INFO][o.e.g.GatewayService] [node-1] recovered [0] indices into cluster\_state  
[2023-01-17T15:15:09,083][INFO][o.e.h.n.s.HealthNodeTaskExecutor] [node-1] Node [{node-1}{CTG69\_BqSayLFuEcdgb0gQ}] is selected as the current health node.  
[2023-01-17T15:15:38,232][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:16:08,239][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:16:38,246][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:17:08,249][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:17:38,263][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:18:08,279][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:18:38,294][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:19:08,310][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:19:38,326][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:20:08,341][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:20:38,357][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:21:08,373][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:21:38,388][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:22:08,404][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:22:38,420][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:23:08,435][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:23:38,451][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.  
[2023-01-17T15:24:08,453][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting. Fully-formed clusters do not attempt to discover other nodes, and nodes with different cluster UUIDs cannot belong to the same cluster. The cluster UUID persists across restarts and can only be changed by deleting the contents of the node's data path(s). Remove the discovery configuration to suppress this message.

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [January 17, 2023, 11:20am UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/8 "2023-01-17T11:20:56Z")

</div>

> [@devdev7711](#):
>
> [2023-01-17T15:21:38,388][WARN][o.e.c.c.Coordinator] [node-1] This node is a fully-formed single-node cluster with cluster UUID [RDQafVKZRXiwbpZQiZEiUQ], but it is configured as if to discover other nodes and form a multi-node cluster via the [discovery.seed\_hosts=[CVMP6543]] setting.

Is your intention to have a single node or multi-node?

---

<div class="post-metadata">

**Author:** ![devdev7711](https://avatars.discourse-cdn.com/v4/letter/d/3be4f8/32.png) [@devdev7711](https://discuss.elastic.co/u/devdev7711)\
**Post date:** [January 17, 2023, 12:17pm UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/9 "2023-01-17T12:17:21Z")

</div>

only single node.  
but i changed nodes name multiple times and run elasticsearch.bat file i want only one node.

---

<div class="post-metadata">

**Author:** ![Rios](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rios/32/95745_2.png) [@Rios](https://discuss.elastic.co/u/Rios)\
**Post date:** [January 17, 2023, 12:30pm UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/10 "2023-01-17T12:30:30Z")

</div>

For the single-node elasticsearch, you need next settings?

```auto
cluster.name: <somename>
node.name: <set name or will be hostname>
path.data: /path/data
path.logs: /path/logs

network.host: 0.0.0.0
http.port: 9200
discovery.type: single-node

```

---

<div class="post-metadata">

**Author:** ![devdev7711](https://avatars.discourse-cdn.com/v4/letter/d/3be4f8/32.png) [@devdev7711](https://discuss.elastic.co/u/devdev7711)\
**Post date:** [January 17, 2023, 12:35pm UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/11 "2023-01-17T12:35:42Z")

</div>

my setting is the same i am thinking due to multiple node change and multiple run created issue I am deleting and creating again

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 14, 2023, 12:36pm UTC](https://discuss.elastic.co/t/i-am-setting-elasticsearch-8-5-3-but-getting-below-error/323216/12 "2023-02-14T12:36:22Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
