# I cannot start elasticseach service

**URL:** https://discuss.elastic.co/t/i-cannot-start-elasticseach-service/51840
**Category:** Elasticsearch
**Created:** [June 3, 2016, 11:45pm UTC](https://discuss.elastic.co/t/i-cannot-start-elasticseach-service/51840 "2016-06-03T23:45:15Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![condescendent](https://avatars.discourse-cdn.com/v4/letter/c/b5ac83/32.png) [@condescendent](https://discuss.elastic.co/u/condescendent)
#### Post date: [June 3, 2016, 11:45pm UTC](https://discuss.elastic.co/t/i-cannot-start-elasticseach-service/51840/1 "2016-06-03T23:45:15Z")

</div>

I got an old system in my new position 🙂  
It looks like a elasticsearch + logstash server.

When i tried to open the elasticseach link, it complains about the service.  
"Error Could not contact Elasticseach at [http://kibana.ec2.avery.com:9200](http://kibana.ec2.avery.com:9200). Please ensure that ElasticSearch is reachable from your system.

root@monitor:/usr/share$ cd elasticsearch  
root@monitor:/usr/share/elasticsearch$ ./bin/elasticsearch  
Failed to configure logging...  
org.elasticsearch.ElasticsearchException: Failed to load logging configuration  
at org.elasticsearch.common.logging.log4j.LogConfigurator.resolveConfig(LogConfigurator.java:135)  
at org.elasticsearch.common.logging.log4j.LogConfigurator.configure(LogConfigurator.java:85)  
at org.elasticsearch.bootstrap.Bootstrap.setupLogging(Bootstrap.java:94)  
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:178)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)  
Caused by: java.nio.file.NoSuchFileException: /usr/share/elasticsearch/config  
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:86)  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)  
at sun.nio.fs.UnixFileAttributeViews$Basic.readAttributes(UnixFileAttributeViews.java:55)  
at sun.nio.fs.UnixFileSystemProvider.readAttributes(UnixFileSystemProvider.java:144)  
at sun.nio.fs.LinuxFileSystemProvider.readAttributes(LinuxFileSystemProvider.java:97)  
at java.nio.file.Files.readAttributes(Files.java:1686)  
at java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:109)  
at java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:69)  
at java.nio.file.Files.walkFileTree(Files.java:2602)  
at org.elasticsearch.common.logging.log4j.LogConfigurator.resolveConfig(LogConfigurator.java:119)  
... 4 more  
log4j:WARN No appenders could be found for logger (node).  
log4j:WARN Please initialize the log4j system properly.  
log4j:WARN See [http://logging.apache.org/log4j/1.2/faq.html#noconfig](http://logging.apache.org/log4j/1.2/faq.html#noconfig) for more info.  
^Croot@monitor:/usr/share/elasticsearch$ pwd  
/usr/share/elasticsearch  
root@monitor:/usr/share/elasticsearch$

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [June 4, 2016, 1:51am UTC](https://discuss.elastic.co/t/i-cannot-start-elasticseach-service/51840/2 "2016-06-04T01:51:56Z")

</div>

Don't run ES as root!

It looks like you have installed it using a deb/rpm, if so, use the OS service management.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:46pm UTC](https://discuss.elastic.co/t/i-cannot-start-elasticseach-service/51840/3 "2017-07-05T22:46:17Z")

</div>


