# I cannot start logstash on my machine. Error message inside

**URL:** <https://discuss.elastic.co/t/i-cannot-start-logstash-on-my-machine-error-message-inside/88900>\
**Category:** Logstash\
**Created:** [June 10, 2017, 12:07am UTC](https://discuss.elastic.co/t/i-cannot-start-logstash-on-my-machine-error-message-inside/88900 "2017-06-10T00:07:39Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![dona](https://avatars.discourse-cdn.com/v4/letter/d/7c8e57/32.png) [@dona](https://discuss.elastic.co/u/dona)\
**Post date:** [June 10, 2017, 12:07am UTC](https://discuss.elastic.co/t/i-cannot-start-logstash-on-my-machine-error-message-inside/88900/1 "2017-06-10T00:07:40Z")

</div>

The following is the test command from the tutorial:

`./logstash -e 'input { stdin { } } output { stdout {} }'`

The following is the error.

```
WARNING: Could not find logstash.yml which is typically located in $LS_HOME/config or /etc/logstash. You can specify the path using --path.settings. Continuing using the defaults
Could not find log4j2 configuration at path //usr/share/logstash/config/log4j2.properties. Using default config which logs to console
01:55:14.242 [main] FATAL logstash.runner - An unexpected error occurred! {:error=>#<ArgumentError: Path "/usr/share/logstash/data" must be a writable directory. It is not writable.>, :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/settings.rb:433:in `validate'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:216:in `validate_value'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:132:in `validate_all'", "org/jruby/RubyHash.java:1342:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:131:in `validate_all'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:217:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:185:in `run'", "/usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:71:in `(root)'"]}

```

As for the error message part that says:

`Path "/usr/share/logstash/data" must be a writable directory. It is not writable.`

The directory is owned and writable by logstash.

Can anyone suggest any solutions?

---

<div class="post-metadata">

**Author:** ![Makra](https://avatars.discourse-cdn.com/v4/letter/m/8491ac/32.png) [@Makra](https://discuss.elastic.co/u/Makra)\
**Post date:** [June 10, 2017, 1:49am UTC](https://discuss.elastic.co/t/i-cannot-start-logstash-on-my-machine-error-message-inside/88900/2 "2017-06-10T01:49:33Z")

</div>

> [@dona](#):
>
> Path "/usr/share/logstash/data" must be a writable directory. It is not writable.

The directory /usr/share/logstash must be owned by logstash and the permission of data directory should be 777

$ chown -R logstash.logstash /usr/share/logstash  
$ chmod 777 /usr/share/logstash/data

Also check the user who owns logstash in /etc/default/logstash by default it is logstash.

.................................  
................................  
LS\_USER="logstash"  
LS\_GROUP="logstash"  
...............................  
..............................

---

<div class="post-metadata">

**Author:** ![dona](https://avatars.discourse-cdn.com/v4/letter/d/7c8e57/32.png) [@dona](https://discuss.elastic.co/u/dona)\
**Post date:** [June 10, 2017, 12:43pm UTC](https://discuss.elastic.co/t/i-cannot-start-logstash-on-my-machine-error-message-inside/88900/3 "2017-06-10T12:43:59Z")

</div>

I ran your commands and the ownership of /usr/share/logstash are fine. Initially the /etc/default/logstash was owned by root actually but I fixed it and it is now owned by logstash too. However, when I ran the same command as above now, I get nothing out of it. Not even an error message. The command just runs indefinitely blocking the command line. It's stuck somewhere.

Edit:  
Nevermind, it worked. It just too a long time to set up the pipeline for some reason. Thank you 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 8, 2017, 12:44pm UTC](https://discuss.elastic.co/t/i-cannot-start-logstash-on-my-machine-error-message-inside/88900/4 "2017-07-08T12:44:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
