# I can't start Kibana on Ubuntu 16.04

**URL:** https://discuss.elastic.co/t/i-cant-start-kibana-on-ubuntu-16-04/222180
**Category:** Kibana
**Created:** [March 4, 2020, 11:52pm UTC](https://discuss.elastic.co/t/i-cant-start-kibana-on-ubuntu-16-04/222180 "2020-03-04T23:52:12Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Mohamed\_Koubaa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mohamed_koubaa/32/63843_2.png) [@Mohamed\_Koubaa](https://discuss.elastic.co/u/Mohamed_Koubaa)
#### Post date: [March 4, 2020, 11:52pm UTC](https://discuss.elastic.co/t/i-cant-start-kibana-on-ubuntu-16-04/222180/1 "2020-03-04T23:52:12Z")

</div>

I installed the ELK package. Elasticsearch, kibana and logstash. Elasticsear seems to be working fine but i can't seem to be able to start kibana.  
Here are the results of `sudo service kibana status`

> kibana.service - Kibana  
> Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: e  
> Active: failed (Result: start-limit-hit) since خ 2020-03-05 00:09:07 CET; 4mi  
> Process: 2550 ExecStart=/usr/share/kibana/bin/kibana -c /etc/kibana/kibana.yml  
> Main PID: 2550 (code=exited, status=1/FAILURE)
> 
> مار 05 00:09:06 bruce-VirtualBox systemd[1]: kibana.service: Main process exited  
> مار 05 00:09:06 bruce-VirtualBox systemd[1]: kibana.service: Unit entered failed  
> مار 05 00:09:06 bruce-VirtualBox systemd[1]: kibana.service: Failed with result  
> مار 05 00:09:07 bruce-VirtualBox systemd[1]: kibana.service: Service hold-off ti  
> مار 05 00:09:07 bruce-VirtualBox systemd[1]: Stopped Kibana.  
> مار 05 00:09:07 bruce-VirtualBox systemd[1]: kibana.service: Start request repea  
> مار 05 00:09:07 bruce-VirtualBox systemd[1]: Failed to start Kibana.  
> مار 05 00:09:07 bruce-VirtualBox systemd[1]: kibana.service: Unit entered failed  
> مار 05 00:09:07 bruce-VirtualBox systemd[1]: kibana.service: Failed with result

and here are the contents of the kibana.yml file

> Kibana is served by a back end server. This setting specifies the port to use.  
> #server.port: 5601
> 
> # Specifies the address to which the Kibana server will bind. IP addresses and $
> 
> # The default is 'localhost', which usually means remote machines will not be a$
> 
> # To allow connections from remote users, set this parameter to a non-loopback $
> 
> #server.host: "localhost"
> 
> # Enables you to specify a path to mount Kibana at if you are running behind a $
> 
> # Use the `server.rewriteBasePath` setting to tell Kibana if it should remove t$
> 
> # from requests it receives, and to prevent a deprecation warning at startup.
> 
> # This setting cannot end in a slash.
> 
> #server.basePath: ""
> 
> # Specifies whether Kibana should rewrite requests that are prefixed with
> 
> # `server.basePath` or require that they are rewritten by your reverse proxy.
> 
> # This setting was effectively always `false` before Kibana 6.3 and will
> 
> # default to `true` starting in Kibana 7.0.
> 
> #server.rewriteBasePath: false
> 
> # from requests it receives, and to prevent a deprecation warning at startup.
> 
> # This setting cannot end in a slash.
> 
> #server.basePath: ""
> 
> # Specifies whether Kibana should rewrite requests that are prefixed with
> 
> # `server.basePath` or require that they are rewritten by your reverse proxy.
> 
> # This setting was effectively always `false` before Kibana 6.3 and will
> 
> # default to `true` starting in Kibana 7.0.
> 
> #server.rewriteBasePath: false
> 
> # The maximum payload size in bytes for incoming server requests.
> 
> #server.maxPayloadBytes: 1048576
> 
> # The Kibana server's name. This is used for display purposes.
> 
> server.name: "localhost"
> 
> # The URLs of the Elasticsearch instances to use for all your queries.
> 
> #elasticsearch.hosts: ["[http://localhost:9200](http://localhost:9200)"]  
> elasticsearch.url:"[http://localhost:9200](http://localhost:9200)"

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [March 5, 2020, 7:34pm UTC](https://discuss.elastic.co/t/i-cant-start-kibana-on-ubuntu-16-04/222180/2 "2020-03-05T19:34:56Z")

</div>

Please format your code/logs/config using the `</>` button in the text editor, or markdown style back ticks. It helps to make things easy to read which helps us help you 🙂

What do the actual Kibana logs show?

---

<div class="post-metadata">

### Author: ![Mohamed\_Koubaa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mohamed_koubaa/32/63843_2.png) [@Mohamed\_Koubaa](https://discuss.elastic.co/u/Mohamed_Koubaa)
#### Post date: [March 5, 2020, 9:29pm UTC](https://discuss.elastic.co/t/i-cant-start-kibana-on-ubuntu-16-04/222180/3 "2020-03-05T21:29:41Z")

</div>

I didn't have any logs , i purged both kibana and elasticsearch to fix it.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [March 5, 2020, 10:37pm UTC](https://discuss.elastic.co/t/i-cant-start-kibana-on-ubuntu-16-04/222180/4 "2020-03-05T22:37:05Z")

</div>

It's going to be super hard to troubleshoot without logs.

---

<div class="post-metadata">

### Author: ![Mohamed\_Koubaa](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mohamed_koubaa/32/63843_2.png) [@Mohamed\_Koubaa](https://discuss.elastic.co/u/Mohamed_Koubaa)
#### Post date: [March 6, 2020, 1:14am UTC](https://discuss.elastic.co/t/i-cant-start-kibana-on-ubuntu-16-04/222180/5 "2020-03-06T01:14:48Z")

</div>

I found a solution for this, which is deleting this version and installing the newest. I am however facing another problem which i posted the logs for.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 3, 2020, 1:14am UTC](https://discuss.elastic.co/t/i-cant-start-kibana-on-ubuntu-16-04/222180/6 "2020-04-03T01:14:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
