# I get the error "No processor type exists with name \[attachment\]"

**URL:** <https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935>\
**Category:** Elasticsearch\
**Created:** [July 4, 2019, 2:52pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935 "2019-07-04T14:52:16Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 4, 2019, 2:52pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/1 "2019-07-04T14:52:17Z")

</div>

i get  
{  
"error": {  
"root\_cause": [  
{  
"type": "parse\_exception",  
"reason": "No processor type exists with name [attachment]",  
"processor\_type": "attachment"  
}  
],  
"type": "parse\_exception",  
"reason": "No processor type exists with name [attachment]",  
"processor\_type": "attachment"  
},  
"status": 400  
}

when i try to do the pipeline here in the docs [https://www.elastic.co/guide/en/elasticsearch/plugins/7.2/using-ingest-attachment.html](https://www.elastic.co/guide/en/elasticsearch/plugins/7.2/using-ingest-attachment.html)  
PUT \_ingest/pipeline/attachment  
{  
"description" : "Extract attachment information",  
"processors" : [  
{  
"attachment" : {  
"field" : "data",  
"indexed\_chars" : 11  
}  
}  
]  
}  
can anyone help me! i'm new to ES i just install it, everything is working and i followed the docs i can index and search fine ..  
i installed the plugin : sudo bin/elasticsearch-plugin install ingest-attachment  
and when i hit : GET \_cat/plugins?v .. i get :  
name component version  
ubuntu-TUF-Gaming-FX505GE-FX505GE ingest-attachment 7.2.0

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 4, 2019, 3:49pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/2 "2019-07-04T15:49:43Z")

</div>

Did you restart the node before running the `PUT _ingest/pipeline/attachment`?

Could you share the full logs? (formatted please with `</>` icon).

---

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 4, 2019, 3:59pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/3 "2019-07-04T15:59:41Z")

</div>

if you mean by restarting : `sudo systemctl restart elasticsearch.service` yes i did it.  
can you please specify how can i get the log you want?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 4, 2019, 4:41pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/4 "2019-07-04T16:41:27Z")

</div>

It depends on your source package. Read from [https://www.elastic.co/guide/en/elasticsearch/reference/current/install-elasticsearch.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/install-elasticsearch.html)

For RPM for example ([https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/rpm.html)) the log dir is `/var/log/elasticsearch` by default.

---

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 4, 2019, 4:58pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/5 "2019-07-04T16:58:10Z")

</div>

ok i downloaded the archive package from the download page. i choose download for linux, then extracted and started the elasticsearch with `./bin/elasticsearch` in cmd.  
what is the log that i should show? ![image](https://us1.discourse-cdn.com/elastic/original/3X/a/f/af2a6362a92f6af30ec23e3e0c7b98a1c57a7080.png)

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 4, 2019, 4:58pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/6 "2019-07-04T16:58:49Z")

</div>

`elasticsearch.log`

---

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 4, 2019, 5:00pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/7 "2019-07-04T17:00:05Z")

</div>

here it is ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/4/74d2509d8a19f5449a745fbf62cb5364fa9b627e.png)

---

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 4, 2019, 5:09pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/8 "2019-07-04T17:09:55Z")

</div>

i saw you talk about this in old issues and you said that we have to install the plugin in every node.. first i don't understand why i have 2 nodes, i only had installed elasticsearch for 5 days and just followed the docs on how to index and do simple stuff !

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/5/d/5de9bfebcb1c955a58b3d0a52ed4b139d9d2a2ec.png)  
if the problem is that i dind't installed the plugin in the two ndes.. how can i do that ?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 4, 2019, 5:40pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/9 "2019-07-04T17:40:10Z")

</div>

You can't have 2 nodes running on the same machine unless if you changed some settings.  
Kill the node you don't need. Or just kill them all and restart only one

---

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 4, 2019, 5:47pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/10 "2019-07-04T17:47:22Z")

</div>

ok but can you please tell me how to do that, i don't want to do it wrong .. i don't remember myself doing 2 nodes,

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 4, 2019, 7:21pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/11 "2019-07-04T19:21:33Z")

</div>

What gives

```
ps -ef | grep elasticsearch
```

---

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 4, 2019, 7:27pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/12 "2019-07-04T19:27:33Z")

</div>

it gives this

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/0/0/0071ac621d66a49ba04c4243a20e30857b1d9340.png)

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 4, 2019, 7:45pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/13 "2019-07-04T19:45:37Z")

</div>

Please don't post images of text as they are hardly readable and not searchable.

Instead paste the text and format it with `</>` icon. Check the preview window.

You have started one elasticsearch as a service and another one manually.  
If you don't really care about any of them, just `kill -9` the process.

---

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 4, 2019, 7:47pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/14 "2019-07-04T19:47:40Z")

</div>

sorry `ubuntu 10512 6875 0 16:43 pts/0 00:02:09 /home/ubuntu/Downloads/elasticsearch-7.2.0/jdk/bin/java -Xms1g -Xmx1g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -Des.networkaddress.cache.ttl=60 -Des.networkaddress.cache.negative.ttl=10 -XX:+AlwaysPreTouch -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -XX:-OmitStackTraceInFastThrow -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Djava.io.tmpdir=/tmp/elasticsearch-4654280176806404706 -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=data -XX:ErrorFile=logs/hs_err_pid%p.log -Xlog:gc*,gc+age=trace,safepoint:file=logs/gc.log:utctime,pid,tags:filecount=32,filesize=64m -Djava.locale.providers=COMPAT -Dio.netty.allocator.type=unpooled -XX:MaxDirectMemorySize=536870912 -Des.path.home=/home/ubuntu/Downloads/elasticsearch-7.2.0 -Des.path.conf=/home/ubuntu/Downloads/elasticsearch-7.2.0/config -Des.distribution.flavor=default -Des.distribution.type=tar -Des.bundled_jdk=true -cp /home/ubuntu/Downloads/elasticsearch-7.2.0/lib/* org.elasticsearch.bootstrap.Elasticsearch ubuntu 10634 10512 0 16:43 pts/0 00:00:00 /home/ubuntu/Downloads/elasticsearch-7.2.0/modules/x-pack-ml/platform/linux-x86_64/bin/controller elastic+ 15282 1 1 17:24 ? 00:02:54 /usr/share/elasticsearch/jdk/bin/java -Xms1g -Xmx1g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -Des.networkaddress.cache.ttl=60 -Des.networkaddress.cache.negative.ttl=10 -XX:+AlwaysPreTouch -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -XX:-OmitStackTraceInFastThrow -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Djava.io.tmpdir=/tmp/elasticsearch-17667327696129157755 -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/var/lib/elasticsearch -XX:ErrorFile=/var/log/elasticsearch/hs_err_pid%p.log -Xlog:gc*,gc+age=trace,safepoint:file=/var/log/elasticsearch/gc.log:utctime,pid,tags:filecount=32,filesize=64m -Djava.locale.providers=COMPAT -Dio.netty.allocator.type=unpooled -XX:MaxDirectMemorySize=536870912 -Des.path.home=/usr/share/elasticsearch -Des.path.conf=/etc/elasticsearch -Des.distribution.flavor=default -Des.distribution.type=deb -Des.bundled_jdk=true -cp /usr/share/elasticsearch/lib/* org.elasticsearch.bootstrap.Elasticsearch -p /var/run/elasticsearch/elasticsearch.pid --quiet elastic+ 15426 15282 0 17:24 ? 00:00:00 /usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/bin/controller ubuntu 26003 23027 0 20:27 pts/2 00:00:00 grep --color=auto elasticsearch`

---

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 4, 2019, 7:48pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/15 "2019-07-04T19:48:11Z")

</div>

ok i will kill them , but them how can i start one ?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 4, 2019, 8:21pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/16 "2019-07-04T20:21:20Z")

</div>

Which one do you want to start?

---

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 4, 2019, 8:23pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/17 "2019-07-04T20:23:23Z")

</div>

i did kill second one by  
`kill -10512`  
so i need to restart the first one i think

---

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 4, 2019, 8:41pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/18 "2019-07-04T20:41:44Z")

</div>

so i did kill one and did `sudo systemctl restart elasticsearch.service` and now when i did `GET /_cat/nodes?v` i get `ip heap.percent ram.percent cpu load_1m load_5m load_15m node.role master name 127.0.0.1 15 83 8 0.67 1.20 0.98 mdi * ubuntu-TUF-Gaming-FX505GE-FX505GE`  
but i still get `{ "error": { "root_cause": [{ "type": "parse_exception", "reason": "No processor type exists with name [attachment]", "processor_type": "attachment" } ], "type": "parse_exception", "reason": "No processor type exists with name [attachment]", "processor_type": "attachment" }, "status": 400 }`

when i do  
`PUT _ingest/pipeline/attachment { "description" : "Extract attachment information", "processors" : [{ "attachment" : { "field" : "data", "indexed_chars" : 11 } }] }`  
PS: i removed and reinstalled the Ingest Attachment Processor Plugin!

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 4, 2019, 9:00pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/19 "2019-07-04T21:00:25Z")

</div>

What does the cat plugins API returns?

---

<div class="post-metadata">

**Author:** ![FeizNouri](https://avatars.discourse-cdn.com/v4/letter/f/7993a0/32.png) [@FeizNouri](https://discuss.elastic.co/u/FeizNouri)\
**Post date:** [July 8, 2019, 1:28pm UTC](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935/20 "2019-07-08T13:28:49Z")

</div>

i uninstalled elasticsearch and reinstalled it and everything works fine and i understood now that at first i installed and run it twice: with service and with`./bin/elasticsearch` that is why i got two nodes. thanks

[Next page](https://discuss.elastic.co/t/i-get-the-error-no-processor-type-exists-with-name-attachment/188935.md?page=2)
