# I got errors after installing x-pack on elasticsearch 5.0.1 node: "exception when exporting documents"

**URL:** <https://discuss.elastic.co/t/i-got-errors-after-installing-x-pack-on-elasticsearch-5-0-1-node-exception-when-exporting-documents/67120>\
**Category:** Elasticsearch\
**Created:** [November 24, 2016, 2:28pm UTC](https://discuss.elastic.co/t/i-got-errors-after-installing-x-pack-on-elasticsearch-5-0-1-node-exception-when-exporting-documents/67120 "2016-11-24T14:28:26Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![marminthibaut](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marminthibaut/32/8509_2.png) [@marminthibaut](https://discuss.elastic.co/u/marminthibaut)\
**Post date:** [November 24, 2016, 2:28pm UTC](https://discuss.elastic.co/t/i-got-errors-after-installing-x-pack-on-elasticsearch-5-0-1-node-exception-when-exporting-documents/67120/1 "2016-11-24T14:28:26Z")

</div>

Hi !

I run an elasticsearch node in a Docker container (from the official docker image). All bootstrap checks are passing, everything works great without x-pack.

I followed the installation procedure (from [here](https://www.elastic.co/guide/en/x-pack/current/installing-xpack.html)), but when I restart my node, I have the following error:

```
    [2016-11-24T14:25:17,169][INFO][o.e.x.m.e.Exporters] [SR067974CTI3700] skipping exporter [default_local] as it isn't ready yet
[2016-11-24T14:25:17,169][ERROR][o.e.x.m.AgentService] [SR067974CTI3700] exception when exporting documents
org.elasticsearch.xpack.monitoring.exporter.ExportException: exporters are either not ready or faulty
        at org.elasticsearch.xpack.monitoring.exporter.Exporters.export(Exporters.java:188) ~[x-pack-5.0.1.jar:5.0.1]
        at org.elasticsearch.xpack.monitoring.AgentService$ExportingWorker.run(AgentService.java:208) [x-pack-5.0.1.jar:5.0.1]
        at java.lang.Thread.run(Thread.java:745) [?:1.8.0_111]

```

These lines are thrown every 10 seconds.

When I try to do a get on localhost:9200 with curl, I got:

```
$ curl localhost:9200?pretty -u elastic:changeme
{
  "error" : {
    "root_cause" : [
      {
        "type" : "security_exception",
        "reason" : "failed to authenticate user [elastic]",
        "header" : {
          "WWW-Authenticate" : "Basic realm=\"security\" charset=\"UTF-8\""
        }
      }
    ],
    "type" : "security_exception",
    "reason" : "failed to authenticate user [elastic]",
    "header" : {
      "WWW-Authenticate" : "Basic realm=\"security\" charset=\"UTF-8\""
    }
  },
  "status" : 401
}

```

Any Idea?

Thanks!

---

<div class="post-metadata">

**Author:** ![leizhu](https://avatars.discourse-cdn.com/v4/letter/l/9de053/32.png) [@leizhu](https://discuss.elastic.co/u/leizhu)\
**Post date:** [November 28, 2016, 11:15am UTC](https://discuss.elastic.co/t/i-got-errors-after-installing-x-pack-on-elasticsearch-5-0-1-node-exception-when-exporting-documents/67120/2 "2016-11-28T11:15:39Z")

</div>

I'm running into the same issue, any solution?

---

<div class="post-metadata">

**Author:** ![jdizzle](https://avatars.discourse-cdn.com/v4/letter/j/43a26b/32.png) [@jdizzle](https://discuss.elastic.co/u/jdizzle)\
**Post date:** [December 9, 2016, 5:00pm UTC](https://discuss.elastic.co/t/i-got-errors-after-installing-x-pack-on-elasticsearch-5-0-1-node-exception-when-exporting-documents/67120/3 "2016-12-09T17:00:19Z")

</div>

Hey Everyone,

I'm seeing the exact same issue, but I'm not running ES in a docker container. ES version 5.1.1

---

<div class="post-metadata">

**Author:** ![Joe\_Fleming](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joe_fleming/32/3561_2.png) [@Joe\_Fleming](https://discuss.elastic.co/u/Joe_Fleming)\
**Post date:** [December 9, 2016, 5:48pm UTC](https://discuss.elastic.co/t/i-got-errors-after-installing-x-pack-on-elasticsearch-5-0-1-node-exception-when-exporting-documents/67120/4 "2016-12-09T17:48:03Z")

</div>

Have you changed anything with your security settings? `elastic:changeme` should work out of the box.

Can you try to disabled Security and see if everything else is working correctly? You can disable it by adding `xpack.security.enabled: false` to your `elasticsearch.yml`.

---

<div class="post-metadata">

**Author:** ![jdizzle](https://avatars.discourse-cdn.com/v4/letter/j/43a26b/32.png) [@jdizzle](https://discuss.elastic.co/u/jdizzle)\
**Post date:** [December 9, 2016, 6:52pm UTC](https://discuss.elastic.co/t/i-got-errors-after-installing-x-pack-on-elasticsearch-5-0-1-node-exception-when-exporting-documents/67120/5 "2016-12-09T18:52:37Z")

</div>

I made two changes, but not sure which one made the difference. During the upgrade I had disabled shard allocation. After upgrading and installing x-pack I wasn't able to re-enable shard allocation due to failed auth. The other thing I didn't do initially was step three in x-pack install guide. Once I removed x-pack, I re-enabled shard allocation and then added the action.auto\_create\_index line to my config file. I reinstalled x-pack and all is good now. Hope this helps anyone else out there.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 6, 2017, 6:52pm UTC](https://discuss.elastic.co/t/i-got-errors-after-installing-x-pack-on-elasticsearch-5-0-1-node-exception-when-exporting-documents/67120/6 "2017-01-06T18:52:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
