# I have a date field and got the error: 'Fielddata is disabled on text fields by default.'

**URL:** https://discuss.elastic.co/t/i-have-a-date-field-and-got-the-error-fielddata-is-disabled-on-text-fields-by-default/216335
**Category:** Elasticsearch
**Created:** [January 23, 2020, 10:27pm UTC](https://discuss.elastic.co/t/i-have-a-date-field-and-got-the-error-fielddata-is-disabled-on-text-fields-by-default/216335 "2020-01-23T22:27:34Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Daniel\_Faria](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/daniel_faria/32/45326_2.png) [@Daniel\_Faria](https://discuss.elastic.co/u/Daniel_Faria)
#### Post date: [January 23, 2020, 10:27pm UTC](https://discuss.elastic.co/t/i-have-a-date-field-and-got-the-error-fielddata-is-disabled-on-text-fields-by-default/216335/1 "2020-01-23T22:27:34Z")

</div>

Hello.

I have a date field mapping as date and got the error: 'Fielddata is disabled on text fields by default.'' on Kibana query.

`Fielddata is disabled on text fields by default. Set fielddata=true on [log_processed.time] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.`

My field log\_processed.time is really a date as you can see on querys bellow:

> Blockquote  
> {  
> "logstash-2019.12.21" : {  
> "mappings" : {  
> "time" : {  
> "full\_name" : "time",  
> "mapping" : {  
> "time" : {  
> "type" : "date"  
> }  
> }  
> }  
> }  
> }  
> }

My versions is:

Elasticsearch and Kibana: 7.4.0

Thank you.

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [January 27, 2020, 10:44am UTC](https://discuss.elastic.co/t/i-have-a-date-field-and-got-the-error-fielddata-is-disabled-on-text-fields-by-default/216335/2 "2020-01-27T10:44:54Z")

</div>

Hey Daniel,

the mapping does not refer to a `log_processed.time` field, just to another `time` field. Please share **full** reproducible examples, otherwise it will be super hard to debug and help. See [https://www.elastic.co/help](https://www.elastic.co/help)

Thanks a ton!

--Alex

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [February 24, 2020, 10:44am UTC](https://discuss.elastic.co/t/i-have-a-date-field-and-got-the-error-fielddata-is-disabled-on-text-fields-by-default/216335/3 "2020-02-24T10:44:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
