# I have an issue with the elastic 8.1.3 settings

**URL:** <https://discuss.elastic.co/t/i-have-an-issue-with-the-elastic-8-1-3-settings/303102>\
**Category:** Elasticsearch\
**Created:** [April 24, 2022, 3:14pm UTC](https://discuss.elastic.co/t/i-have-an-issue-with-the-elastic-8-1-3-settings/303102 "2022-04-24T15:14:34Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mahmoud](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mahmoud/32/83050_2.png) [@Mahmoud](https://discuss.elastic.co/u/Mahmoud)\
**Post date:** [April 24, 2022, 3:14pm UTC](https://discuss.elastic.co/t/i-have-an-issue-with-the-elastic-8-1-3-settings/303102/1 "2022-04-24T15:14:34Z")

</div>

I have a startup problem with elastic version 8.1.3 i trying to configure elastic cluster its have single node

```auto
Apr 24 16:50:40 elastic systemd-entrypoint[3419]: ERROR: Elasticsearch did not exit normally - check the logs at /var/log/elasticsearch/securicip.log
Apr 24 16:50:42 elastic systemd[1]: Failed to start Elasticsearch.
-- Subject: Unit elasticsearch.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit elasticsearch.service has failed.
--
-- The result is failed.
Apr 24 16:50:42 elastic systemd[1]: Unit elasticsearch.service entered failed state.
Apr 24 16:50:42 elastic systemd[1]: elasticsearch.service failed.
Apr 24 16:50:42 elastic polkitd[601]: Unregistered Authentication Agent for unix-process:3406:157982 (system bus name :1.48, object path /org/freedesktop/Poli
Apr 24 16:50:50 elastic sshd[3772]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=89.252.140.21 user=root
Apr 24 16:50:50 elastic sshd[3772]: pam_succeed_if(sshd:auth): requirement "uid >= 1000" not met by user "root"

```

```auto

# ---------------------------------- Cluster -----------------------------------
#
# Use a descriptive name for your cluster:
#
cluster.name: securicip
#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node:
#
node.name: elastic
#
# Add custom attributes to the node:

# Add custom attributes to the node:
#
#node.attr.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
path.data: /var/lib/elasticsearch
#
# Path to log files:
#
path.logs: /var/log/elasticsearch
#
# ----------------------------------- Memory -----------------------------------
#
# Lock the memory on startup:
#
#bootstrap.memory_lock: true
#
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#
# ---------------------------------- Network -----------------------------------
#
# By default Elasticsearch is only accessible on localhost. Set a different
# address here to expose this node on the network:
#
network.host: 0.0.0.0
#
# By default Elasticsearch listens for HTTP traffic on the first free port it
# finds starting at 9200. Set a specific HTTP port here:
#
http.port: 9200
#
# For more information, consult the network module documentation.
#
# --------------------------------- Discovery ----------------------------------

#discovery.seed_hosts: ["host1", "host2"]
#
# Bootstrap the cluster using an initial set of master-eligible nodes:
#
#cluster.initial_master_nodes: ["node-1", "node-2"]
#
# For more information, consult the discovery and cluster formation module documentation.
#
# ---------------------------------- Various -----------------------------------
#
# Allow wildcard deletion of indices:
#
#action.destructive_requires_name: false

# Enable security features
xpack.security.enabled: true

xpack.security.enrollment.enabled: true

# Enable encryption for HTTP API client connections, such as Kibana, Logstash, and Agents
xpack.security.http.ssl:
  enabled: true
  keystore.path: certs/http.p12

# Enable encryption and mutual authentication between cluster nodes
xpack.security.transport.ssl:
  enabled: true
  verification_mode: certificate
  keystore.path: certs/transport.p12
  truststore.path: certs/transport.p12
# Create a new cluster with the current node only
# Additional nodes can still join the cluster later
cluster.initial_master_nodes: ["elastic"]

# Allow HTTP API connections from localhost and local networks
# Connections are encrypted and require user authentication
http.host: [_local_, _site_]

# Allow other nodes to join the cluster from localhost and local networks
# Connections are encrypted and mutually authenticated
#transport.host: [_local_]

#----------------------- END SECURITY AUTO CONFIGURATION -------------------------

```

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [April 24, 2022, 5:39pm UTC](https://discuss.elastic.co/t/i-have-an-issue-with-the-elastic-8-1-3-settings/303102/2 "2022-04-24T17:39:45Z")

</div>

> [@Mahmoud](#):
>
> ```auto
> discovery.seed_hosts: ["host1"]
> #
> # Bootstrap the cluster using an initial set of master-eligible nodes:
> #
> cluster.initial_master_nodes: ["node-1"]
> 
> ```

Few think you need.  
I think first time you need this to set and node.role: [master,data,ingest,transform]

But this might not be problem as last time

Also check log file "/var/log/elasticsearch/securicip.log"

---

<div class="post-metadata">

**Author:** ![Mahmoud](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mahmoud/32/83050_2.png) [@Mahmoud](https://discuss.elastic.co/u/Mahmoud)\
**Post date:** [April 26, 2022, 10:47pm UTC](https://discuss.elastic.co/t/i-have-an-issue-with-the-elastic-8-1-3-settings/303102/3 "2022-04-26T22:47:01Z")

</div>

thanks for help, i did what you say , but it's still same problem

---

<div class="post-metadata">

**Author:** ![elasticforme](https://avatars.discourse-cdn.com/v4/letter/e/f05b48/32.png) [@elasticforme](https://discuss.elastic.co/u/elasticforme)\
**Post date:** [April 27, 2022, 1:17am UTC](https://discuss.elastic.co/t/i-have-an-issue-with-the-elastic-8-1-3-settings/303102/4 "2022-04-27T01:17:43Z")

</div>

what are messages in log file?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 25, 2022, 1:18am UTC](https://discuss.elastic.co/t/i-have-an-issue-with-the-elastic-8-1-3-settings/303102/5 "2022-05-25T01:18:19Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
