# I m unable to restart the logstash after updating the conf.d file

**URL:** <https://discuss.elastic.co/t/i-m-unable-to-restart-the-logstash-after-updating-the-conf-d-file/314768>\
**Category:** Logstash\
**Created:** [September 20, 2022, 9:59am UTC](https://discuss.elastic.co/t/i-m-unable-to-restart-the-logstash-after-updating-the-conf-d-file/314768 "2022-09-20T09:59:18Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![prashanthk](https://avatars.discourse-cdn.com/v4/letter/p/898d66/32.png) [@prashanthk](https://discuss.elastic.co/u/prashanthk)\
**Post date:** [September 20, 2022, 9:59am UTC](https://discuss.elastic.co/t/i-m-unable-to-restart-the-logstash-after-updating-the-conf-d-file/314768/1 "2022-09-20T09:59:19Z")

</div>

Im unable to start logstash after updating the conf.d file in logstash. i checked the logs it is showing as Attempted to resurrect connection to dead ES instance, but got an error. I need to start the logstash now.

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [September 20, 2022, 12:06pm UTC](https://discuss.elastic.co/t/i-m-unable-to-restart-the-logstash-after-updating-the-conf-d-file/314768/2 "2022-09-20T12:06:02Z")

</div>

You need to provide more context, please share the log you are receiving using the preformatted button in the editor, the `</>` button.

Also, what you change? How are you running logstash? As a service with systemctl?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 18, 2022, 12:06pm UTC](https://discuss.elastic.co/t/i-m-unable-to-restart-the-logstash-after-updating-the-conf-d-file/314768/3 "2022-10-18T12:06:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
