# I tried to upgrade the Elasticsearch to 7.16.2 and it’s working fine but Logstash upgrade to 7.16.2 still not working with upgraded elastic. I am getting below error with it, I tried to troubleshoot the issue but it’s still the same

**URL:** <https://discuss.elastic.co/t/i-tried-to-upgrade-the-elasticsearch-to-7-16-2-and-it-s-working-fine-but-logstash-upgrade-to-7-16-2-still-not-working-with-upgraded-elastic-i-am-getting-below-error-with-it-i-tried-to-troubleshoot-the-issue-but-it-s-still-the-same/303216>\
**Category:** Logstash\
**Created:** [April 26, 2022, 6:15am UTC](https://discuss.elastic.co/t/i-tried-to-upgrade-the-elasticsearch-to-7-16-2-and-it-s-working-fine-but-logstash-upgrade-to-7-16-2-still-not-working-with-upgraded-elastic-i-am-getting-below-error-with-it-i-tried-to-troubleshoot-the-issue-but-it-s-still-the-same/303216 "2022-04-26T06:15:08Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![rutika\_kamble](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rutika_kamble/32/101002_2.png) [@rutika\_kamble](https://discuss.elastic.co/u/rutika_kamble)\
**Post date:** [April 26, 2022, 6:15am UTC](https://discuss.elastic.co/t/i-tried-to-upgrade-the-elasticsearch-to-7-16-2-and-it-s-working-fine-but-logstash-upgrade-to-7-16-2-still-not-working-with-upgraded-elastic-i-am-getting-below-error-with-it-i-tried-to-troubleshoot-the-issue-but-it-s-still-the-same/303216/1 "2022-04-26T06:15:08Z")

</div>

[2022-04-22T04:24:45,425][WARN][deprecation.logstash.filters.json] Relying on default value of `pipeline.ecs_compatibility`, which may change in a future major release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.  
[2022-04-22T04:24:45,427][WARN][deprecation.logstash.filters.json] Relying on default value of `pipeline.ecs_compatibility`, which may change in a future major release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.  
[2022-04-22T04:24:45,428][WARN][deprecation.logstash.filters.json] Relying on default value of `pipeline.ecs_compatibility`, which may change in a future major release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.  
[2022-04-22T04:24:45,429][WARN][deprecation.logstash.filters.json] Relying on default value of `pipeline.ecs_compatibility`, which may change in a future major release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.  
[2022-04-22T04:24:45,429][WARN][deprecation.logstash.filters.json] Relying on default value of `pipeline.ecs_compatibility`, which may change in a future major release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.  
[2022-04-22T04:24:45,429][WARN][deprecation.logstash.filters.grok] Relying on default value of `pipeline.ecs_compatibility`, which may change in a future major release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.  
[2022-04-22T04:24:45,535][INFO][logstash.javapipeline] Starting pipeline {:pipeline\_id=\>"main", "pipeline.workers"=\>4, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>50, "pipeline.max\_inflight"=\>500, "pipeline.sources"=\>["/etc/logstash/conf.d/iot.conf"], :thread=\>"#\<Thread:0x8881ce3 run\>"}  
[2022-04-22T04:24:47,918][INFO][logstash.javapipeline] Pipeline Java execution initialization time {"seconds"=\>2.38}  
[2022-04-22T04:24:47,951][WARN][deprecation.logstash.codecs.json] Relying on default value of `pipeline.ecs_compatibility`, which may change in a future major release of Logstash. To avoid unexpected changes when upgrading Logstash, please explicitly declare your desired ECS Compatibility mode.  
[2022-04-22T04:24:53,307][ERROR][logstash.javapipeline] Pipeline error {:pipeline\_id=\>"main", :exception=\>java.lang.IllegalStateException: failed to create a child event loop, :backtrace=\>["io.netty.util.concurrent.MultithreadEventExecutorGroup.(io/netty/util/concurrent/MultithreadEventExecutorGroup.java:88)", "io.netty.util.concurrent.MultithreadEventExecutorGroup.(io/netty/util/concurrent/MultithreadEventExecutorGroup.java:60)", "io.netty.util.concurrent.MultithreadEventExecutorGroup.(io/netty/util/concurrent/MultithreadEventExecutorGroup.java:49)", "io.netty.channel.MultithreadEventLoopGroup.(io/netty/channel/MultithreadEventLoopGroup.java:59)", "io.netty.channel.nio.NioEventLoopGroup.(io/netty/channel/nio/NioEventLoopGroup.java:86)", "io.netty.channel.nio.NioEventLoopGroup.(io/netty/channel/nio/NioEventLoopGroup.java:81)", "io.netty.channel.nio.NioEventLoopGroup.(io/netty/channel/nio/NioEventLoopGroup.java:68)", "org.logstash.plugins.inputs.http.NettyHttpServer.(org/logstash/plugins/inputs/http/NettyHttpServer.java:40)", "jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)", "jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(jdk/internal/reflect/NativeConstructorAccessorImpl.java:62)", "jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(jdk/internal/reflect/DelegatingConstructorAccessorImpl.java:45)", "java.lang.reflect.Constructor.newInstance(java/lang/reflect/Constructor.java:490)", "org.jruby.javasupport.JavaConstructor.newInstanceDirect(org/jruby/javasupport/JavaConstructor.java:253)", "org.jruby.RubyClass.newInstance(org/jruby/RubyClass.java:939)", "org.jruby.RubyClass$INVOKER$i$newInstance.call(org/jruby/RubyClass$INVOKER$i$newInstance.gen)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_input\_minus\_http\_minus\_3\_dot\_4\_dot\_4\_minus\_java.lib.logstash.inputs.http.create\_http\_server(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-http-3.4.4-java/lib/logstash/inputs/http.rb:256)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_input\_minus\_http\_minus\_3\_dot\_4\_dot\_4\_minus\_java.lib.logstash.inputs.http.register(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-input-http-3.4.4-java/lib/logstash/inputs/http.rb:148)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.register\_plugins(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:232)", "org.jruby.RubyArray.each(org/jruby/RubyArray.java:1821)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.register\_plugins(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:231)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.start\_inputs(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:390)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.start\_workers(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:315)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.run(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:189)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.start(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:141)", "org.jruby.RubyProc.call(org/jruby/RubyProc.java:318)", "java.lang.Thread.run(java/lang/Thread.java:829)"], "pipeline.sources"=\>["/etc/logstash/conf.d/iot.conf"], :thread=\>"#\<Thread:0x8881ce3 run\>"}  
[2022-04-22T04:24:53,313][INFO][logstash.javapipeline] Pipeline terminated {"pipeline.id"=\>"main"}  
[2022-04-22T04:24:53,322][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
[2022-04-22T04:24:53,395][INFO][logstash.runner] Logstash shut down.  
[2022-04-22T04:24:53,404][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit  
org.jruby.exceptions.SystemExit: (SystemExit) exit  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.20.1.jar:?]  
at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.20.1.jar:?]  
at usr.share.logstash.lib.bootstrap.environment.(/usr/share/logstash/lib/bootstrap/environment.rb:94) ~[?:?]

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 24, 2022, 6:15am UTC](https://discuss.elastic.co/t/i-tried-to-upgrade-the-elasticsearch-to-7-16-2-and-it-s-working-fine-but-logstash-upgrade-to-7-16-2-still-not-working-with-upgraded-elastic-i-am-getting-below-error-with-it-i-tried-to-troubleshoot-the-issue-but-it-s-still-the-same/303216/2 "2022-05-24T06:15:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
