# I will run elasticsearch it will getting error

**URL:** <https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103>\
**Category:** Elasticsearch\
**Created:** [April 12, 2017, 7:25am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103 "2017-04-12T07:25:15Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 12, 2017, 7:25am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/1 "2017-04-12T07:25:15Z")

</div>

Hi All ,

I am run the elasticsearch it will getting error.

./elasticsearch  
[2017-04-12T07:23:31,443][INFO][o.e.n.Node] [] initializing ...  
[2017-04-12T07:23:31,476][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalStateException: failed to obtain node locks, tried [[/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/data/elasticsearch]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max\_local\_storage\_nodes] (was [1])?  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) ~[elasticsearch-5.2.0.jar:5.2.0]  
Caused by: java.lang.IllegalStateException: failed to obtain node locks, tried [[/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/data/elasticsearch]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max\_local\_storage\_nodes] (was [1])?  
at org.elasticsearch.env.NodeEnvironment.(NodeEnvironment.java:260) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.node.Node.(Node.java:252) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.node.Node.(Node.java:232) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Bootstrap$6.(Bootstrap.java:241) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:241) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:333) ~[elasticsearch-5.2.0.jar:5.2.0]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) ~[elasticsearch-5.2.0.jar:5.2.0]  
... 6 more

Could you please help me.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 12, 2017, 7:58am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/2 "2017-04-12T07:58:10Z")

</div>

A node is already running

---

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 12, 2017, 8:00am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/3 "2017-04-12T08:00:24Z")

</div>

Node is not running .it is a new installation.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 12, 2017, 9:25am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/4 "2017-04-12T09:25:12Z")

</div>

Are you sure? Did you run ps -ef to check?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 12, 2017, 9:25am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/5 "2017-04-12T09:25:55Z")

</div>

Check the write rights as well for the data dir

---

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 12, 2017, 9:27am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/6 "2017-04-12T09:27:15Z")

</div>

ps -ef | grep node. I am run the command

venkata+ 18899 4348 0 09:26 pts/0 00:00:00 grep --color=auto node.

I have full permissions in that directory.

---

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 12, 2017, 9:32am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/7 "2017-04-12T09:32:57Z")

</div>

UID PID PPID C STIME TTY TIME CMD  
root 1 0 0 Apr10 ? 00:00:13 /usr/lib/systemd/systemd --switched-root --system --deserialize 21  
root 2 0 0 Apr10 ? 00:00:00 [kthreadd]  
root 3 2 0 Apr10 ? 00:00:00 [ksoftirqd/0]  
root 5 2 0 Apr10 ? 00:00:00 [kworker/0:0H]  
root 7 2 0 Apr10 ? 00:00:00 [migration/0]  
root 8 2 0 Apr10 ? 00:00:00 [rcu\_bh]  
root 9 2 0 Apr10 ? 00:00:37 [rcu\_sched]  
root 10 2 0 Apr10 ? 00:00:00 [watchdog/0]  
root 11 2 0 Apr10 ? 00:00:00 [watchdog/1]  
root 12 2 0 Apr10 ? 00:00:00 [migration/1]  
root 13 2 0 Apr10 ? 00:00:00 [ksoftirqd/1]  
root 15 2 0 Apr10 ? 00:00:00 [kworker/1:0H]  
root 16 2 0 Apr10 ? 00:00:00 [watchdog/2]  
root 17 2 0 Apr10 ? 00:00:00 [migration/2]  
root 18 2 0 Apr10 ? 00:00:00 [ksoftirqd/2]  
root 21 2 0 Apr10 ? 00:00:00 [watchdog/3]  
root 22 2 0 Apr10 ? 00:00:00 [migration/3]  
root 23 2 0 Apr10 ? 00:00:00 [ksoftirqd/3]  
root 25 2 0 Apr10 ? 00:00:00 [kworker/3:0H]  
root 26 2 0 Apr10 ? 00:00:00 [watchdog/4]  
root 27 2 0 Apr10 ? 00:00:00 [migration/4]  
root 28 2 0 Apr10 ? 00:00:00 [ksoftirqd/4]  
root 31 2 0 Apr10 ? 00:00:00 [watchdog/5]  
root 32 2 0 Apr10 ? 00:00:00 [migration/5]  
root 33 2 0 Apr10 ? 00:00:00 [ksoftirqd/5]  
root 35 2 0 Apr10 ? 00:00:00 [kworker/5:0H]  
root 36 2 0 Apr10 ? 00:00:00 [watchdog/6]  
root 37 2 0 Apr10 ? 00:00:00 [migration/6]  
root 38 2 0 Apr10 ? 00:00:00 [ksoftirqd/6]  
root 40 2 0 Apr10 ? 00:00:00 [kworker/6:0H]  
root 41 2 0 Apr10 ? 00:00:00 [watchdog/7]  
root 42 2 0 Apr10 ? 00:00:00 [migration/7]  
root 43 2 0 Apr10 ? 00:00:00 [ksoftirqd/7]  
root 45 2 0 Apr10 ? 00:00:00 [kworker/7:0H]  
root 47 2 0 Apr10 ? 00:00:00 [kdevtmpfs]  
root 48 2 0 Apr10 ? 00:00:00 [netns]  
root 49 2 0 Apr10 ? 00:00:00 [khungtaskd]  
root 50 2 0 Apr10 ? 00:00:00 [writeback]  
root 51 2 0 Apr10 ? 00:00:00 [kintegrityd]  
root 52 2 0 Apr10 ? 00:00:00 [bioset]  
root 53 2 0 Apr10 ? 00:00:00 [kblockd]  
root 54 2 0 Apr10 ? 00:00:00 [md]  
root 60 2 0 Apr10 ? 00:00:00 [kswapd0]  
root 61 2 0 Apr10 ? 00:00:00 [ksmd]  
root 62 2 0 Apr10 ? 00:00:03 [khugepaged]  
root 63 2 0 Apr10 ? 00:00:00 [fsnotify\_mark]  
root 64 2 0 Apr10 ? 00:00:00 [crypto]  
root 72 2 0 Apr10 ? 00:00:00 [kthrotld]  
root 74 2 0 Apr10 ? 00:00:00 [kmpath\_rdacd]  
root 75 2 0 Apr10 ? 00:00:00 [kpsmoused]  
root 77 2 0 Apr10 ? 00:00:00 [ipv6\_addrconf]  
root 97 2 0 Apr10 ? 00:00:00 [deferwq]  
root 177 2 0 Apr10 ? 00:00:07 [kauditd]  
root 270 2 0 Apr10 ? 00:00:00 [hv\_vmbus\_con]  
root 275 2 0 Apr10 ? 00:00:00 [ata\_sff]  
root 284 2 0 Apr10 ? 00:00:00 [scsi\_eh\_0]  
root 285 2 0 Apr10 ? 00:00:01 [kworker/7:1]  
root 286 2 0 Apr10 ? 00:00:00 [scsi\_tmf\_0]  
root 287 2 0 Apr10 ? 00:00:00 [scsi\_eh\_1]  
root 288 2 0 Apr10 ? 00:00:00 [scsi\_tmf\_1]  
root 289 2 0 Apr10 ? 00:00:00 [scsi\_eh\_2]  
root 290 2 0 Apr10 ? 00:00:00 [scsi\_tmf\_2]  
root 293 2 0 Apr10 ? 00:00:02 [kworker/u128:3]  
root 296 2 0 Apr10 ? 00:00:00 [scsi\_eh\_3]  
root 297 2 0 Apr10 ? 00:00:00 [scsi\_tmf\_3]  
root 301 2 0 Apr10 ? 00:00:00 [scsi\_eh\_4]  
root 302 2 0 Apr10 ? 00:00:00 [scsi\_tmf\_4]  
root 303 2 0 Apr10 ? 00:00:00 [scsi\_eh\_5]  
root 304 2 0 Apr10 ? 00:00:00 [kworker/u128:4]  
root 305 2 0 Apr10 ? 00:00:00 [scsi\_tmf\_5]  
root 328 2 0 Apr10 ? 00:00:00 [xfsalloc]  
root 329 2 0 Apr10 ? 00:00:00 [xfs\_mru\_cache]  
root 330 2 0 Apr10 ? 00:00:00 [xfs-buf/sda2]  
root 331 2 0 Apr10 ? 00:00:00 [xfs-data/sda2]  
root 332 2 0 Apr10 ? 00:00:00 [xfs-conv/sda2]  
root 333 2 0 Apr10 ? 00:00:00 [xfs-cil/sda2]  
root 334 2 0 Apr10 ? 00:00:00 [xfs-reclaim/sda]  
root 335 2 0 Apr10 ? 00:00:00 [xfs-log/sda2]  
root 336 2 0 Apr10 ? 00:00:00 [xfs-eofblocks/s]  
root 337 2 0 Apr10 ? 00:00:33 [xfsaild/sda2]  
root 406 1 0 Apr10 ? 00:01:51 /usr/lib/systemd/systemd-journald  
root 431 1 0 Apr10 ? 00:00:00 /usr/sbin/lvmetad -f  
root 439 1 0 Apr10 ? 00:00:00 /usr/lib/systemd/systemd-udevd  
root 519 2 0 Apr10 ? 00:00:00 [xfs-buf/sda1]  
root 520 2 0 Apr10 ? 00:00:00 [xfs-data/sda1]  
root 521 2 0 Apr10 ? 00:00:00 [xfs-conv/sda1]  
root 522 2 0 Apr10 ? 00:00:00 [xfs-cil/sda1]  
root 523 2 0 Apr10 ? 00:00:00 [xfs-reclaim/sda]  
root 524 2 0 Apr10 ? 00:00:00 [xfs-log/sda1]  
root 525 2 0 Apr10 ? 00:00:00 [xfs-eofblocks/s]  
root 526 2 0 Apr10 ? 00:00:00 [xfsaild/sda1]  
root 552 2 0 Apr10 ? 00:00:01 [kworker/0:1H]  
root 553 2 0 Apr10 ? 00:00:00 [kworker/1:1H]  
root 555 1 0 Apr10 ? 00:00:17 /sbin/auditd -n  
root 576 1 0 Apr10 ? 00:00:04 /usr/sbin/irqbalance --foreground  
polkitd 577 1 0 Apr10 ? 00:00:00 /usr/lib/polkit-1/polkitd --no-debug  
root 579 1 0 Apr10 ? 00:00:00 /usr/sbin/abrtd -d -s  
root 580 1 0 Apr10 ? 00:00:01 /usr/lib/systemd/systemd-logind  
root 581 1 0 Apr10 ? 00:03:39 /sbin/rngd -f  
root 583 1 0 Apr10 ? 00:00:00 /usr/bin/abrt-watch-log -F BUG: WARNING: at WARNING: CPU: INFO: possible recursive locking detected ernel BUG  
root 588 1 0 Apr10 ? 00:00:00 /usr/sbin/smartd -n -q never  
libstor+ 593 1 0 Apr10 ? 00:00:00 /usr/bin/lsmd -d  
dbus 594 1 0 Apr10 ? 00:00:02 /bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation  
chrony 601 1 0 Apr10 ? 00:00:00 /usr/sbin/chronyd  
root 613 1 0 Apr10 ? 00:00:00 /usr/sbin/atd -f  
root 615 1 0 Apr10 ? 00:00:00 /usr/sbin/cron

---

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 12, 2017, 9:33am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/8 "2017-04-12T09:33:21Z")

</div>

root 738 636 0 Apr10 ? 00:00:00 /sbin/dhclient -d -q -sf /usr/libexec/nm-dhcp-helper -pf /var/run/dhclient-eth0.pid -lf /var/lib/NetworkManag  
root 787 2 0 Apr10 ? 00:00:00 [kworker/7:1H]  
root 946 1 0 Apr10 ? 00:00:16 /usr/bin/python -Es /usr/sbin/tuned -l -P  
root 955 1 0 Apr10 ? 00:00:00 /usr/bin/python -u /usr/sbin/waagent -daemon  
root 957 1 0 Apr10 ? 00:00:00 /usr/bin/rhsmcertd  
root 959 1 0 Apr10 ? 00:00:00 rhnsd  
root 986 2 0 05:30 ? 00:00:00 [kworker/4:2]  
root 1079 1 0 Apr10 ? 00:00:16 /usr/sbin/sshd  
root 1362 1 0 Apr10 ? 00:00:18 /opt/omi/bin/omiserver -d  
root 2126 2 0 Apr10 ? 00:00:00 [jbd2/sdb1-8]  
root 2127 2 0 Apr10 ? 00:00:00 [ext4-rsv-conver]  
root 2134 955 0 Apr10 ? 00:03:58 python -u /usr/sbin/waagent -run-exthandlers  
root 2167 2 0 Apr10 ? 00:00:00 [kworker/6:1H]  
root 2196 1 0 Apr10 ? 00:00:16 python /var/lib/waagent/Microsoft.OSTCExtensions.LinuxDiagnostic-2.3.9023/diagnostic.py -daemon  
root 2288 2 0 Apr10 ? 00:00:00 [kworker/4:2H]  
root 2351 2196 0 Apr10 ? 00:07:46 /var/lib/waagent/Microsoft.OSTCExtensions.LinuxDiagnostic-2.3.9023/bin/mdsd -A -C -c /var/lib/waagent/Microso  
root 2401 1362 0 Apr10 ? 00:00:35 /opt/omi/bin/omiagent 9 11 --destdir / --providerdir /opt/omi/lib --idletimeout 90 --loglevel WARNING  
root 2616 2 0 Apr10 ? 00:00:00 [kworker/3:1H]  
root 4303 1079 0 06:31 ? 00:00:00 sshd: venkata.bollineni [priv]  
venkata+ 4347 4303 0 06:32 ? 00:00:00 sshd: venkata.bollineni@pts/0  
venkata+ 4348 4347 0 06:32 pts/0 00:00:00 -bash  
venkata+ 4433 4348 0 06:33 pts/0 00:00:18 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOc  
root 5928 1079 0 06:56 ? 00:00:00 sshd: venkata.bollineni [priv]  
venkata+ 5955 5928 0 06:56 ? 00:00:00 sshd: venkata.bollineni@pts/1  
venkata+ 5956 5955 0 06:56 pts/1 00:00:00 -bash  
venkata+ 6831 4348 0 07:07 pts/0 00:00:02 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOc  
venkata+ 7284 4348 0 07:11 pts/0 00:00:02 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOc  
venkata+ 7467 4348 0 07:13 pts/0 00:00:03 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOc  
venkata+ 8342 4348 0 07:23 pts/0 00:00:02 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOc  
venkata+ 8782 4348 0 07:29 pts/0 00:00:03 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOc  
root 11681 2 0 08:10 ? 00:00:00 [kworker/2:0H]  
root 12310 1 0 08:12 ? 00:00:01 /usr/sbin/rsyslogd -n  
root 12993 2 0 08:13 ? 00:00:00 [kworker/1:3]  
root 12994 2 0 08:13 ? 00:00:00 [kworker/2:0]  
root 13054 2 0 08:13 ? 00:00:00 [kworker/3:3]  
root 14268 2 0 08:15 ? 00:00:00 [kworker/5:1]  
root 14382 2 0 08:16 ? 00:00:00 [kworker/6:2]  
root 16143 2 0 08:40 ? 00:00:00 [kworker/0:0]  
root 17216 2 0 09:00 ? 00:00:00 [kworker/7:2]  
root 17286 2 0 09:01 ? 00:00:00 [kworker/1:0]  
root 17890 5956 0 09:12 pts/1 00:00:00 sudo su -  
root 17903 17890 0 09:12 pts/1 00:00:00 su -  
root 17904 17903 0 09:12 pts/1 00:00:00 -bash  
root 18533 2 0 09:20 ? 00:00:00 [kworker/0:2]  
venkata+ 19060 4348 0 09:29 pts/0 00:00:00 ps -ef  
root 21595 2 0 Apr11 ? 00:00:00 [kworker/2:2H]  
root 35821 2 0 Apr10 ? 00:00:01 [kworker/6:0]  
root 40974 2 0 Apr10 ? 00:00:01 [kworker/2:1]  
root 41085 2 0 00:41 ? 00:00:00 [kworker/4:1H]  
root 52401 2 0 Apr10 ? 00:00:01 [kworker/4:0]  
root 58448 2 0 04:00 ? 00:00:00 [kworker/5:2]  
root 64528 2 0 05:10 ? 00:00:00 [kworker/3:2]

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 12, 2017, 9:47am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/9 "2017-04-12T09:47:04Z")

</div>

What is this process?

```
venkata+ 4433 4348 0 06:33 pts/0 00:00:18 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOc
```

---

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 12, 2017, 9:48am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/10 "2017-04-12T09:48:59Z")

</div>

I dont know this. could you please tell me.

---

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 12, 2017, 10:08am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/11 "2017-04-12T10:08:23Z")

</div>

Hi dadoonet,

now it showing bellow details. elasticsearch working correctly or not ?

Could you please tell me.

[2017-04-12T10:05:59,882][INFO][o.e.n.Node] [] initializing ...  
[2017-04-12T10:05:59,957][INFO][o.e.e.NodeEnvironment] [mASLKlx] using [1] data paths, mounts [[/ (rootfs)]], net usable\_space [26.4gb], net total\_space [31.4gb], spins? [unknown], types [rootfs]  
[2017-04-12T10:05:59,957][INFO][o.e.e.NodeEnvironment] [mASLKlx] heap size [1.9gb], compressed ordinary object pointers [true]  
[2017-04-12T10:05:59,958][INFO][o.e.n.Node] node name [mASLKlx] derived from node ID [mASLKlxsR5qYPuX-hXd73w]; set [[node.name](http://node.name)] to override  
[2017-04-12T10:05:59,960][INFO][o.e.n.Node] version[5.2.0], pid[21379], build[24e05b9/2017-01-24T19:52:35.800Z], OS[Linux/3.10.0-514.10.2.el7.x86\_64/amd64], JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/1.8.0\_121/25.121-b13]  
[2017-04-12T10:06:00,576][INFO][o.e.p.PluginsService] [mASLKlx] loaded module [aggs-matrix-stats]  
[2017-04-12T10:06:00,577][INFO][o.e.p.PluginsService] [mASLKlx] loaded module [ingest-common]  
[2017-04-12T10:06:00,577][INFO][o.e.p.PluginsService] [mASLKlx] loaded module [lang-expression]  
[2017-04-12T10:06:00,577][INFO][o.e.p.PluginsService] [mASLKlx] loaded module [lang-groovy]  
[2017-04-12T10:06:00,577][INFO][o.e.p.PluginsService] [mASLKlx] loaded module [lang-mustache]  
[2017-04-12T10:06:00,577][INFO][o.e.p.PluginsService] [mASLKlx] loaded module [lang-painless]  
[2017-04-12T10:06:00,577][INFO][o.e.p.PluginsService] [mASLKlx] loaded module [percolator]  
[2017-04-12T10:06:00,577][INFO][o.e.p.PluginsService] [mASLKlx] loaded module [reindex]  
[2017-04-12T10:06:00,577][INFO][o.e.p.PluginsService] [mASLKlx] loaded module [transport-netty3]  
[2017-04-12T10:06:00,577][INFO][o.e.p.PluginsService] [mASLKlx] loaded module [transport-netty4]  
[2017-04-12T10:06:00,578][INFO][o.e.p.PluginsService] [mASLKlx] no plugins loaded  
[2017-04-12T10:06:02,289][INFO][o.e.n.Node] initialized  
[2017-04-12T10:06:02,289][INFO][o.e.n.Node] [mASLKlx] starting ...  
[2017-04-12T10:06:02,451][INFO][o.e.t.TransportService] [mASLKlx] publish\_address {127.0.0.1:9301}, bound\_addresses {[::1]:9301}, {127.0.0.1:9301}  
[2017-04-12T10:06:02,457][WARN][o.e.b.BootstrapChecks] [mASLKlx] max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]  
[2017-04-12T10:06:05,500][INFO][o.e.c.s.ClusterService] [mASLKlx] new\_master {mASLKlx}{mASLKlxsR5qYPuX-hXd73w}{g5S4Sv29SkyCdQ5Hw4-Zpw}{127.0.0.1}{127.0.0.1:9301}, reason: zen-disco-elected-as-master ([0] nodes joined)  
[2017-04-12T10:06:05,520][INFO][o.e.h.HttpServer] [mASLKlx] publish\_address {127.0.0.1:9201}, bound\_addresses {[::1]:9201}, {127.0.0.1:9201}  
[2017-04-12T10:06:05,521][INFO][o.e.n.Node] [mASLKlx] started  
[2017-04-12T10:06:05,533][INFO][o.e.g.GatewayService] [mASLKlx] recovered [0] indices into cluster\_state

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 12, 2017, 11:02am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/12 "2017-04-12T11:02:51Z")

</div>

Yes. For development.

---

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 12, 2017, 11:07am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/13 "2017-04-12T11:07:23Z")

</div>

Thanks dadoonet,

I am runing kibana. It will showing error. Could you please help.

log [10:17:01.064] [info][status][plugin:kibana@5.2.0] Status changed from uninitialized to green - Ready  
log [10:17:01.141] [info][status][plugin:elasticsearch@5.2.0] Status changed from uninitialized to yellow - Waiting for Elasticsearch  
log [10:17:01.165] [info][status][plugin:console@5.2.0] Status changed from uninitialized to green - Ready  
log [10:17:01.323] [info][status][plugin:timelion@5.2.0] Status changed from uninitialized to green - Ready  
log [10:17:01.328] [info][listening] Server running at [http://localhost:5601](http://localhost:5601)  
log [10:17:01.329] [info][status][ui settings] Status changed from uninitialized to yellow - Elasticsearch plugin is yellow  
log [10:17:04.156] [error][status][plugin:elasticsearch@5.2.0] Status changed from yellow to red - Request Timeout after 3000ms  
log [10:17:04.157] [error][status][ui settings] Status changed from yellow to red - Elasticsearch plugin is red

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 12, 2017, 12:03pm UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/14 "2017-04-12T12:03:41Z")

</div>

Actually no. You still have another elasticsearch running. Or at least this one started on port 9201 instead of 9200.  
Which means that you have another elasticsearch running already.

---

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 13, 2017, 4:50am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/15 "2017-04-13T04:50:03Z")

</div>

Thanks Dadoonet

I have run logstash. It will showing error.Could you please tell me.

Sending Logstash's logs to /elk/logstash-5.2.0/logs which is now configured via log4j2.properties  
[2017-04-13T04:45:15,744][INFO][logstash.setting.writabledirectory] Creating directory {:setting=\>"path.queue", :path=\>"/elk/logstash-5.2.0/data/queue"}  
ERROR: No configuration file was specified. Perhaps you forgot to provide the '-f yourlogstash.conf' flag?  
usage:  
bin/logstash -f CONFIG\_PATH [-t] [-r] [] [-w COUNT] [-l LOG]  
bin/logstash -e CONFIG\_STR [-t] [--log.level fatal|error|warn|info|debug|trace] [-w COUNT] [-l LOG]  
bin/logstash -i SHELL [--log.level fatal|error|warn|info|debug|trace]  
bin/logstash -V [--log.level fatal|error|warn|info|debug|trace]  
bin/logstash --help

---

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 13, 2017, 6:09am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/16 "2017-04-13T06:09:54Z")

</div>

Hi Dadoonet,

How to check elasticsearch runing or [not.Is](http://not.Is) there any command.

I tried service elasticsearch status  
systemctl status elasticsearch.service

both commands not working

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 13, 2017, 7:14am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/17 "2017-04-13T07:14:24Z")

</div>

```
ps -ef | grep java
```

---

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 13, 2017, 7:31am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/18 "2017-04-13T07:31:32Z")

</div>

venkata+ 4433 4348 0 Apr12 pts/0 00:00:18 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -server -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -Djdk.io.permissionsUseCanonicalPath=true -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Dlog4j.skipJansi=true -XX:+HeapDumpOnOutOfMemoryError -Des.path.home=/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0 -cp /home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/elasticsearch-5.2.0.jar:/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/\* org.elasticsearch.bootstrap.Elasticsearch  
venkata+ 6831 4348 0 Apr12 pts/0 00:00:02 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -server -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -Djdk.io.permissionsUseCanonicalPath=true -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Dlog4j.skipJansi=true -XX:+HeapDumpOnOutOfMemoryError -Des.path.home=/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0 -cp /home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/elasticsearch-5.2.0.jar:/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/\* org.elasticsearch.bootstrap.Elasticsearch  
venkata+ 7284 4348 0 Apr12 pts/0 00:00:02 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -server -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -Djdk.io.permissionsUseCanonicalPath=true -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Dlog4j.skipJansi=true -XX:+HeapDumpOnOutOfMemoryError -Des.path.home=/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0 -cp /home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/elasticsearch-5.2.0.jar:/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/\* org.elasticsearch.bootstrap.Elasticsearch  
venkata+ 7467 4348 0 Apr12 pts/0 00:00:03 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -server -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -Djdk.io.permissionsUseCanonicalPath=true -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Dlog4j.skipJansi=true -XX:+HeapDumpOnOutOfMemoryError -Des.path.home=/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0 -cp /home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/elasticsearch-5.2.0.jar:/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/\* org.elasticsearch.bootstrap.Elasticsearch  
venkata+ 8342 4348 0 Apr12 pts/0 00:00:02 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -server -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -Djdk.io.permissionsUseCanonicalPath=true -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Dlog4j.skipJansi=true -XX:+HeapDumpOnOutOfMemoryError -Des.path.home=/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0 -cp /home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/elasticsearch-5.2.0.jar:/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/\* org.elasticsearch.bootstrap.Elasticsearch  
venkata+ 8782 4348 0 Apr12 pts/0 00:00:03 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -server -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -Djdk.io.permissionsUseCanonicalPath=true -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Dlog4j.skipJansi=true -XX:+HeapDumpOnOutOfMemoryError -Des.path.home=/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0 -cp /home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/elasticsearch-5.2.0.jar:/home/venkata.bollineni/mywizardservices/elasticsearch/elasticsearch-5.2.0/lib/\* org.elasticsearch.bootstrap.Elasticsearch  
venkata+ 26567 20868 0 Apr12 pts/1 00:00:12 /bin/java -Xms2g -Xmx2g -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -server -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -Djdk.io.permissionsUseCanonicalPath=true -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Dlog4j.skipJansi=true -XX:+HeapDumpOnOutOfMemoryError -Des.path.home=/elk/elasticsearch-5.2.0 -cp /elk/elasticsearch-5.2.0/lib/elasticsearch-5.2.0.jar:/elk/elasticsearch-5.2.0/lib/\* org.elasticsearch.bootstrap.Elasticsearch  
root 38216 21070 0 07:30 pts/0 00:00:00 grep --color=auto java

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [April 13, 2017, 7:50am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/19 "2017-04-13T07:50:35Z")

</div>

You launched 7 elasticsearch nodes.  
You probably modified some settings for that as it's not possible out of the box.

---

<div class="post-metadata">

**Author:** ![bvnages](https://avatars.discourse-cdn.com/v4/letter/b/ecccb3/32.png) [@bvnages](https://discuss.elastic.co/u/bvnages)\
**Post date:** [April 13, 2017, 7:51am UTC](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103/20 "2017-04-13T07:51:16Z")

</div>

How to disable that nodes . Could you please tell me.

[Next page](https://discuss.elastic.co/t/i-will-run-elasticsearch-it-will-getting-error/82103.md?page=2)
