# IllegalStateException

**URL:** <https://discuss.elastic.co/t/illegalstateexception/33648>\
**Category:** Elasticsearch\
**Created:** [November 3, 2015, 3:20pm UTC](https://discuss.elastic.co/t/illegalstateexception/33648 "2015-11-03T15:20:15Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![tgdesrochers](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tgdesrochers/32/51322_2.png) [@tgdesrochers](https://discuss.elastic.co/u/tgdesrochers)\
**Post date:** [November 3, 2015, 3:20pm UTC](https://discuss.elastic.co/t/illegalstateexception/33648/1 "2015-11-03T15:20:15Z")

</div>

I have just upgraded my nodes to 2.0 from 1.7. I upgraded via RPM package. When I restart my nodes I get the following error:

[2015-11-03 10:13:02,789][ERROR][gateway] [MASTER\_NODE\_1] failed to read local state, exiting...  
java.lang.IllegalStateException: unable to upgrade the mappings for the index [logstash-2015.10.21], reason: [Field name [basic\_constraints.ca] cannot contain '.']

I cannot figure out why I am getting this exception. Did I miss something in the breaking changes?

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [November 3, 2015, 3:24pm UTC](https://discuss.elastic.co/t/illegalstateexception/33648/2 "2015-11-03T15:24:34Z")

</div>

Field names may not contain dots in 2.0: [https://www.elastic.co/guide/en/elasticsearch/reference/2.0/\_mapping\_changes.html#\_field\_names\_may\_not\_contain\_dots](https://www.elastic.co/guide/en/elasticsearch/reference/2.0/_mapping_changes.html#_field_names_may_not_contain_dots)

---

<div class="post-metadata">

**Author:** ![tgdesrochers](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tgdesrochers/32/51322_2.png) [@tgdesrochers](https://discuss.elastic.co/u/tgdesrochers)\
**Post date:** [November 3, 2015, 3:55pm UTC](https://discuss.elastic.co/t/illegalstateexception/33648/3 "2015-11-03T15:55:07Z")

</div>

I guess I somewhat understand this. I have many fields that contain dots in them. I am using BroIDS and almost all fields from their logs have dots in them. The only exception I am getting at the moment is the one listed above. I don't have an issue deleting the index and starting fresh since I am upgrading my test network before attempting this on a production network, but it seems strange that this is the one field creating the exception.

Since now I cannot start the nodes where I upgraded to 2.0 how do I interact with the ES API to change index mappings or delete indices?

---

<div class="post-metadata">

**Author:** ![magnusbaeck](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/magnusbaeck/32/44943_2.png) [@magnusbaeck](https://discuss.elastic.co/u/magnusbaeck)\
**Post date:** [November 3, 2015, 5:59pm UTC](https://discuss.elastic.co/t/illegalstateexception/33648/4 "2015-11-03T17:59:31Z")

</div>

I'd assume you have to downgrade to 1.7, start up ES, and the necessary adjustments, double-check that the migration plugin is happy, then reattempt the upgrade.

---

<div class="post-metadata">

**Author:** ![tgdesrochers](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tgdesrochers/32/51322_2.png) [@tgdesrochers](https://discuss.elastic.co/u/tgdesrochers)\
**Post date:** [November 3, 2015, 6:02pm UTC](https://discuss.elastic.co/t/illegalstateexception/33648/5 "2015-11-03T18:02:48Z")

</div>

thanks, I got things to work on my Master nodes. Now when I try to get my worker nodes started I get:

CONF\_FILE setting is no longer supported. elasticsearch.yml must be placed in the config directory and cannot be renamed.

Not sure where to change this and its not well documented.

This upgrade is not going well (all user error for sure) I'm sure it will be worth it in the end

my elasticsearch.yml files in in /etc/elasticsearch/.

I installed the upgrade via RPM

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:40pm UTC](https://discuss.elastic.co/t/illegalstateexception/33648/6 "2017-07-05T23:40:50Z")

</div>


