# ILM policy is notworking

**URL:** https://discuss.elastic.co/t/ilm-policy-is-notworking/267891
**Category:** Elasticsearch
**Tags:** ilm-index-lifecycle-management
**Created:** [March 20, 2021, 6:27pm UTC](https://discuss.elastic.co/t/ilm-policy-is-notworking/267891 "2021-03-20T18:27:20Z")
**Posts on this page:** 1
**Showing post:** 6

<div class="post-metadata">

### Author: ![AClerk](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/aclerk/32/55297_2.png) [@AClerk](https://discuss.elastic.co/u/AClerk)
#### Post date: [March 23, 2021, 12:07am UTC](https://discuss.elastic.co/t/ilm-policy-is-notworking/267891/6 "2021-03-23T00:07:34Z")

</div>

How did you apply the settings?  
Not sure what is going on here, maybe someone from the elastic team can assist?  
Anyhow, try to remove the rollover from your template and test again.

Some discussions:

> [@Index management error: "Index is not the write index for alias"](https://discuss.elastic.co/t/index-management-error-index-is-not-the-write-index-for-alias/180894/2):
>
> Had the same thing happen. If you use the rollover API manually to do the rollover instead of using your ILM policy, each time the policy runs it will throw this error. This happens because the index is not being flagged as complete, when the policy runs it appears to be trying to manage the index but it's not flagged as writable. Add "index.lifecycle.indexing\_complete": "true" to the index in question, then clear the error by retrying the policy. When the policy next runs(default is every 1…

> [@Index \[filebeat-7.4.1-YYYY.MM.DD\] is not the write index for alias \[filebeat-7.4.1\]](https://discuss.elastic.co/t/index-filebeat-7-4-1-yyyy-mm-dd-is-not-the-write-index-for-alias-filebeat-7-4-1/206405):
>
> Hi, After installation on 1 filebeat agent to a new 7.4.1 Elastic cluster, I have the following errors on my filebeat indices: Index lifecycle error illegal\_argument\_exception: index [filebeat-7.4.1-2019.11.04] is not the write index for alias [filebeat-7.4.1] GET filebeat-7.4.1/\_ilm/explain "filebeat-7.4.1-2019.11.04" : { "index" : "filebeat-7.4.1-2019.11.04", "managed" : true, "policy" : "filebeat-7.4.1", "lifecycle\_date\_millis" : 1572822004864, "age" : "1…

> [@Index Lifecycle Error - Not Write Index](https://discuss.elastic.co/t/index-lifecycle-error-not-write-index/207068):
>
> Hello guys, i tried to implement an ilm-policy. Now i always get the following error: illegal\_argument\_exception: source alias [Syslog] does not point to a write index Now, i don't really get how i make this index my write index. Anybody got an idea how to solve this, without loosing data? Greets, Moritz

---

_[View the full topic](https://discuss.elastic.co/t/ilm-policy-is-notworking/267891)._
