# ILM reports error illegal\_argument\_exception

**URL:** <https://discuss.elastic.co/t/ilm-reports-error-illegal-argument-exception/194968>\
**Category:** Beats\
**Tags:** metricbeat\
**Created:** [August 13, 2019, 6:53am UTC](https://discuss.elastic.co/t/ilm-reports-error-illegal-argument-exception/194968 "2019-08-13T06:53:41Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![swieczor](https://avatars.discourse-cdn.com/v4/letter/s/848f3c/32.png) [@swieczor](https://discuss.elastic.co/u/swieczor)\
**Post date:** [August 13, 2019, 6:53am UTC](https://discuss.elastic.co/t/ilm-reports-error-illegal-argument-exception/194968/1 "2019-08-13T06:53:42Z")

</div>

**Elasticsearch version** : 7.2.0  
Installed by eck-operator: 0.9.0-rc7

**Plugins installed** : as installed by eck-operator version 0.9.0-rc7  
[docker.elastic.co/elasticsearch/elasticsearch:7.2.0](http://docker.elastic.co/elasticsearch/elasticsearch:7.2.0)

**JVM version** ( `java -version` ): as used in elasticsearch docker image

**OS version** ( `uname -a` if on a Unix-like system): Host OS: Ubuntu 16.04,  
Linux 4.15.0-55-generic

**Description of the problem including expected versus actual behavior** :  
The following options are used for deploying metricbeat helm chart - overwritten values below.

ILM reports the following error:  
illegal\_argument\_exception: index.lifecycle.rollover\_alias [metricbeat] does not point to index [metricbeat-nfs-provisioner-2019.08.09]

**Steps to reproduce** :

1. install elasticsearch 7.2.0 using eck-operator at elasticsearch namespace.  
Default install with 2 nodes.

2. install metricbeat using helm chart: stable/metricbeat with the following overwrite myvalues.yml:  
helm install -f myvalues.yml --name metric --namespace elasticsearch stable/metricbeat

myvalues.yml - \> rename txt to yml  
[myvalues.txt](https://github.com/elastic/elasticsearch/files/3492626/myvalues.txt)

1. Wait 2-5min to see error on kibana. It is not seen immediately.

I read [https://www.elastic.co/guide/en/beats/metricbeat/current/ilm.html](https://www.elastic.co/guide/en/beats/metricbeat/current/ilm.html) documentation and try to put setup.ilm.pattern: "{[kubernetes.pod.\_module.namespace]}-{now/d}-01"  
but error is appeared: kubernetes.pod.\_module.namespace cannot be mapped to date format.

Goal is to create separate indices per namespace and control them via ILM policy.

Thank you! Slawek Wieczorkowski

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 10, 2019, 6:53am UTC](https://discuss.elastic.co/t/ilm-reports-error-illegal-argument-exception/194968/2 "2019-09-10T06:53:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
