# I'm trying to create a cluster on AWS but cannot start the service

**URL:** <https://discuss.elastic.co/t/im-trying-to-create-a-cluster-on-aws-but-cannot-start-the-service/87311>\
**Category:** Elasticsearch\
**Created:** [May 27, 2017, 12:37am UTC](https://discuss.elastic.co/t/im-trying-to-create-a-cluster-on-aws-but-cannot-start-the-service/87311 "2017-05-27T00:37:14Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![MountainMoon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mountainmoon/32/125700_2.png) [@MountainMoon](https://discuss.elastic.co/u/MountainMoon)\
**Post date:** [May 27, 2017, 12:37am UTC](https://discuss.elastic.co/t/im-trying-to-create-a-cluster-on-aws-but-cannot-start-the-service/87311/1 "2017-05-27T00:37:14Z")

</div>

I was creating a ES 5.4 cluster on AWS. But the service cannot start with no useful error message:  
elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Fri 2017-05-26 16:23:04 -08; 8s ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 10500 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 10498 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 10500 (code=exited, status=1/FAILURE)

May 26 16:23:04 ip-172-31-35-134.localdomain systemd[1]: Starting Elasticsearch...  
May 26 16:23:04 ip-172-31-35-134.localdomain systemd[1]: Started Elasticsearch.  
May 26 16:23:04 ip-172-31-35-134.localdomain systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
May 26 16:23:04 ip-172-31-35-134.localdomain systemd[1]: Unit elasticsearch.service entered failed state.  
May 26 16:23:04 ip-172-31-35-134.localdomain systemd[1]: elasticsearch.service failed.  
Checking jexec statusnetconsole module not loaded

I took a look at the "/data/elasticlog" folder which i set for logs. There is no log.  
And I copied the config files from /etc/elasticsearch to /usr/share/elasticsearch/config and try to run elasticsearch from /bin directly. It works!

Any idea about this issue or where i can find the error log for the service will be very appreciated.  
Thanks!

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [May 28, 2017, 7:38am UTC](https://discuss.elastic.co/t/im-trying-to-create-a-cluster-on-aws-but-cannot-start-the-service/87311/2 "2017-05-28T07:38:29Z")

</div>

How did you install ES?

---

<div class="post-metadata">

**Author:** ![MountainMoon](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mountainmoon/32/125700_2.png) [@MountainMoon](https://discuss.elastic.co/u/MountainMoon)\
**Post date:** [May 30, 2017, 8:09pm UTC](https://discuss.elastic.co/t/im-trying-to-create-a-cluster-on-aws-but-cannot-start-the-service/87311/3 "2017-05-30T20:09:04Z")

</div>

Update. Some configuration are not supported in ES5.0 like the ES\_HEAP\_SIZE. I followed an old document to configure the system so it doesn't work.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 27, 2017, 8:09pm UTC](https://discuss.elastic.co/t/im-trying-to-create-a-cluster-on-aws-but-cannot-start-the-service/87311/4 "2017-06-27T20:09:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
