# Import CSV data to Elastic App Search "block in start\_input" Error

**URL:** <https://discuss.elastic.co/t/import-csv-data-to-elastic-app-search-block-in-start-input-error/237937>\
**Category:** Logstash\
**Created:** [June 20, 2020, 7:47pm UTC](https://discuss.elastic.co/t/import-csv-data-to-elastic-app-search-block-in-start-input-error/237937 "2020-06-20T19:47:50Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![th3Hopper](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/th3hopper/32/70750_2.png) [@th3Hopper](https://discuss.elastic.co/u/th3Hopper)\
**Post date:** [June 20, 2020, 7:47pm UTC](https://discuss.elastic.co/t/import-csv-data-to-elastic-app-search-block-in-start-input-error/237937/1 "2020-06-20T19:47:50Z")

</div>

I'm trying to import CSV data to my Elastic App search but it throwing an error.

**Error Message:-**

```auto
[2020-06-21T01:40:17,552][INFO][filewatch.observingtail][main][07a10415268d8655d99cdad82a61cbca125e21687e65bc0296c88f92c9d9c4d1] START, creating Discoverer, Watch with file and sincedb collections
[2020-06-21T01:40:17,555][ERROR][logstash.javapipeline][main][07a10415268d8655d99cdad82a61cbca125e21687e65bc0296c88f92c9d9c4d1] A plugin had an unrecoverable error. Will restart this plugin.
  Pipeline_id:main
  Plugin: <LogStash::Inputs::File start_position=>"beginning", path=>["/Users/thehopper/Documents/elastic/Raw_Data/first.csv"], id=>"07a10415268d8655d99cdad82a61cbca125e21687e65bc0296c88f92c9d9c4d1", sincedb_path=>"/dev/null", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_a55d2b4b-0837-4754-88e1-ee7ca0dc916f", enable_metric=>true, charset=>"UTF-8">, stat_interval=>1.0, discover_interval=>15, sincedb_write_interval=>15.0, delimiter=>"\n", close_older=>3600.0, mode=>"tail", file_completed_action=>"delete", sincedb_clean_after=>1209600.0, file_chunk_size=>32768, file_chunk_count=>140737488355327, file_sort_by=>"last_modified", file_sort_direction=>"asc", exit_after_read=>false, check_archive_validity=>false>
  Error: Permission denied - Permission denied
  Exception: Errno::EACCES
  Stack: org/jruby/RubyFile.java:1267:in `utime'
uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1133:in `block in touch'
org/jruby/RubyArray.java:1809:in `each'
uri:classloader:/META-INF/jruby.home/lib/ruby/stdlib/fileutils.rb:1130:in `touch'
/Users/thehopper/Documents/elastic/logstash-7.8.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/filewatch/sincedb_collection.rb:22:in `initialize'
/Users/thehopper/Documents/elastic/logstash-7.8.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/filewatch/observing_base.rb:62:in `build_watch_and_dependencies'
/Users/thehopper/Documents/elastic/logstash-7.8.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/filewatch/observing_base.rb:56:in `initialize'
/Users/thehopper/Documents/elastic/logstash-7.8.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/logstash/inputs/file.rb:345:in `start_processing'
/Users/thehopper/Documents/elastic/logstash-7.8.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-file-4.1.18/lib/logstash/inputs/file.rb:361:in `run'
/Users/thehopper/Documents/elastic/logstash-7.8.0/logstash-core/lib/logstash/java_pipeline.rb:345:in `inputworker'
/Users/thehopper/Documents/elastic/logstash-7.8.0/logstash-core/lib/logstash/java_pipeline.rb:336:in `block in start_input'

```

**Config file:-**

```auto
input {
  file {
    path => ["/Users/thehopper/Documents/elastic/Raw_Data/first.csv"]
    start_position => "beginning"
    sincedb_path => "/dev/null"
  }
}
filter {
  csv {
    separator => ","
    columns => ["first","last","Full Name","Solved*","Age","Gender","Race","Date","Address","Neighborhood","status","lat","lon","Map Description","Story","URL"]
  }
}
output {
   elastic_app_search {
     url => "http://localhost:3002"
     api_key => "private-key...."
     engine => "email-pass-engine"
  }
  stdout {
    codec => rubydebug
  }
}

```

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [June 20, 2020, 7:58pm UTC](https://discuss.elastic.co/t/import-csv-data-to-elastic-app-search-block-in-start-input-error/237937/2 "2020-06-20T19:58:06Z")

</div>

[That code](https://github.com/logstash-plugins/logstash-input-file/blob/a0384c08f89d661c2420fb35a737b438030a1bcc/lib/filewatch/sincedb_collection.rb#L22) is trying to touch the sincedb. It appears you do not have write access to /dev/null. Check the permissions and ownership of it.

---

<div class="post-metadata">

**Author:** ![th3Hopper](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/th3hopper/32/70750_2.png) [@th3Hopper](https://discuss.elastic.co/u/th3Hopper)\
**Post date:** [June 20, 2020, 8:26pm UTC](https://discuss.elastic.co/t/import-csv-data-to-elastic-app-search-block-in-start-input-error/237937/3 "2020-06-20T20:26:07Z")

</div>

Thank you for your response. You were right, I run the command with Sudo now it's working.

---

<div class="post-metadata">

**Author:** ![th3Hopper](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/th3hopper/32/70750_2.png) [@th3Hopper](https://discuss.elastic.co/u/th3Hopper)\
**Post date:** [June 20, 2020, 8:31pm UTC](https://discuss.elastic.co/t/import-csv-data-to-elastic-app-search-block-in-start-input-error/237937/4 "2020-06-20T20:31:11Z")

</div>

can you help me with another thing, my import file so big. Is there any way to see the progress of the import.

I have tried with small file but after finish import, it's not showing any successful mange So If my file is big how do I know it's or not?

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [June 20, 2020, 8:40pm UTC](https://discuss.elastic.co/t/import-csv-data-to-elastic-app-search-block-in-start-input-error/237937/5 "2020-06-20T20:40:42Z")

</div>

The [pipeline stats API](https://www.elastic.co/guide/en/logstash/current/node-stats-api.html#pipeline-stats) can be used to see how many events have passed through input, filters, and outputs.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 18, 2020, 8:40pm UTC](https://discuss.elastic.co/t/import-csv-data-to-elastic-app-search-block-in-start-input-error/237937/6 "2020-07-18T20:40:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
