# Importing Existing Beat Dashboards in offline server

**URL:** <https://discuss.elastic.co/t/importing-existing-beat-dashboards-in-offline-server/69075>\
**Category:** Kibana\
**Created:** [December 14, 2016, 7:42pm UTC](https://discuss.elastic.co/t/importing-existing-beat-dashboards-in-offline-server/69075 "2016-12-14T19:42:16Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ravikumar\_G](https://avatars.discourse-cdn.com/v4/letter/r/71e660/32.png) [@Ravikumar\_G](https://discuss.elastic.co/u/Ravikumar_G)\
**Post date:** [December 14, 2016, 7:42pm UTC](https://discuss.elastic.co/t/importing-existing-beat-dashboards-in-offline-server/69075/1 "2016-12-14T19:42:16Z")

</div>

Hi I'm trying to install Metric dashboard its my first time trying this

Downloaded .zip beats tried still by defaults its taking to [https://artifacts.elastic.co/downloads/beats/beats-dashboards/beats-dashboards-5.1.1.zip](https://artifacts.elastic.co/downloads/beats/beats-dashboards/beats-dashboards-5.1.1.zip)

tried to edit script looks like import\_dashboards is not human readable

[root@elk-cclab38 metricbeat]# ./scripts/import\_dashboards /root/beats-dashboards-master.zip  
fail to set the mapping. Error: Put [http://127.0.0.1:9200/.kibana/\_mapping/search:](http://127.0.0.1:9200/.kibana/_mapping/search:) dial tcp 127.0.0.1:9200: getsockopt: connection refused  
Create temporary directory /tmp/tmp813730817  
Downloading [https://artifacts.elastic.co/downloads/beats/beats-dashboards/beats-dashboards-5.1.1.zip](https://artifacts.elastic.co/downloads/beats/beats-dashboards/beats-dashboards-5.1.1.zip)  
^C  
[root@elk-cclab38 metricbeat]#

---

<div class="post-metadata">

**Author:** ![Ravikumar\_G](https://avatars.discourse-cdn.com/v4/letter/r/71e660/32.png) [@Ravikumar\_G](https://discuss.elastic.co/u/Ravikumar_G)\
**Post date:** [December 14, 2016, 7:47pm UTC](https://discuss.elastic.co/t/importing-existing-beat-dashboards-in-offline-server/69075/2 "2016-12-14T19:47:57Z")

</div>

[https://www.elastic.co/guide/en/beats/libbeat/master/import-dashboards.html](https://www.elastic.co/guide/en/beats/libbeat/master/import-dashboards.html)

[root@elk-cclab38 metricbeat]# ./scripts/import\_dashboards -file /root/beats-dashboards-5.1.1.zip  
fail to set the mapping. Error: Put [http://127.0.0.1:9200/.kibana/\_mapping/search:](http://127.0.0.1:9200/.kibana/_mapping/search:) dial tcp 127.0.0.1:9200: getsockopt: connection refused  
Create temporary directory /tmp/tmp964028833  
Unzip archive /tmp/tmp964028833  
/tmp/tmp964028833/beats-dashboards-5.1.1/filebeat  
/tmp/tmp964028833/beats-dashboards-5.1.1/heartbeat  
/tmp/tmp964028833/beats-dashboards-5.1.1/metricbeat  
Import directory /tmp/tmp964028833/beats-dashboards-5.1.1/metricbeat/index-pattern  
Import index to /.kibana/index-pattern/metricbeat-\* from /tmp/tmp964028833/beats-dashboards-5.1.1/metricbeat/index-pattern/metricbeat.json  
ERROR: couldn't load json. Error: Put [http://127.0.0.1:9200/.kibana/index-pattern/metricbeat-](http://127.0.0.1:9200/.kibana/index-pattern/metricbeat-)_: dial tcp 127.0.0.1:9200: getsockopt: connection refused  
fail to import index-pattern: fail to load directory /tmp/tmp964028833/beats-dashboards-5.1.1/metricbeat/index-pattern: error loading /tmp/tmp964028833/beats-dashboards-5.1.1/metricbeat/index-pattern/metricbeat.json: couldn't load json. Error: Put [http://127.0.0.1:9200/.kibana/index-pattern/metricbeat-](http://127.0.0.1:9200/.kibana/index-pattern/metricbeat-)_: dial tcp 127.0.0.1:9200: getsockopt: connection refused

[root@elk-cclab38 metricbeat]#

---

<div class="post-metadata">

**Author:** ![Ravikumar\_G](https://avatars.discourse-cdn.com/v4/letter/r/71e660/32.png) [@Ravikumar\_G](https://discuss.elastic.co/u/Ravikumar_G)\
**Post date:** [December 14, 2016, 8:11pm UTC](https://discuss.elastic.co/t/importing-existing-beat-dashboards-in-offline-server/69075/3 "2016-12-14T20:11:46Z")

</div>

I think i figured out 🙂

[root@elk-cclab38 metricbeat]# ./scripts/import\_dashboards -file /root/beats-dashboards-5.1.1.zip -es [http://10.251.33.130:9200](http://10.251.33.130:9200)  
Create temporary directory /tmp/tmp679203075  
Unzip archive /tmp/tmp679203075  
/tmp/tmp679203075/beats-dashboards-5.1.1/filebeat  
/tmp/tmp679203075/beats-dashboards-5.1.1/heartbeat  
/tmp/tmp679203075/beats-dashboards-5.1.1/metricbeat  
Import directory /tmp/tmp679203075/beats-dashboards-5.1.1/metricbeat/index-pattern  
Import index to /.kibana/index-pattern/metricbeat-\* from /tmp/tmp679203075/beats-dashboards-5.1.1/metricbeat/index-pattern/metricbeat.json

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 11, 2017, 8:11pm UTC](https://discuss.elastic.co/t/importing-existing-beat-dashboards-in-offline-server/69075/4 "2017-01-11T20:11:59Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
