# IncompatibleClassChangeError\[Implementing class\]

**URL:** <https://discuss.elastic.co/t/incompatibleclasschangeerror-implementing-class/17684>\
**Category:** Elasticsearch\
**Created:** [May 23, 2014, 2:54am UTC](https://discuss.elastic.co/t/incompatibleclasschangeerror-implementing-class/17684 "2014-05-23T02:54:12Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Olivier\_B](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/olivier_b/32/1422_2.png) [@Olivier\_B](https://discuss.elastic.co/u/Olivier_B)\
**Post date:** [May 23, 2014, 2:54am UTC](https://discuss.elastic.co/t/incompatibleclasschangeerror-implementing-class/17684/1 "2014-05-23T02:54:12Z")

</div>

Hey!

I'm using Elasticsearch 1.1.1 on ubuntu on java 7:

java version "1.7.0\_55"  
OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1)  
OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)

It's working perfectly. But, when I try to upgrade to 1.2.0, elasticsearch  
won't start:  
[2014-05-23 02:32:53,812][INFO][node] [Larry Bodine]version  
[1.2.0], pid[43], build[c82387f/2014-05-22T12:49:13Z]  
[2014-05-23 02:32:53,813][INFO][node] [Larry Bodine]initializing  
...  
[2014-05-23 02:32:53,853][INFO][plugins] [Larry Bodine]loaded  
[cloud-aws, jetty, river-couchdb, lang-javascript], sites [bigdesk]  
[2014-05-23 02:32:56,655][INFO][node] [Larry Bodine]initialized  
[2014-05-23 02:32:56,655][INFO][node] [Larry Bodine]starting  
...  
[2014-05-23 02:32:56,800][INFO][transport] [Larry Bodine]bound\_address  
{inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address {inet[/172.17.0.2:9300]}  
[2014-05-23 02:32:59,846][INFO][cluster.service] [Larry Bodine]  
new\_master [Larry  
Bodine][QBC3No2hQYKosA-cz9Pfog][7c414f6cd187][inet[/172.17.0.2:9300]],  
reason: zen-disco-join (elected\_as\_master)  
[2014-05-23 02:32:59,895][INFO][discovery] [Larry Bodine]  
es-cluster/QBC3No2hQYKosA-cz9Pfog  
[2014-05-23 02:32:59,939][INFO][gateway] [Larry Bodine]recovered  
[0] indices into cluster\_state  
{1.2.0}: Startup Failed ...

- IncompatibleClassChangeError[Implementing class]

Any idea of what's happening?

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/91b5acc5-28bc-470c-badf-0729b8250235%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/91b5acc5-28bc-470c-badf-0729b8250235%40googlegroups.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![Ivan](https://avatars.discourse-cdn.com/v4/letter/i/df788c/32.png) [@Ivan](https://discuss.elastic.co/u/Ivan)\
**Post date:** [May 23, 2014, 4:44pm UTC](https://discuss.elastic.co/t/incompatibleclasschangeerror-implementing-class/17684/2 "2014-05-23T16:44:56Z")

</div>

Not positive, but I would assume the issue is with one of your plugins. Try  
removing them and see if the problem persist and if it does, keep re-adding  
them one by one until you find the culprit.

--  
Ivan

On Thu, May 22, 2014 at 7:54 PM, Olivier B [obierlai@gmail.com](mailto:obierlai@gmail.com) wrote:

> Hey!
> 
> I'm using Elasticsearch 1.1.1 on ubuntu on java 7:
> 
> java version "1.7.0\_55"  
> OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1)  
> OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)
> 
> It's working perfectly. But, when I try to upgrade to 1.2.0, elasticsearch  
> won't start:  
> [2014-05-23 02:32:53,812][INFO][node] [Larry Bodine]version  
> [1.2.0], pid[43], build[c82387f/2014-05-22T12:49:13Z]  
> [2014-05-23 02:32:53,813][INFO][node] [Larry Bodine]initializing  
> ...  
> [2014-05-23 02:32:53,853][INFO][plugins] [Larry Bodine]loaded  
> [cloud-aws, jetty, river-couchdb, lang-javascript], sites [bigdesk]  
> [2014-05-23 02:32:56,655][INFO][node] [Larry Bodine]initialized  
> [2014-05-23 02:32:56,655][INFO][node] [Larry Bodine]starting  
> ...  
> [2014-05-23 02:32:56,800][INFO][transport] [Larry Bodine]bound\_address  
> {inet[/0:0:0:0:0:0:0:0:9300]}, publish\_address {inet[/172.17.0.2:9300]}  
> [2014-05-23 02:32:59,846][INFO][cluster.service] [Larry Bodine]  
> new\_master [Larry  
> Bodine][QBC3No2hQYKosA-cz9Pfog][7c414f6cd187][inet[/172.17.0.2:9300]],  
> reason: zen-disco-join (elected\_as\_master)  
> [2014-05-23 02:32:59,895][INFO][discovery] [Larry Bodine]  
> es-cluster/QBC3No2hQYKosA-cz9Pfog  
> [2014-05-23 02:32:59,939][INFO][gateway] [Larry Bodine]recovered  
> [0] indices into cluster\_state  
> {1.2.0}: Startup Failed ...
> 
> - IncompatibleClassChangeError[Implementing class]
> 
> Any idea of what's happening?
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> To view this discussion on the web visit  
> [https://groups.google.com/d/msgid/elasticsearch/91b5acc5-28bc-470c-badf-0729b8250235%40googlegroups.com](https://groups.google.com/d/msgid/elasticsearch/91b5acc5-28bc-470c-badf-0729b8250235%40googlegroups.com)[https://groups.google.com/d/msgid/elasticsearch/91b5acc5-28bc-470c-badf-0729b8250235%40googlegroups.com?utm\_medium=email&utm\_source=footer](https://groups.google.com/d/msgid/elasticsearch/91b5acc5-28bc-470c-badf-0729b8250235%40googlegroups.com?utm_medium=email&utm_source=footer)  
> .  
> For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
To view this discussion on the web visit [https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQApagKyCQg-CDh25OEb9JKBGHrTZtpVjZndteevAyZ0vg%40mail.gmail.com](https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQApagKyCQg-CDh25OEb9JKBGHrTZtpVjZndteevAyZ0vg%40mail.gmail.com).  
For more options, visit [https://groups.google.com/d/optout](https://groups.google.com/d/optout).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 1:27am UTC](https://discuss.elastic.co/t/incompatibleclasschangeerror-implementing-class/17684/3 "2017-07-06T01:27:21Z")

</div>


