# Inconsistent "Error in visualization: Request Entity Too Large"

**URL:** <https://discuss.elastic.co/t/inconsistent-error-in-visualization-request-entity-too-large/188353>\
**Category:** Kibana\
**Created:** [July 1, 2019, 3:17pm UTC](https://discuss.elastic.co/t/inconsistent-error-in-visualization-request-entity-too-large/188353 "2019-07-01T15:17:36Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ebalmeida](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ebalmeida/32/47103_2.png) [@ebalmeida](https://discuss.elastic.co/u/ebalmeida)\
**Post date:** [July 1, 2019, 3:17pm UTC](https://discuss.elastic.co/t/inconsistent-error-in-visualization-request-entity-too-large/188353/1 "2019-07-01T15:17:36Z")

</div>

Hi guys,

I have developed a kibana dasboard for a customer and it's deployed on a private cloud which is neither in my environment or the customer's. During development I got a few of the aforementioned errors so I chopped one dashboard in two and it worked fine. Still works fine on my environment, but in the customer's environment it throws the error several times every time they open one of the dashboards. Any one dealt with a similar issue before?

Thanks in advance!

---

<div class="post-metadata">

**Author:** ![Larry\_Gregory](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/larry_gregory/32/34969_2.png) [@Larry\_Gregory](https://discuss.elastic.co/u/Larry_Gregory)\
**Post date:** [July 1, 2019, 3:42pm UTC](https://discuss.elastic.co/t/inconsistent-error-in-visualization-request-entity-too-large/188353/2 "2019-07-01T15:42:20Z")

</div>

Hey @ebalmeida,

Do you happen to have a reverse proxy (such as nginx or apache) in front of Kibana? If so, that could be rejecting the request if it's not properly configured.

If that's not the issue, you could try setting `server.maxPayloadBytes` to a larger value in your `kibana.yml` (the default value is **1048576** ). Settings here: [https://www.elastic.co/guide/en/kibana/current/settings.html](https://www.elastic.co/guide/en/kibana/current/settings.html)

---

<div class="post-metadata">

**Author:** ![ebalmeida](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ebalmeida/32/47103_2.png) [@ebalmeida](https://discuss.elastic.co/u/ebalmeida)\
**Post date:** [July 10, 2019, 6:46pm UTC](https://discuss.elastic.co/t/inconsistent-error-in-visualization-request-entity-too-large/188353/3 "2019-07-10T18:46:13Z")

</div>

Seems to have worked (the maxPayloadBytes solution). Thanks a lot

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 7, 2019, 6:46pm UTC](https://discuss.elastic.co/t/inconsistent-error-in-visualization-request-entity-too-large/188353/4 "2019-08-07T18:46:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
