# Incorrect information in logs

**URL:** <https://discuss.elastic.co/t/incorrect-information-in-logs/145348>\
**Category:** Elasticsearch\
**Created:** [August 21, 2018, 9:49am UTC](https://discuss.elastic.co/t/incorrect-information-in-logs/145348 "2018-08-21T09:49:04Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![pavel-sbor](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pavel-sbor/32/34080_2.png) [@pavel-sbor](https://discuss.elastic.co/u/pavel-sbor)\
**Post date:** [August 21, 2018, 9:49am UTC](https://discuss.elastic.co/t/incorrect-information-in-logs/145348/1 "2018-08-21T09:49:04Z")

</div>

Hi

I've got this message in logs of ES instance (it's part of a cluster, ES version is 6.2.3):

> [2018-08-20T17:58:58,581][DEBUG][o.e.a.s.TransportSearchAction] [server01(master,data)] [logstash-index-2018.08.20][10], node[bqIEf6kyRjOoPUxY7X3qjQ], [R], s[STARTED], a[id=jzpb9x1dRUijMHCuUDiEGw]: Failed to execute [SearchRequest{searchType=QUERY\_THEN\_FETCH, indices=[_logstash-_-2018.08.20], indicesOptions=IndicesOptions[id=39, ignore\_unavailable=true, allow\_no\_indices=true, expand\_wildcards\_open=true, expand\_wildcards\_closed=false, allow\_aliases\_to\_multiple\_indices=true, forbid\_closed\_indices=true, ignore\_aliases=false], types=, routing='null', preference='null', requestCache=null, scroll=null, maxConcurrentShardRequests=75, batchedReduceSize=512, preFilterShardSize=8, source={"size":0,"query":{"bool":{"filter":[{"range":{"@timestamp":{"from":"1534775321018","to":"1534777121018","include\_lower":true,"include\_upper":true,"format":"epoch\_millis","boost":1.0}}},{"query\_string":{"query":"\<SOME\_QUERY\>","fields":,"type":"best\_fields","default\_operator":"or","max\_determinized\_states":10000,"enable\_position\_increments":true,"fuzziness":"AUTO","fuzzy\_prefix\_length":0,"fuzzy\_max\_expansions":50,"phrase\_slop":0,"analyze\_wildcard":true,"escape":false,"auto\_generate\_synonyms\_phrase\_query":true,"fuzzy\_transpositions":true,"boost":1.0}}],"adjust\_pure\_negative":true,"boost":1.0}},"aggregations":{"2":{"date\_histogram":{"field":"@timestamp","format":"epoch\_millis","interval":"1m","offset":0,"order":{"\_key":"asc"},"keyed":false,"min\_doc\_count":0,"extended\_bounds":{"min":"1534775321018","max":"1534777121018"}}}}}}] lastShard [true]  
> org.elasticsearch.transport.RemoteTransportException: [server02(master,data)][\<SOME\_IP\>:9300][indices:data/read/search[phase/query]]  
> Caused by: org.elasticsearch.common.util.concurrent.EsRejectedExecutionException: rejected execution of org.elasticsearch.common.util.concurrent.TimedRunnable@19961b1c on QueueResizingEsThreadPoolExecutor[name = server02(master,data)/search, queue capacity = 1000, min queue capacity = 1000, max queue capacity = 1000, frame size = 2000, targeted response rate = 1s, task execution EWMA = 501.5ms, adjustment amount = 50, org.elasticsearch.common.util.concurrent.QueueResizingEsThreadPoolExecutor@32017069[Running, pool size = 13, active threads = 13, queued tasks = 1000, completed tasks = 36101129]]

As I understand, it says that there is filled search queue on node server02, so search query was rejected.  
According to this log, search queue capacity is 1000:

> queue capacity = 1000, min queue capacity = 1000, max queue capacity = 1000

But I have such options in config files on both ES servers:

> thread\_pool.bulk.queue\_size: 10000  
> thread\_pool.search.queue\_size: 20000

GET /\_cat/thread\_pool says that these options are applied.

In my opinion it's logging error. It should be fixed, because it's misleading and makes problem investigations more difficult.

---

<div class="post-metadata">

**Author:** ![max583](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/max583/32/33765_2.png) [@max583](https://discuss.elastic.co/u/max583)\
**Post date:** [August 24, 2018, 11:32am UTC](https://discuss.elastic.co/t/incorrect-information-in-logs/145348/2 "2018-08-24T11:32:11Z")

</div>

I have the same problem. And many search rejects. Is there a way to solve problem by configuring?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 21, 2018, 11:32am UTC](https://discuss.elastic.co/t/incorrect-information-in-logs/145348/3 "2018-09-21T11:32:11Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
