# Index data from MSSQL server to Elasticsearch using Logstash as nested documents

**URL:** <https://discuss.elastic.co/t/index-data-from-mssql-server-to-elasticsearch-using-logstash-as-nested-documents/217179>\
**Category:** Logstash\
**Created:** [January 30, 2020, 12:33pm UTC](https://discuss.elastic.co/t/index-data-from-mssql-server-to-elasticsearch-using-logstash-as-nested-documents/217179 "2020-01-30T12:33:00Z")\
**Posts on this page:** 1\
**Showing post:** 5

<div class="post-metadata">

**Author:** ![Mohan\_vel](https://avatars.discourse-cdn.com/v4/letter/m/49beb7/32.png) [@Mohan\_vel](https://discuss.elastic.co/u/Mohan_vel)\
**Post date:** [February 1, 2020, 7:40pm UTC](https://discuss.elastic.co/t/index-data-from-mssql-server-to-elasticsearch-using-logstash-as-nested-documents/217179/5 "2020-02-01T19:40:17Z")

</div>

Thanks Archelle. I have tried the above code but now i am getting error related to driver so the error is quite different so i have opened another topic i have pasted the link below for your reference

[invalid setting jdbc\_streaming](https://discuss.elastic.co/t/invalid-setting-for-jdbc-streaming-filter-plugin/217498/3)

Once the issue get resolved i will mark it as solution. As of now both topic is open. Hopefully it will be resolved. Kindly help me to close this. Thanks in advance.

---

_[View the full topic](https://discuss.elastic.co/t/index-data-from-mssql-server-to-elasticsearch-using-logstash-as-nested-documents/217179)._
