# Index management error: "Index is not the write index for alias"

**URL:** <https://discuss.elastic.co/t/index-management-error-index-is-not-the-write-index-for-alias/180894>\
**Category:** Elasticsearch\
**Tags:** ilm-index-lifecycle-management\
**Created:** [May 13, 2019, 9:22pm UTC](https://discuss.elastic.co/t/index-management-error-index-is-not-the-write-index-for-alias/180894 "2019-05-13T21:22:42Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![gbrown](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gbrown/32/34482_2.png) [@gbrown](https://discuss.elastic.co/u/gbrown)\
**Post date:** [May 28, 2019, 10:51pm UTC](https://discuss.elastic.co/t/index-management-error-index-is-not-the-write-index-for-alias/180894/3 "2019-05-28T22:51:33Z")

</div>

@John_Fredrickson is correct, this will happen if you use the Rollover API on an index which is managed by an ILM policy. Because the index isn't the write index for the `metricbeat-7.0.0` anymore, ILM can't be sure that everything is working as intended, so it takes the "safer" option and does nothing, rather than proceed to the Warm phase when that might not be what you want. John is also correct that you can set `index.lifecycle.indexing_complete` to `true` and use the [Retry API](https://www.elastic.co/guide/en/elasticsearch/reference/6.8/ilm-retry-policy.html) to allow ILM to skip rollover in this case.

I should note that you'll only have this issue on the one index that was rolled over manually, (`metricbeat-7.0.0-2019.04.26-000001` in this case), all subsequent indices should proceed through their lifecycle policy as normal, assuming the rollover is handled by ILM.

---

_[View the full topic](https://discuss.elastic.co/t/index-management-error-index-is-not-the-write-index-for-alias/180894)._
