# Index\_not\_found\_exception error

**URL:** <https://discuss.elastic.co/t/index-not-found-exception-error/321581>\
**Category:** Elasticsearch\
**Created:** [December 19, 2022, 5:11pm UTC](https://discuss.elastic.co/t/index-not-found-exception-error/321581 "2022-12-19T17:11:01Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Reg\_Dancy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/reg_dancy/32/98580_2.png) [@Reg\_Dancy](https://discuss.elastic.co/u/Reg_Dancy)\
**Post date:** [December 19, 2022, 5:11pm UTC](https://discuss.elastic.co/t/index-not-found-exception-error/321581/1 "2022-12-19T17:11:01Z")

</div>

Hello all, I'm working on removing nodes from my cluster to drain and I'm getting the errors

{"error":{"root\_cause":[{"type":"index\_not\_found\_exception","reason":"no such index and [action.auto\_create\_index] ([.monitoring-_,filebeat_]) doesn't match","index\_uuid":"_na_","index":"\_cluster"}],"type":"index\_not\_found\_exception","reason":"no such index and [action.auto\_create\_index] ([.monitoring-_,filebeat_]) doesn't match","index\_uuid":"_na_","index":"\_cluster"},"status":404}

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 19, 2022, 10:49pm UTC](https://discuss.elastic.co/t/index-not-found-exception-error/321581/2 "2022-12-19T22:49:21Z")

</div>

Welcome to our community! 😃

What command are you running to receive this error?

---

<div class="post-metadata">

**Author:** ![Reg\_Dancy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/reg_dancy/32/98580_2.png) [@Reg\_Dancy](https://discuss.elastic.co/u/Reg_Dancy)\
**Post date:** [December 21, 2022, 3:13pm UTC](https://discuss.elastic.co/t/index-not-found-exception-error/321581/3 "2022-12-21T15:13:02Z")

</div>

Hello, thanks for the welcome 🙂  
I used the following command but it turns out that I had an extra "/" in my command. I removed it and it worked.  
curl --header 'content-type: application/json' -XPUT "[http://localhost:9200/\_cluster/settings](http://localhost:9200/_cluster/settings)" -d '{"transient" :{"cluster.routing.allocation.exclude.\_ip" : "1.2.3.4"}}}'

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 18, 2023, 3:13pm UTC](https://discuss.elastic.co/t/index-not-found-exception-error/321581/4 "2023-01-18T15:13:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
