# Index pattern creation fails in 7.9.2

**URL:** <https://discuss.elastic.co/t/index-pattern-creation-fails-in-7-9-2/271367>\
**Category:** Kibana\
**Created:** [April 27, 2021, 11:48am UTC](https://discuss.elastic.co/t/index-pattern-creation-fails-in-7-9-2/271367 "2021-04-27T11:48:17Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Lieven\_Merckx](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lieven_merckx/32/35336_2.png) [@Lieven\_Merckx](https://discuss.elastic.co/u/Lieven_Merckx)\
**Post date:** [April 27, 2021, 11:48am UTC](https://discuss.elastic.co/t/index-pattern-creation-fails-in-7-9-2/271367/1 "2021-04-27T11:48:17Z")

</div>

When we installed Elastic and Kibana on ou Kubernetes environment we have the recurrent issue that on a restart the index-pattern creation fails. It's an old issue that doesn't get solved in the latest release of Elastic.  
The sequence to reproduce the issue :

- restart Elastic nodes , restart Kibana
- data is ingested into indexes
- goto index-management to create index patterns
- create index-pattern , example : apm-\*
- goto discover in Kibana =\> no index pattern found !
- restart Kibana process on Kubernetes separately , without restarting Elastic
- goto discover in Kibana =\> the previously created index is suddenly there !  
See also : [Created Index Pattern is not visible in KIbana 7.0.1](https://discuss.elastic.co/t/created-index-pattern-is-not-visible-in-kibana-7-0-1/184098)

---

<div class="post-metadata">

**Author:** ![matw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matw/32/13913_2.png) [@matw](https://discuss.elastic.co/u/matw)\
**Post date:** [April 27, 2021, 2:39pm UTC](https://discuss.elastic.co/t/index-pattern-creation-fails-in-7-9-2/271367/2 "2021-04-27T14:39:30Z")

</div>

Hi  
What Linux do you use? Is there a proxy involved?  
Thx & Best,  
Matthias

---

<div class="post-metadata">

**Author:** ![Lieven\_Merckx](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lieven_merckx/32/35336_2.png) [@Lieven\_Merckx](https://discuss.elastic.co/u/Lieven_Merckx)\
**Post date:** [April 28, 2021, 7:45am UTC](https://discuss.elastic.co/t/index-pattern-creation-fails-in-7-9-2/271367/3 "2021-04-28T07:45:25Z")

</div>

Hi Matthias,  
We use RedHat linux. There is indeed a reverse proxy involved. Not sure if this makes a difference. If the caching of the proxy would be playing a role then the restart of Kibana shouldn't make a difference ? The phenomenon only presents itself on the first index pattern created after a full restart, starting completely empty on indexes, dashboards,..

More specifically we deploy on REL-8 with docker images from Elastic which contain CentOS Linux version 7.  
Lieven

---

<div class="post-metadata">

**Author:** ![matw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/matw/32/13913_2.png) [@matw](https://discuss.elastic.co/u/matw)\
**Post date:** [April 28, 2021, 8:42am UTC](https://discuss.elastic.co/t/index-pattern-creation-fails-in-7-9-2/271367/4 "2021-04-28T08:42:36Z")

</div>

Hi  
Thanks for those details, I'm collecting evidence that there's an issue, you're not the first one reporting this. The previous reports were all using a proxy. Mind if I ask, are there any logs entries in the kibana log or in the log of your reverse proxy that could point to an issue?  
Thx!  
Matthias

---

<div class="post-metadata">

**Author:** ![Lieven\_Merckx](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/lieven_merckx/32/35336_2.png) [@Lieven\_Merckx](https://discuss.elastic.co/u/Lieven_Merckx)\
**Post date:** [April 28, 2021, 8:56am UTC](https://discuss.elastic.co/t/index-pattern-creation-fails-in-7-9-2/271367/5 "2021-04-28T08:56:07Z")

</div>

Hi,  
since it's only presenting itself at a new restart,I'll have to check the next time. Being part of a big company, we don't control the proxy ourselves. Any idea what kind of symptom we should be looking for ? My impression is that the root cause is kibana and elastic going out of sync on the list of index patterns. Checking if we have the previous logs of Kibana before restart...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 26, 2021, 8:57am UTC](https://discuss.elastic.co/t/index-pattern-creation-fails-in-7-9-2/271367/6 "2021-05-26T08:57:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
