# Index READONLY

**URL:** https://discuss.elastic.co/t/index-readonly/178802
**Category:** Elasticsearch
**Created:** [April 28, 2019, 2:21pm UTC](https://discuss.elastic.co/t/index-readonly/178802 "2019-04-28T14:21:49Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![adwaitjoshi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/adwaitjoshi/32/35098_2.png) [@adwaitjoshi](https://discuss.elastic.co/u/adwaitjoshi)
#### Post date: [April 28, 2019, 2:21pm UTC](https://discuss.elastic.co/t/index-readonly/178802/1 "2019-04-28T14:21:49Z")

</div>

I am having a weird issue where my index keeps going into a readonly status. I understand that when the disk space is low, the index does this as a safety measure. The disk was getting full up to a certain point and then we cleared a lot of things and now it has more than 1.8TB of free space, the index is still doing this! Any ideas why?

![image](https://us1.discourse-cdn.com/elastic/original/3X/a/3/a3e577be5d0d137124a8fc602f6ba73522f4ca35.jpeg)

---

<div class="post-metadata">

### Author: ![dbakti7](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dbakti7/32/42250_2.png) [@dbakti7](https://discuss.elastic.co/u/dbakti7)
#### Post date: [April 28, 2019, 2:28pm UTC](https://discuss.elastic.co/t/index-readonly/178802/2 "2019-04-28T14:28:26Z")

</div>

> <https://github.com/elastic/kibana/issues/13685#issuecomment-345859559>
>
> \<!--
> GitHub is reserved for bug reports and feature requests. The best place
> t…o ask a general question is at the Elastic Discourse forums at
> https://discuss.elastic.co. If you are in fact posting a bug report or
> a feature request, please include one and only one of the below blocks
> in your new issue.
> \--\>
> 
> \<!--
> If you are filing a bug report, please remove the below feature
> request block and provide responses for all of the below items.
> \--\>
> 
> \*\*Kibana version\*\*: 6.0.0-beta1
> 
> \*\*Elasticsearch version\*\*: 6.0.0-beta1
> 
> \*\*Server OS version\*\*: Ubuntu 16.04.2 LTS
> 
> \*\*Browser version\*\*: Chrome 60.0.3112.90
> 
> \*\*Browser OS version\*\*: Windows 10
> 
> \*\*Original install method (e.g. download page, yum, from source, etc.)\*\*: Official tar.gz packages
> 
> \*\*Description of the problem including expected versus actual behavior\*\*:
> 
> I'm running a single node Elasticsearch instance, logstash and Kibana. Everything runs on the same host in separate docker containers.
> 
> If the high disk watermark is exceeded on the ES host, the following is logged in the elasticsearch log:
> 
> \`\`\`
> \[2017-08-24T07:45:11,757\]\[INFO \]\[o.e.c.r.a.DiskThresholdMonitor\] \[CSOifAr\] rerouting shards: \[high disk watermark exceeded on one or more nodes\]
> \[2017-08-24T07:45:41,760\]\[WARN \]\[o.e.c.r.a.DiskThresholdMonitor\] \[CSOifAr\] flood stage disk watermark \[95%\] exceeded on \[CSOifArqQK-7PBZM\_keNoA\]\[CSOifAr\]\[/data/elasticsearch/nodes/0\] free: 693.8mb\[2.1%\], all indice
> s on this node will marked read-only
> \`\`\`
> 
> When this has occured, changes to the \`.kibana\` index will of course fail as the index cannot be written to. This can be observed by trying to change any setting under \_Management\_-\>\_Advanced Settings\_ where a change to i.e. \_search:queryLanguage\_ fails with the message \`Config: Error 403 Forbidden: blocked by: \[FORBIDDEN/12/index read-only / allow delete (api)\];\`
> 
> !\[index\_read\_only\](https://user-images.githubusercontent.com/133108/29657724-d598f60c-88b8-11e7-8e0c-b647dfe5c101.png)
> 
> If more disk space now is made available, ES will log that the node has gone under the high watermark:
> \`\`\`
> \[2017-08-24T07:47:11,774\]\[INFO \]\[o.e.c.r.a.DiskThresholdMonitor\] \[CSOifAr\] rerouting shards: \[one or more nodes has gone under the high or low watermark\]
> \`\`\`
> 
> One would now assume that it would be possible to make changes to Kibana settings but trying to make a settings change still fails with the error message:
> 
> \`Config: Error 403 Forbidden: blocked by: \[FORBIDDEN/12/index read-only / allow delete (api)\];\`
> 
> \*\*Steps to reproduce\*\*:
> 1. Make sure that setting changes can be performed without errors
> 2. Fill up the elasticsearch data disk so that the high disk watermark is exceeded (I used \`fallocate -l9G largefile\`)
> 3. Verify in the ES log that the high disk watermark has been exceeded and the indices has been marked read-only
> 4. Perform a setting change and verify that it fails since writes are prohibited
> 5. Resolve the high disk watermark condition (which I did with \`rm largefile\`)
> 6. Verify that the ES log states that the node has gone under the high disk watermark (and thus should be possible to write to?)
> 7. Perform a setting change and it will fail when it actually should succeed.

try this..

> curl -XPUT -H "Content-Type: application/json"  
> https://[YOUR\_ELASTICSEARCH\_ENDPOINT]:9200/\_all/\_settings -d  
> '{"index.blocks.read\_only\_allow\_delete": null}'

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 26, 2019, 2:28pm UTC](https://discuss.elastic.co/t/index-readonly/178802/3 "2019-05-26T14:28:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
