# Index Shard Gateway Recovery Exception

**URL:** <https://discuss.elastic.co/t/index-shard-gateway-recovery-exception/29422>\
**Category:** Elasticsearch\
**Created:** [September 16, 2015, 4:03pm UTC](https://discuss.elastic.co/t/index-shard-gateway-recovery-exception/29422 "2015-09-16T16:03:23Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Piyush\_Goyal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/piyush_goyal/32/8025_2.png) [@Piyush\_Goyal](https://discuss.elastic.co/u/Piyush_Goyal)\
**Post date:** [September 16, 2015, 4:03pm UTC](https://discuss.elastic.co/t/index-shard-gateway-recovery-exception/29422/1 "2015-09-16T16:03:23Z")

</div>

Hi Folks,

Unluckily the disk on which ES was stored became full and one of the three nodes got shut down. Now the cluster is not able recover one of the shard with the following exception. Looks like ES is unable to read one of the ID of the document. Can someone help on how to restore the cluster:

[2015-09-16 15:38:36,686][WARN][cluster.action.shard] [es\_prod\_cortez\_node2] [cortez][11] sending failed shard for [cortez][11], node[qnFTAqSRR4mMdPe96uUsXQ], [P], s[INITIALIZING], indexUUID [TIW3RodOR8-25fuy\_1OuXw], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[cortez][11] failed to recover shard]; nested: ElasticsearchException[failed to read [data][xkYmcWMwleg1v2prraSSUA==]]; nested: ElasticsearchIllegalArgumentException[No version type match [108]]; ]]

[2015-09-16 15:38:38,388][WARN][indices.cluster] [es\_prod\_cortez\_node2] [cortez][11] failed to start shard  
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [cortez][11] failed to recover shard  
at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:269)  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:132)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: org.elasticsearch.ElasticsearchException: failed to read [data][xkYmcWMwleg1v2prraSSUA==]  
at org.elasticsearch.index.translog.Translog$Index.readFrom(Translog.java:511)  
at org.elasticsearch.index.translog.TranslogStreams.readTranslogOperation(TranslogStreams.java:52)  
at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:241)  
... 4 more  
Caused by: org.elasticsearch.ElasticsearchIllegalArgumentException: No version type match [108]  
at org.elasticsearch.index.VersionType.fromValue(VersionType.java:307)  
at org.elasticsearch.index.translog.Translog$Index.readFrom(Translog.java:508)  
... 6 more

Regards  
Piyush

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:49pm UTC](https://discuss.elastic.co/t/index-shard-gateway-recovery-exception/29422/2 "2017-07-05T23:49:58Z")

</div>


