# IndexFormatException: ES?

**URL:** <https://discuss.elastic.co/t/indexformatexception-es/13560>\
**Category:** Elasticsearch\
**Created:** [September 11, 2013, 6:34pm UTC](https://discuss.elastic.co/t/indexformatexception-es/13560 "2013-09-11T18:34:25Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Paul\_Sanwald\_2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/paul_sanwald_2/32/881_2.png) [@Paul\_Sanwald\_2](https://discuss.elastic.co/u/Paul_Sanwald_2)\
**Post date:** [September 11, 2013, 6:34pm UTC](https://discuss.elastic.co/t/indexformatexception-es/13560/1 "2013-09-11T18:34:25Z")

</div>

Hi Everyone,  
hoping someone can help with the below exception. I've indexed a bunch  
of data using ES, with the S3 gateway (I realize this is deprecated but it  
has served us well).

I'm running ES (0.20.6) using elasticsearch-spring embedded in a war.  
Problem is, after a restart, the service hangs on startup. Can anyone shed  
any light on why this exception might be occurring?

18:15:20.217 [DEBUG] o.e.cluster.service - [Mary Walker] processing  
[shard-failed ([dataset\_metadata][3], node[lzJ-UcPdTvujT9CX0KDKQg], [P],  
s[INITIALIZING]), reason [Failed to start shard, message  
[IndexShardGatewayRecoveryException[[dataset\_metadata][3] failed to recover  
commit\_point [commit-4]/[4]]; nested:  
EngineCreationFailureException[[dataset\_metadata][3] failed to create  
engine]; nested: IndexFormatTooOldException[Format version is not supported  
(resource:  
ChecksumIndexInput(NIOFSIndexInput(path="/usr/share/tomcat7/data/mydata/nodes/0/indices/dataset\_metadata/3/index/segments\_1"))):  
1071082519 (needs to be between -1 and -11). This version of Lucene only  
supports indexes created with release 1.9 and later.]; ]]]: done applying  
updated cluster\_state

I tried upgrading ES versions, but no dice.

Thanks in advance,

--paul

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![mvg](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mvg/32/98890_2.png) [@mvg](https://discuss.elastic.co/u/mvg)\
**Post date:** [September 12, 2013, 8:16am UTC](https://discuss.elastic.co/t/indexformatexception-es/13560/2 "2013-09-12T08:16:03Z")

</div>

Did another node with a different ES version opened the data directory? It  
could be that the index index got corrupted. Are all the shards failing?

On 11 September 2013 20:34, Paul Sanwald [paul@redowlanalytics.com](mailto:paul@redowlanalytics.com) wrote:

> Hi Everyone,  
> hoping someone can help with the below exception. I've indexed a bunch  
> of data using ES, with the S3 gateway (I realize this is deprecated but it  
> has served us well).
> 
> I'm running ES (0.20.6) using elasticsearch-spring embedded in a war.  
> Problem is, after a restart, the service hangs on startup. Can anyone shed  
> any light on why this exception might be occurring?
> 
> 18:15:20.217 [DEBUG] o.e.cluster.service - [Mary Walker] processing  
> [shard-failed ([dataset\_metadata][3], node[lzJ-UcPdTvujT9CX0KDKQg], [P],  
> s[INITIALIZING]), reason [Failed to start shard, message  
> [IndexShardGatewayRecoveryException[[dataset\_metadata][3] failed to recover  
> commit\_point [commit-4]/[4]]; nested:  
> EngineCreationFailureException[[dataset\_metadata][3] failed to create  
> engine]; nested: IndexFormatTooOldException[Format version is not supported  
> (resource:  
> ChecksumIndexInput(NIOFSIndexInput(path="/usr/share/tomcat7/data/mydata/nodes/0/indices/dataset\_metadata/3/index/segments\_1"))):  
> 1071082519 (needs to be between -1 and -11). This version of Lucene only  
> supports indexes created with release 1.9 and later.]; ]]]: done applying  
> updated cluster\_state
> 
> I tried upgrading ES versions, but no dice.
> 
> Thanks in advance,
> 
> --paul
> 
> --  
> You received this message because you are subscribed to the Google Groups  
> "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an  
> email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
Met vriendelijke groet,

Martijn van Groningen

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![Paul\_Sanwald\_2](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/paul_sanwald_2/32/881_2.png) [@Paul\_Sanwald\_2](https://discuss.elastic.co/u/Paul_Sanwald_2)\
**Post date:** [September 12, 2013, 12:58pm UTC](https://discuss.elastic.co/t/indexformatexception-es/13560/3 "2013-09-12T12:58:29Z")

</div>

Martijn - thanks for the reply.

We figured this out late yesterday, this was an interesting one: The  
problem was that the ec2 instance that was firing up elasticsearch is  
(since I'm using the s3 gateway) loading data from S3 into its local  
storage. This was taking a long time, and as a result, the application  
context we were using was timing out the ES initialization before the load  
could finish.

This resulted in a corrupt local index, which resulted in the above  
exception. Hopefully this post will save someone some time at some point in  
the future.

Next step for me: move off of S3 gateway, as it's deprecated!

--paul

On Thu, Sep 12, 2013 at 4:16 AM, Martijn v Groningen \<  
[martijn.v.groningen@gmail.com](mailto:martijn.v.groningen@gmail.com)\> wrote:

> Did another node with a different ES version opened the data directory? It  
> could be that the index index got corrupted. Are all the shards failing?
> 
> On 11 September 2013 20:34, Paul Sanwald [paul@redowlanalytics.com](mailto:paul@redowlanalytics.com) wrote:
> 
> > Hi Everyone,  
> > hoping someone can help with the below exception. I've indexed a bunch  
> > of data using ES, with the S3 gateway (I realize this is deprecated but it  
> > has served us well).
> > 
> > I'm running ES (0.20.6) using elasticsearch-spring embedded in a war.  
> > Problem is, after a restart, the service hangs on startup. Can anyone shed  
> > any light on why this exception might be occurring?
> > 
> > 18:15:20.217 [DEBUG] o.e.cluster.service - [Mary Walker] processing  
> > [shard-failed ([dataset\_metadata][3], node[lzJ-UcPdTvujT9CX0KDKQg], [P],  
> > s[INITIALIZING]), reason [Failed to start shard, message  
> > [IndexShardGatewayRecoveryException[[dataset\_metadata][3] failed to recover  
> > commit\_point [commit-4]/[4]]; nested:  
> > EngineCreationFailureException[[dataset\_metadata][3] failed to create  
> > engine]; nested: IndexFormatTooOldException[Format version is not supported  
> > (resource:  
> > ChecksumIndexInput(NIOFSIndexInput(path="/usr/share/tomcat7/data/mydata/nodes/0/indices/dataset\_metadata/3/index/segments\_1"))):  
> > 1071082519 (needs to be between -1 and -11). This version of Lucene only  
> > supports indexes created with release 1.9 and later.]; ]]]: done applying  
> > updated cluster\_state
> > 
> > I tried upgrading ES versions, but no dice.
> > 
> > Thanks in advance,
> > 
> > --paul
> > 
> > --  
> > You received this message because you are subscribed to the Google Groups  
> > "elasticsearch" group.  
> > To unsubscribe from this group and stop receiving emails from it, send an  
> > email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).
> > 
> > For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).
> 
> --  
> Met vriendelijke groet,
> 
> Martijn van Groningen
> 
> --  
> You received this message because you are subscribed to a topic in the  
> Google Groups "elasticsearch" group.  
> To unsubscribe from this topic, visit  
> [https://groups.google.com/d/topic/elasticsearch/cwD-OIrXpHM/unsubscribe](https://groups.google.com/d/topic/elasticsearch/cwD-OIrXpHM/unsubscribe).  
> To unsubscribe from this group and all its topics, send an email to  
> [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:16am UTC](https://discuss.elastic.co/t/indexformatexception-es/13560/4 "2017-07-06T02:16:55Z")

</div>


