# Indexing fails with transport error

**URL:** <https://discuss.elastic.co/t/indexing-fails-with-transport-error/54846>\
**Category:** Elasticsearch\
**Created:** [July 6, 2016, 3:58pm UTC](https://discuss.elastic.co/t/indexing-fails-with-transport-error/54846 "2016-07-06T15:58:08Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![HSA](https://avatars.discourse-cdn.com/v4/letter/h/71e660/32.png) [@HSA](https://discuss.elastic.co/u/HSA)\
**Post date:** [July 6, 2016, 3:58pm UTC](https://discuss.elastic.co/t/indexing-fails-with-transport-error/54846/1 "2016-07-06T15:58:09Z")

</div>

Hi I`m new to search and indexing.

I am using nutch2.3.1/hbase1.1.5/elastic2.3.0 stack installed in an AWS m4.xlarge instance. Everything running in single-node configurations.

After crawling a website, I can see the content in HBase, but when I try to index that using  
`./nutch index elasticsearch -all`

I get following error in the elasticsearch

```
[2016-07-06 15:46:01,487][WARN][transport.netty] [Mordred] exception caught on transport layer [[id: 0xc3ad0eda, /127.0.0.1:42834 => /127.0.0.1:9300]], closing connection
java.lang.IllegalStateException: Message not fully read (request) for requestId [0], action [cluster/nodes/info], readerIndex [39] vs expected [57]; resetting
	at org.elasticsearch.transport.netty.MessageChannelHandler.messageReceived(MessageChannelHandler.java:120)
	at org.jboss.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:70)
	at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)
	at org.jboss.netty.channel.DefaultChannelPipeline$DefaultChannelHandlerContext.sendUpstream(DefaultChannelPipeline.java:791)
	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:296)
	at org.jboss.netty.handler.codec.frame.FrameDecoder.unfoldAndFireMessageReceived(FrameDecoder.java:462)
	at org.jboss.netty.handler.codec.frame.FrameDecoder.callDecode(FrameDecoder.java:443)
	at org.jboss.netty.handler.codec.frame.FrameDecoder.messageReceived(FrameDecoder.java:303)
	at org.jboss.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:70)
	at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)
	at org.jboss.netty.channel.DefaultChannelPipeline$DefaultChannelHandlerContext.sendUpstream(DefaultChannelPipeline.java:791)
	at org.elasticsearch.common.netty.OpenChannelsHandler.handleUpstream(OpenChannelsHandler.java:75)
	at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:564)
	at org.jboss.netty.channel.DefaultChannelPipeline.sendUpstream(DefaultChannelPipeline.java:559)
	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:268)
	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:255)
	at org.jboss.netty.channel.socket.nio.NioWorker.read(NioWorker.java:88)
	at org.jboss.netty.channel.socket.nio.AbstractNioWorker.process(AbstractNioWorker.java:108)
	at org.jboss.netty.channel.socket.nio.AbstractNioSelector.run(AbstractNioSelector.java:337)
	at org.jboss.netty.channel.socket.nio.AbstractNioWorker.run(AbstractNioWorker.java:89)
	at org.jboss.netty.channel.socket.nio.NioWorker.run(NioWorker.java:178)
	at org.jboss.netty.util.ThreadRenamingRunnable.run(ThreadRenamingRunnable.java:108)
	at org.jboss.netty.util.internal.DeadLockProofWorker$1.run(DeadLockProofWorker.java:42)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

```

I am not able to proceed as I cannot find any resource that would explain how to resolve the issue. 😓

Any help is much appreciated.

Thanks in advance 👍

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [July 6, 2016, 4:48pm UTC](https://discuss.elastic.co/t/indexing-fails-with-transport-error/54846/2 "2016-07-06T16:48:41Z")

</div>

A guess is that Nutch is sending data using the Transport protocol (port 9300) using a format elasticsearch does not understand.

Either this version of Nutch is not compatible with this elasticsearch version.  
Or Nutch should be configured to use REST port (9200)?

I don't know nutch so can't really tell more.

---

<div class="post-metadata">

**Author:** ![HSA](https://avatars.discourse-cdn.com/v4/letter/h/71e660/32.png) [@HSA](https://discuss.elastic.co/u/HSA)\
**Post date:** [July 6, 2016, 7:02pm UTC](https://discuss.elastic.co/t/indexing-fails-with-transport-error/54846/3 "2016-07-06T19:02:01Z")

</div>

Thanks very much, It was mu guess as well, because I am using the latest nutch and hbase version. So the elasticsearch integration might not be up-to-date,

Nutch is using the correct port it seems. checked the config files

I am going to try a stack with more older versions, to see whether I can running, and then build on from there.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 10:37pm UTC](https://discuss.elastic.co/t/indexing-fails-with-transport-error/54846/4 "2017-07-05T22:37:34Z")

</div>


