# IndexShardGatewayRecoveryException

**URL:** <https://discuss.elastic.co/t/indexshardgatewayrecoveryexception/13317>\
**Category:** Elasticsearch\
**Created:** [August 24, 2013, 12:10pm UTC](https://discuss.elastic.co/t/indexshardgatewayrecoveryexception/13317 "2013-08-24T12:10:21Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Benedict\_Liang](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/benedict_liang/32/2154_2.png) [@Benedict\_Liang](https://discuss.elastic.co/u/Benedict_Liang)\
**Post date:** [August 24, 2013, 12:10pm UTC](https://discuss.elastic.co/t/indexshardgatewayrecoveryexception/13317/1 "2013-08-24T12:10:21Z")

</div>

I have followed the instructions stated in the this wiki[https://github.com/richardwilly98/elasticsearch-river-mongodb/wiki](https://github.com/richardwilly98/elasticsearch-river-mongodb/wiki),  
and the versions are as follows:  
ES: 0.90.2  
Mongodb: 2.4.5  
River: 1.6.11

ES was set up using Homebrew.

The error log:

[2013-08-24 17:21:29,791][INFO][node] [Plunderer] {0.90.2}[6098]: initializing ...[2013-08-24 17:21:29,825][INFO][plugins] [Plunderer] loaded [river-mongodb, mapper-attachments], sites [][2013-08-24 17:21:31,603][INFO][node] [Plunderer] {0.90.2}[6098]: initialized[2013-08-24 17:21:31,603][INFO][node] [Plunderer] {0.90.2}[6098]: starting ...[2013-08-24 17:21:31,678][INFO][transport] [Plunderer] bound\_address {inet[/127.0.0.1:9300]}, publish\_address {inet[/127.0.0.1:9300]}[2013-08-24 17:21:34,729][INFO][cluster.service] [Plunderer] new\_master [Plunderer][gejapqNySeeG47zxjVlI\_w][inet[/127.0.0.1:9300]], reason: zen-disco-join (elected\_as\_master)[2013-08-24 17:21:34,757][INFO][discovery] [Plunderer] elasticsearch\_benedict/gejapqNySeeG47zxjVlI\_w[2013-08-24 17:21:34,768][INFO][http] [Plunderer] bound\_address {inet[/127.0.0.1:9200]}, publish\_address {inet[/127.0.0.1:9200]}[2013-08-24 17:21:34,769][INFO][node] [Plunderer] {0.90.2}[6098]: started[2013-08-24 17:21:35,202][INFO][gateway] [Plunderer] recovered [2] indices into cluster\_state[2013-08-24 17:21:35,364][WARN][indices.memory] [Plunderer] failed to set shard [\_river][0] index buffer to [20.3mb][2013-08-24 17:21:35,364][WARN][indices.cluster] [Plunderer] [\_river][0] failed to start shard  
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [\_river][0] failed recovery  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:225)  
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)  
at java.lang.Thread.run(Thread.java:680)  
Caused by: org.elasticsearch.index.engine.EngineCreationFailureException: [\_river][0] failed to open reader on writer  
at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:291)  
at org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryPrepareForTranslog(InternalIndexShard.java:571)  
at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:200)  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:174)  
... 3 more  
Caused by: org.apache.lucene.index.IndexFormatTooNewException: Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)  
at org.apache.lucene.codecs.CodecUtil.checkHeaderNoMagic(CodecUtil.java:148)  
at org.apache.lucene.codecs.CodecUtil.checkHeader(CodecUtil.java:130)  
at org.apache.lucene.codecs.lucene42.Lucene42DocValuesProducer.(Lucene42DocValuesProducer.java:84)  
at org.apache.lucene.codecs.lucene42.Lucene42NormsFormat.normsProducer(Lucene42NormsFormat.java:57)  
at org.apache.lucene.index.SegmentCoreReaders.(SegmentCoreReaders.java:141)  
at org.apache.lucene.index.SegmentReader.(SegmentReader.java:56)  
at org.apache.lucene.index.ReadersAndLiveDocs.getReader(ReadersAndLiveDocs.java:121)  
at org.apache.lucene.index.ReadersAndLiveDocs.getReadOnlyClone(ReadersAndLiveDocs.java:218)  
at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:100)  
at org.apache.lucene.index.IndexWriter.getReader(IndexWriter.java:377)  
at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:111)  
at org.apache.lucene.search.SearcherManager.(SearcherManager.java:89)  
at org.elasticsearch.index.engine.robin.RobinEngine.buildSearchManager(RobinEngine.java:1427)  
at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:275)  
... 6 more[2013-08-24 17:21:35,369][WARN][cluster.action.shard] [Plunderer] sending failed shard for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]][2013-08-24 17:21:35,369][WARN][cluster.action.shard] [Plunderer] received shard failed for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]][2013-08-24 17:21:35,487][WARN][indices.cluster] [Plunderer] [\_river][0] failed to start shard  
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [\_river][0] failed recovery  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:225)  
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)  
at java.lang.Thread.run(Thread.java:680)  
Caused by: org.elasticsearch.index.engine.EngineCreationFailureException: [\_river][0] failed to open reader on writer  
at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:291)  
at org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryPrepareForTranslog(InternalIndexShard.java:571)  
at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:200)  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:174)  
... 3 more  
Caused by: org.apache.lucene.index.IndexFormatTooNewException: Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)  
at org.apache.lucene.codecs.CodecUtil.checkHeaderNoMagic(CodecUtil.java:148)  
at org.apache.lucene.codecs.CodecUtil.checkHeader(CodecUtil.java:130)  
at org.apache.lucene.codecs.lucene42.Lucene42DocValuesProducer.(Lucene42DocValuesProducer.java:84)  
at org.apache.lucene.codecs.lucene42.Lucene42NormsFormat.normsProducer(Lucene42NormsFormat.java:57)  
at org.apache.lucene.index.SegmentCoreReaders.(SegmentCoreReaders.java:141)  
at org.apache.lucene.index.SegmentReader.(SegmentReader.java:56)  
at org.apache.lucene.index.ReadersAndLiveDocs.getReader(ReadersAndLiveDocs.java:121)  
at org.apache.lucene.index.ReadersAndLiveDocs.getReadOnlyClone(ReadersAndLiveDocs.java:218)  
at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:100)  
at org.apache.lucene.index.IndexWriter.getReader(IndexWriter.java:377)  
at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:111)  
at org.apache.lucene.search.SearcherManager.(SearcherManager.java:89)  
at org.elasticsearch.index.engine.robin.RobinEngine.buildSearchManager(RobinEngine.java:1427)  
at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:275)  
... 6 more[2013-08-24 17:21:35,490][WARN][cluster.action.shard] [Plunderer] sending failed shard for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]][2013-08-24 17:21:35,490][WARN][cluster.action.shard] [Plunderer] received shard failed for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]]

The replicaSet config:

{  
"\_id" : "rs0",  
"version" : 1,  
"members" : [  
{  
"\_id" : 0,  
"host" : "localhost:27017"  
}  
]}

Could someone help me out?

Thank you,  
Ben

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![ppearcy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ppearcy/32/980_2.png) [@ppearcy](https://discuss.elastic.co/u/ppearcy)\
**Post date:** [August 27, 2013, 4:01am UTC](https://discuss.elastic.co/t/indexshardgatewayrecoveryexception/13317/2 "2013-08-27T04:01:50Z")

</div>

Hard to tell, but my best guess would be your system ran out of a critical  
resource (disk, file discriptors, ram) and you got corruption.

On Saturday, August 24, 2013 6:10:21 AM UTC-6, Benedict Liang wrote:

> I have followed the instructions stated in the this wiki[https://github.com/richardwilly98/elasticsearch-river-mongodb/wiki](https://github.com/richardwilly98/elasticsearch-river-mongodb/wiki),  
> and the versions are as follows:  
> ES: 0.90.2  
> Mongodb: 2.4.5  
> River: 1.6.11
> 
> ES was set up using Homebrew.
> 
> The error log:
> 
> [2013-08-24 17:21:29,791][INFO][node] [Plunderer] {0.90.2}[6098]: initializing ...[2013-08-24 17:21:29,825][INFO][plugins] [Plunderer] loaded [river-mongodb, mapper-attachments], sites [2013-08-24 17:21:31,603][INFO][node] [Plunderer] {0.90.2}[6098]: initialized[2013-08-24 17:21:31,603][INFO][node] [Plunderer] {0.90.2}[6098]: starting ...[2013-08-24 17:21:31,678][INFO][transport] [Plunderer] bound\_address {inet[/127.0.0.1:9300]}, publish\_address {inet[/127.0.0.1:9300]}[2013-08-24 17:21:34,729][INFO][cluster.service] [Plunderer] new\_master [Plunderer][gejapqNySeeG47zxjVlI\_w][inet[/127.0.0.1:9300]], reason: zen-disco-join (elected\_as\_master)[2013-08-24 17:21:34,757][INFO][discovery] [Plunderer] elasticsearch\_benedict/gejapqNySeeG47zxjVlI\_w[2013-08-24 17:21:34,768][INFO][http] [Plunderer] bound\_address {inet[/127.0.0.1:9200]}, publish\_address {inet[/127.0.0.1:9200]}[2013-08-24 17:21:34,769][INFO][node] [Plunderer] {0.90.2}[6098]: started[2013-08-24 17:21:35,202][INFO][gateway] [Plunderer] recovered [2] indices into cluster\_state[2013-08-24 17:21:35,364][WARN][indices.memory] [Plunderer] failed to set shard [\_river][0] index buffer to [20.3mb][2013-08-24 17:21:35,364][WARN][indices.cluster] [Plunderer] [\_river][0] failed to start shard  
> org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [\_river][0] failed recovery  
> at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:225)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)  
> at java.lang.Thread.run(Thread.java:680)  
> Caused by: org.elasticsearch.index.engine.EngineCreationFailureException: [\_river][0] failed to open reader on writer  
> at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:291)  
> at org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryPrepareForTranslog(InternalIndexShard.java:571)  
> at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:200)  
> at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:174)  
> ... 3 more  
> Caused by: org.apache.lucene.index.IndexFormatTooNewException: Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)  
> at org.apache.lucene.codecs.CodecUtil.checkHeaderNoMagic(CodecUtil.java:148)  
> at org.apache.lucene.codecs.CodecUtil.checkHeader(CodecUtil.java:130)  
> at org.apache.lucene.codecs.lucene42.Lucene42DocValuesProducer.(Lucene42DocValuesProducer.java:84)  
> at org.apache.lucene.codecs.lucene42.Lucene42NormsFormat.normsProducer(Lucene42NormsFormat.java:57)  
> at org.apache.lucene.index.SegmentCoreReaders.(SegmentCoreReaders.java:141)  
> at org.apache.lucene.index.SegmentReader.(SegmentReader.java:56)  
> at org.apache.lucene.index.ReadersAndLiveDocs.getReader(ReadersAndLiveDocs.java:121)  
> at org.apache.lucene.index.ReadersAndLiveDocs.getReadOnlyClone(ReadersAndLiveDocs.java:218)  
> at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:100)  
> at org.apache.lucene.index.IndexWriter.getReader(IndexWriter.java:377)  
> at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:111)  
> at org.apache.lucene.search.SearcherManager.(SearcherManager.java:89)  
> at org.elasticsearch.index.engine.robin.RobinEngine.buildSearchManager(RobinEngine.java:1427)  
> at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:275)  
> ... 6 more[2013-08-24 17:21:35,369][WARN][cluster.action.shard] [Plunderer] sending failed shard for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]][2013-08-24 17:21:35,369][WARN][cluster.action.shard] [Plunderer] received shard failed for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]][2013-08-24 17:21:35,487][WARN][indices.cluster] [Plunderer] [\_river][0] failed to start shard  
> org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [\_river][0] failed recovery  
> at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:225)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)  
> at java.lang.Thread.run(Thread.java:680)  
> Caused by: org.elasticsearch.index.engine.EngineCreationFailureException: [\_river][0] failed to open reader on writer  
> at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:291)  
> at org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryPrepareForTranslog(InternalIndexShard.java:571)  
> at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:200)  
> at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:174)  
> ... 3 more  
> Caused by: org.apache.lucene.index.IndexFormatTooNewException: Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)  
> at org.apache.lucene.codecs.CodecUtil.checkHeaderNoMagic(CodecUtil.java:148)  
> at org.apache.lucene.codecs.CodecUtil.checkHeader(CodecUtil.java:130)  
> at org.apache.lucene.codecs.lucene42.Lucene42DocValuesProducer.(Lucene42DocValuesProducer.java:84)  
> at org.apache.lucene.codecs.lucene42.Lucene42NormsFormat.normsProducer(Lucene42NormsFormat.java:57)  
> at org.apache.lucene.index.SegmentCoreReaders.(SegmentCoreReaders.java:141)  
> at org.apache.lucene.index.SegmentReader.(SegmentReader.java:56)  
> at org.apache.lucene.index.ReadersAndLiveDocs.getReader(ReadersAndLiveDocs.java:121)  
> at org.apache.lucene.index.ReadersAndLiveDocs.getReadOnlyClone(ReadersAndLiveDocs.java:218)  
> at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:100)  
> at org.apache.lucene.index.IndexWriter.getReader(IndexWriter.java:377)  
> at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:111)  
> at org.apache.lucene.search.SearcherManager.(SearcherManager.java:89)  
> at org.elasticsearch.index.engine.robin.RobinEngine.buildSearchManager(RobinEngine.java:1427)  
> at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:275)  
> ... 6 more[2013-08-24 17:21:35,490][WARN][cluster.action.shard] [Plunderer] sending failed shard for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]][2013-08-24 17:21:35,490][WARN][cluster.action.shard] [Plunderer] received shard failed for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]]
> 
> The replicaSet config:
> 
> {  
> "\_id" : "rs0",  
> "version" : 1,  
> "members" : [  
> {  
> "\_id" : 0,  
> "host" : "localhost:27017"  
> }  
> ]}
> 
> Could someone help me out?
> 
> Thank you,  
> Ben

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![Boaz\_Leskes](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/boaz_leskes/32/723_2.png) [@Boaz\_Leskes](https://discuss.elastic.co/u/Boaz_Leskes)\
**Post date:** [August 28, 2013, 8:10am UTC](https://discuss.elastic.co/t/indexshardgatewayrecoveryexception/13317/3 "2013-08-28T08:10:58Z")

</div>

Hi,

That error occurs when a lucene index is opened with an older version than  
the one that created it. In this case it looks like the lucene index was  
created with lucene 4.4 which was shipped with elasticsearch v0.90.3 .  
Elasticsearch v0.90.2 was running on lucene 4.3.1.

Can it be that you first installed 0.90.3 and then downgraded to version  
0.90.2 of ES?

Cheers,  
Boaz

On Saturday, August 24, 2013 2:10:21 PM UTC+2, Benedict Liang wrote:

> I have followed the instructions stated in the this wiki[https://github.com/richardwilly98/elasticsearch-river-mongodb/wiki](https://github.com/richardwilly98/elasticsearch-river-mongodb/wiki),  
> and the versions are as follows:  
> ES: 0.90.2  
> Mongodb: 2.4.5  
> River: 1.6.11
> 
> ES was set up using Homebrew.
> 
> The error log:
> 
> [2013-08-24 17:21:29,791][INFO][node] [Plunderer] {0.90.2}[6098]: initializing ...[2013-08-24 17:21:29,825][INFO][plugins] [Plunderer] loaded [river-mongodb, mapper-attachments], sites [2013-08-24 17:21:31,603][INFO][node] [Plunderer] {0.90.2}[6098]: initialized[2013-08-24 17:21:31,603][INFO][node] [Plunderer] {0.90.2}[6098]: starting ...[2013-08-24 17:21:31,678][INFO][transport] [Plunderer] bound\_address {inet[/127.0.0.1:9300]}, publish\_address {inet[/127.0.0.1:9300]}[2013-08-24 17:21:34,729][INFO][cluster.service] [Plunderer] new\_master [Plunderer][gejapqNySeeG47zxjVlI\_w][inet[/127.0.0.1:9300]], reason: zen-disco-join (elected\_as\_master)[2013-08-24 17:21:34,757][INFO][discovery] [Plunderer] elasticsearch\_benedict/gejapqNySeeG47zxjVlI\_w[2013-08-24 17:21:34,768][INFO][http] [Plunderer] bound\_address {inet[/127.0.0.1:9200]}, publish\_address {inet[/127.0.0.1:9200]}[2013-08-24 17:21:34,769][INFO][node] [Plunderer] {0.90.2}[6098]: started[2013-08-24 17:21:35,202][INFO][gateway] [Plunderer] recovered [2] indices into cluster\_state[2013-08-24 17:21:35,364][WARN][indices.memory] [Plunderer] failed to set shard [\_river][0] index buffer to [20.3mb][2013-08-24 17:21:35,364][WARN][indices.cluster] [Plunderer] [\_river][0] failed to start shard  
> org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [\_river][0] failed recovery  
> at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:225)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)  
> at java.lang.Thread.run(Thread.java:680)  
> Caused by: org.elasticsearch.index.engine.EngineCreationFailureException: [\_river][0] failed to open reader on writer  
> at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:291)  
> at org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryPrepareForTranslog(InternalIndexShard.java:571)  
> at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:200)  
> at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:174)  
> ... 3 more  
> Caused by: org.apache.lucene.index.IndexFormatTooNewException: Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)  
> at org.apache.lucene.codecs.CodecUtil.checkHeaderNoMagic(CodecUtil.java:148)  
> at org.apache.lucene.codecs.CodecUtil.checkHeader(CodecUtil.java:130)  
> at org.apache.lucene.codecs.lucene42.Lucene42DocValuesProducer.(Lucene42DocValuesProducer.java:84)  
> at org.apache.lucene.codecs.lucene42.Lucene42NormsFormat.normsProducer(Lucene42NormsFormat.java:57)  
> at org.apache.lucene.index.SegmentCoreReaders.(SegmentCoreReaders.java:141)  
> at org.apache.lucene.index.SegmentReader.(SegmentReader.java:56)  
> at org.apache.lucene.index.ReadersAndLiveDocs.getReader(ReadersAndLiveDocs.java:121)  
> at org.apache.lucene.index.ReadersAndLiveDocs.getReadOnlyClone(ReadersAndLiveDocs.java:218)  
> at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:100)  
> at org.apache.lucene.index.IndexWriter.getReader(IndexWriter.java:377)  
> at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:111)  
> at org.apache.lucene.search.SearcherManager.(SearcherManager.java:89)  
> at org.elasticsearch.index.engine.robin.RobinEngine.buildSearchManager(RobinEngine.java:1427)  
> at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:275)  
> ... 6 more[2013-08-24 17:21:35,369][WARN][cluster.action.shard] [Plunderer] sending failed shard for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]][2013-08-24 17:21:35,369][WARN][cluster.action.shard] [Plunderer] received shard failed for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]][2013-08-24 17:21:35,487][WARN][indices.cluster] [Plunderer] [\_river][0] failed to start shard  
> org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [\_river][0] failed recovery  
> at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:225)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918)  
> at java.lang.Thread.run(Thread.java:680)  
> Caused by: org.elasticsearch.index.engine.EngineCreationFailureException: [\_river][0] failed to open reader on writer  
> at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:291)  
> at org.elasticsearch.index.shard.service.InternalIndexShard.performRecoveryPrepareForTranslog(InternalIndexShard.java:571)  
> at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:200)  
> at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:174)  
> ... 3 more  
> Caused by: org.apache.lucene.index.IndexFormatTooNewException: Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)  
> at org.apache.lucene.codecs.CodecUtil.checkHeaderNoMagic(CodecUtil.java:148)  
> at org.apache.lucene.codecs.CodecUtil.checkHeader(CodecUtil.java:130)  
> at org.apache.lucene.codecs.lucene42.Lucene42DocValuesProducer.(Lucene42DocValuesProducer.java:84)  
> at org.apache.lucene.codecs.lucene42.Lucene42NormsFormat.normsProducer(Lucene42NormsFormat.java:57)  
> at org.apache.lucene.index.SegmentCoreReaders.(SegmentCoreReaders.java:141)  
> at org.apache.lucene.index.SegmentReader.(SegmentReader.java:56)  
> at org.apache.lucene.index.ReadersAndLiveDocs.getReader(ReadersAndLiveDocs.java:121)  
> at org.apache.lucene.index.ReadersAndLiveDocs.getReadOnlyClone(ReadersAndLiveDocs.java:218)  
> at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:100)  
> at org.apache.lucene.index.IndexWriter.getReader(IndexWriter.java:377)  
> at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:111)  
> at org.apache.lucene.search.SearcherManager.(SearcherManager.java:89)  
> at org.elasticsearch.index.engine.robin.RobinEngine.buildSearchManager(RobinEngine.java:1427)  
> at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:275)  
> ... 6 more[2013-08-24 17:21:35,490][WARN][cluster.action.shard] [Plunderer] sending failed shard for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]][2013-08-24 17:21:35,490][WARN][cluster.action.shard] [Plunderer] received shard failed for [\_river][0], node[gejapqNySeeG47zxjVlI\_w], [P], s[INITIALIZING], reason [Failed to start shard, message [IndexShardGatewayRecoveryException[[\_river][0] failed recovery]; nested: EngineCreationFailureException[[\_river][0] failed to open reader on writer]; nested: IndexFormatTooNewException[Format version is not supported (resource: NIOFSIndexInput(\_2.nvm in path="/usr/local/var/elasticsearch/elasticsearch\_benedict/nodes/0/indices/\_river/0/index/\_2.cfs" slice=1014:1148)): 1 (needs to be between 0 and 0)]; ]]
> 
> The replicaSet config:
> 
> {  
> "\_id" : "rs0",  
> "version" : 1,  
> "members" : [  
> {  
> "\_id" : 0,  
> "host" : "localhost:27017"  
> }  
> ]}
> 
> Could someone help me out?
> 
> Thank you,  
> Ben

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:19am UTC](https://discuss.elastic.co/t/indexshardgatewayrecoveryexception/13317/4 "2017-07-06T02:19:21Z")

</div>


