# IndexShardMissingException and IndexMissingException

**URL:** <https://discuss.elastic.co/t/indexshardmissingexception-and-indexmissingexception/10876>\
**Category:** Elasticsearch\
**Created:** [February 25, 2013, 10:04am UTC](https://discuss.elastic.co/t/indexshardmissingexception-and-indexmissingexception/10876 "2013-02-25T10:04:25Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dong\_Aihua](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dong_aihua/32/2413_2.png) [@Dong\_Aihua](https://discuss.elastic.co/u/Dong_Aihua)\
**Post date:** [February 25, 2013, 10:04am UTC](https://discuss.elastic.co/t/indexshardmissingexception-and-indexmissingexception/10876/1 "2013-02-25T10:04:25Z")

</div>

Hi, guys:  
I created a new cluster from scratch.  
After the cluster is up,

1. If I just created a new index, I got the IndexShardMissing error:  
[2013-02-25 17:58:28,339][DEBUG][action.admin.indices.status]  
[xseed021.kdev] [2013-02-26][4], node[jqGL6hQQQiOAy8pkFS4g0A], [R],  
s[INITIALIZING]: Failed to execute  
[org.elasticsearch.action.admin.indices.status.IndicesStatusRequest@47cf9c40]  
org.elasticsearch.transport.RemoteTransportException:  
[xseed034.kdev][inet[/10.96.250.224:9300]][indices/status/s]  
Caused by: org.elasticsearch.index.IndexShardMissingException:  
[2013-02-26][4] missing  
at  
org.elasticsearch.index.service.InternalIndexService.shardSafe(InternalIndexService.java:179)  
at  
org.elasticsearch.action.admin.indices.status.TransportIndicesStatusAction.shardOperation(TransportIndicesStatusAction.java:153)  
at  
org.elasticsearch.action.admin.indices.status.TransportIndicesStatusAction.shardOperation(TransportIndicesStatusAction.java:59)  
at  
org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$ShardTransportHandler.messageReceived(TransportBroadcastOperationAction.java:398)  
at  
org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$ShardTransportHandler.messageReceived(TransportBroadcastOperationAction.java:384)  
at  
org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:268)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown  
Source)  
at java.lang.Thread.run(Unknown Source)  
This error made shard is stuck in initializing state.

2. If I inserted one log into a new index(auto create a new index), I got  
the IndexMissing error:  
[2013-02-25 18:39:42,843][DEBUG][action.admin.indices.status]  
[xseed021.kdev] [2013-01-01][1], node[jqGL6hQQQiOAy8pkFS4g0A], [P],  
s[INITIALIZING]: Failed to execute  
[org.elasticsearch.action.admin.indices.status.IndicesStatusRequest@773448aa]  
org.elasticsearch.transport.RemoteTransportException:  
[xseed034.kdev][inet[/10.96.250.224:9300]][indices/status/s]  
Caused by: org.elasticsearch.indices.IndexMissingException: [2013-01-01]  
missing  
at  
org.elasticsearch.indices.InternalIndicesService.indexServiceSafe(InternalIndicesService.java:244)  
at  
org.elasticsearch.action.admin.indices.status.TransportIndicesStatusAction.shardOperation(TransportIndicesStatusAction.java:152)  
at  
org.elasticsearch.action.admin.indices.status.TransportIndicesStatusAction.shardOperation(TransportIndicesStatusAction.java:59)  
at  
org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$ShardTransportHandler.messageReceived(TransportBroadcastOperationAction.java:398)  
at  
org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$ShardTransportHandler.messageReceived(TransportBroadcastOperationAction.java:384)  
at  
org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:268)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown  
Source)  
at java.lang.Thread.run(Unknown Source)

Does anyone know what cause these errors and how to avoid it?  
Thank you very much!

-Regards-  
-Dong Aihua-

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [February 25, 2013, 10:51am UTC](https://discuss.elastic.co/t/indexshardmissingexception-and-indexmissingexception/10876/2 "2013-02-25T10:51:50Z")

</div>

You can ignore those failures with the status API, they are not problematic (the request was sent to a node that hasn't had a chance to allocate the index / shard on its node). In general though, we highly recommend to move from the status API to use the stats API, which hold most of the info the status API has.

On Feb 25, 2013, at 11:04 AM, jackiedong [jackiedong168@gmail.com](mailto:jackiedong168@gmail.com) wrote:

> Hi, guys:  
> I created a new cluster from scratch.  
> After the cluster is up,
> 
> 1. If I just created a new index, I got the IndexShardMissing error:  
> [2013-02-25 17:58:28,339][DEBUG][action.admin.indices.status] [xseed021.kdev] [2013-02-26][4], node[jqGL6hQQQiOAy8pkFS4g0A], [R], s[INITIALIZING]: Failed to execute [org.elasticsearch.action.admin.indices.status.IndicesStatusRequest@47cf9c40]  
> org.elasticsearch.transport.RemoteTransportException: [xseed034.kdev][inet[/10.96.250.224:9300]][indices/status/s]  
> Caused by: org.elasticsearch.index.IndexShardMissingException: [2013-02-26][4] missing  
> at org.elasticsearch.index.service.InternalIndexService.shardSafe(InternalIndexService.java:179)  
> at org.elasticsearch.action.admin.indices.status.TransportIndicesStatusAction.shardOperation(TransportIndicesStatusAction.java:153)  
> at org.elasticsearch.action.admin.indices.status.TransportIndicesStatusAction.shardOperation(TransportIndicesStatusAction.java:59)  
> at org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$ShardTransportHandler.messageReceived(TransportBroadcastOperationAction.java:398)  
> at org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$ShardTransportHandler.messageReceived(TransportBroadcastOperationAction.java:384)  
> at org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:268)  
> at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)  
> at java.lang.Thread.run(Unknown Source)  
> This error made shard is stuck in initializing state.
> 
> 2. If I inserted one log into a new index(auto create a new index), I got the IndexMissing error:  
> [2013-02-25 18:39:42,843][DEBUG][action.admin.indices.status] [xseed021.kdev] [2013-01-01][1], node[jqGL6hQQQiOAy8pkFS4g0A], [P], s[INITIALIZING]: Failed to execute [org.elasticsearch.action.admin.indices.status.IndicesStatusRequest@773448aa]  
> org.elasticsearch.transport.RemoteTransportException: [xseed034.kdev][inet[/10.96.250.224:9300]][indices/status/s]  
> Caused by: org.elasticsearch.indices.IndexMissingException: [2013-01-01] missing  
> at org.elasticsearch.indices.InternalIndicesService.indexServiceSafe(InternalIndicesService.java:244)  
> at org.elasticsearch.action.admin.indices.status.TransportIndicesStatusAction.shardOperation(TransportIndicesStatusAction.java:152)  
> at org.elasticsearch.action.admin.indices.status.TransportIndicesStatusAction.shardOperation(TransportIndicesStatusAction.java:59)  
> at org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$ShardTransportHandler.messageReceived(TransportBroadcastOperationAction.java:398)  
> at org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$ShardTransportHandler.messageReceived(TransportBroadcastOperationAction.java:384)  
> at org.elasticsearch.transport.netty.MessageChannelHandler$RequestHandler.run(MessageChannelHandler.java:268)  
> at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)  
> at java.lang.Thread.run(Unknown Source)
> 
> Does anyone know what cause these errors and how to avoid it?  
> Thank you very much!
> 
> -Regards-  
> -Dong Aihua-
> 
> --  
> You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
> To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
> For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

--  
You received this message because you are subscribed to the Google Groups "elasticsearch" group.  
To unsubscribe from this group and stop receiving emails from it, send an email to [elasticsearch+unsubscribe@googlegroups.com](mailto:elasticsearch+unsubscribe@googlegroups.com).  
For more options, visit [https://groups.google.com/groups/opt\_out](https://groups.google.com/groups/opt_out).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 2:49am UTC](https://discuss.elastic.co/t/indexshardmissingexception-and-indexmissingexception/10876/3 "2017-07-06T02:49:44Z")

</div>


