# IndexShardMissingException

**URL:** https://discuss.elastic.co/t/indexshardmissingexception/14944
**Category:** Elasticsearch
**Created:** [December 19, 2013, 1:56am UTC](https://discuss.elastic.co/t/indexshardmissingexception/14944 "2013-12-19T01:56:14Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![lobster777](https://avatars.discourse-cdn.com/v4/letter/l/5f8ce5/32.png) [@lobster777](https://discuss.elastic.co/u/lobster777)
#### Post date: [December 19, 2013, 1:56am UTC](https://discuss.elastic.co/t/indexshardmissingexception/14944/1 "2013-12-19T01:56:14Z")

</div>

[2013-12-19 17:34:27,130][WARN][org.elasticsearch.cluster.service] [IndexNode] failed to apply updated cluster state:  
version [6], source [close-index [1387296000]]  
nodes:  
[IndexNode][SZ\_fDDgLQ6yuRmmZjaAMiQ][inet[/128.18.110.167:9300]], local, master  
routing\_table:  
routing\_nodes:  
-----node\_id[SZ\_fDDgLQ6yuRmmZjaAMiQ][V]  
---- unassigned

org.elasticsearch.index.IndexShardMissingException: [1387296000][0] missing  
at org.elasticsearch.index.service.InternalIndexService.shardInjectorSafe(InternalIndexService.java:296)  
at de.spinscale.elasticsearch.service.suggest.SuggestService$2.beforeIndexShardClosed(SuggestService.java:73)  
at org.elasticsearch.indices.InternalIndicesLifecycle.beforeIndexShardClosed(InternalIndicesLifecycle.java:104)  
at org.elasticsearch.index.service.InternalIndexService.removeShard(InternalIndexService.java:371)  
at org.elasticsearch.indices.cluster.IndicesClusterStateService.applyDeletedShards(IndicesClusterStateService.java:285)  
at org.elasticsearch.indices.cluster.IndicesClusterStateService.clusterChanged(IndicesClusterStateService.java:181)  
at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:395)  
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)  
at java.lang.Thread.run(Unknown Source)  
[2013-12-19 17:34:40,389][INFO][org.elasticsearch.cluster.metadata] [IndexNode] [1387296000] opening index  
[2013-12-19 17:34:40,417][WARN][org.elasticsearch.index.engine.robin] [IndexNode] [1387296000][0] shard is locked, releasing lock  
[2013-12-19 17:34:40,417][WARN][org.elasticsearch.indices.cluster] [IndexNode] [1387296000][0] failed to start shard  
org.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [1387296000][0] failed recovery  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:227)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)  
at java.lang.Thread.run(Unknown Source)  
Caused by: org.elasticsearch.index.engine.EngineCreationFailureException: [1387296000][0] failed to create engine  
at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:257)  
at org.elasticsearch.index.shard.service.InternalIndexShard.start(InternalIndexShard.java:302)  
at org.elasticsearch.index.gateway.local.LocalIndexShardGateway.recover(LocalIndexShardGateway.java:192)  
at org.elasticsearch.index.gateway.IndexShardGatewayService$1.run(IndexShardGatewayService.java:174)  
... 3 more  
Caused by: org.apache.lucene.store.LockReleaseFailedException: Cannot forcefully unlock a NativeFSLock which is held by another indexer component: D:\eSight\LogCenter\indexserver\data\IndexServer128.18.110.167\nodes\0\indices\1387296000\0\index\write.lock  
at org.apache.lucene.store.NativeFSLock.release(NativeFSLockFactory.java:295)  
at org.apache.lucene.index.IndexWriter.unlock(IndexWriter.java:4168)  
at org.elasticsearch.index.engine.robin.RobinEngine.createWriter(RobinEngine.java:1356)  
at org.elasticsearch.index.engine.robin.RobinEngine.start(RobinEngine.java:255)  
... 6 more

I'm using ES 0.90.5 , when I close Index it returns acknowledged:false,start it ,shards unassigned,then logs shows above.  
Does anyone know what cause these errors and how to avoid it?

Thank you very much!

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 6, 2017, 2:00am UTC](https://discuss.elastic.co/t/indexshardmissingexception/14944/2 "2017-07-06T02:00:19Z")

</div>


