# Indices.recovery.compress : true\] due to compression bugs - see issue #7210 for details

**URL:** <https://discuss.elastic.co/t/indices-recovery-compress-true-due-to-compression-bugs-see-issue-7210-for-details/25800>\
**Category:** Elasticsearch\
**Created:** [July 17, 2015, 12:26pm UTC](https://discuss.elastic.co/t/indices-recovery-compress-true-due-to-compression-bugs-see-issue-7210-for-details/25800 "2015-07-17T12:26:25Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![joiceedattel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joiceedattel/32/3811_2.png) [@joiceedattel](https://discuss.elastic.co/u/joiceedattel)\
**Post date:** [July 17, 2015, 12:26pm UTC](https://discuss.elastic.co/t/indices-recovery-compress-true-due-to-compression-bugs-see-issue-7210-for-details/25800/1 "2015-07-17T12:26:25Z")

</div>

Hi  
I'm running a kibana 3 with elasticsearch 1.2.1 . Just now I tried to upgrade elasticsearch to 1.6.0 after copying the indices files from old elasticsearch 1.2.1 directory and while starting 1.6, I'm getting error as follows |

###################################################

[2015-07-17 13:57:04,576][WARN][indices.cluster] [Kid Nova] [[kibana-int][3]] marking and sending shard failed due to [failed recovery]  
org.elasticsearch.indices.recovery.RecoveryFailedException: [kibana-int][3]: Recovery failed from [Andrew Gervais][hESsdZ6kRFq-feMRl2fhjw][opse01netvapp03.vorwerk.local][inet[/10.50.69.151:9300]] into [Kid Nova][skRO4QNkTESV\_6HTrlHPpw][opse01netvapp03.vorwerk.local][inet[/10.50.69.151:9305]] (unexpected error)  
at org.elasticsearch.indices.recovery.RecoveryTarget$RecoveryRunner.onFailure(RecoveryTarget.java:543)  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:41)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: org.elasticsearch.ElasticsearchIllegalStateException: Can't recovery from node [Andrew Gervais][hESsdZ6kRFq-feMRl2fhjw][opse01netvapp03.vorwerk.local][inet[/10.50.69.151:9300]] with [indices.recovery.compress : true] due to compression bugs - see issue #7210 for details  
at org.elasticsearch.indices.recovery.RecoveryTarget.doRecovery(RecoveryTarget.java:187)  
at org.elasticsearch.indices.recovery.RecoveryTarget.access$700(RecoveryTarget.java:70)  
at org.elasticsearch.indices.recovery.RecoveryTarget$RecoveryRunner.doRun(RecoveryTarget.java:561)  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:36)

#############################################

Could any please help me

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [July 18, 2015, 3:04am UTC](https://discuss.elastic.co/t/indices-recovery-compress-true-due-to-compression-bugs-see-issue-7210-for-details/25800/2 "2015-07-18T03:04:54Z")

</div>

Did you do as the log suggested, because that'll solve it 😄  
Also see [Elasticsearch starts with errors](https://discuss.elastic.co/t/elasticsearch-starts-with-errors/24451/2)

---

<div class="post-metadata">

**Author:** ![joiceedattel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joiceedattel/32/3811_2.png) [@joiceedattel](https://discuss.elastic.co/u/joiceedattel)\
**Post date:** [July 18, 2015, 5:16am UTC](https://discuss.elastic.co/t/indices-recovery-compress-true-due-to-compression-bugs-see-issue-7210-for-details/25800/3 "2015-07-18T05:16:43Z")

</div>

Dear Mark Walkom,

You are right, Thanks for the support 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 12:00am UTC](https://discuss.elastic.co/t/indices-recovery-compress-true-due-to-compression-bugs-see-issue-7210-for-details/25800/4 "2017-07-06T00:00:40Z")

</div>


